Windows 8 and 8.1 Forums


ethernet doesnt have a valid ip configaration

  1. #11


    If you have the latest driver then Avast is the most likely culprit here.

    When I see a valid IP with no connection that means something is blocking the connection.

    Does it show up as connected but your browser won't go anywhere?

      My System SpecsSystem Spec

  2. #12


    Posts : 65
    Microsoft Windows 8 Pro with Media Center 64-bit


    Quote Originally Posted by chev65 View Post
    If you have the latest driver then Avast is the most likely culprit here.

    When I see a valid IP with no connection that means something is blocking the connection.

    Does it show up as connected but your browser won't go anywhere?
    No it shows up as not connected.

    BUT I went and rechecked the drivers, and the ethernet driver had gone back to 2006, so I reinstalled the 2011 driver and restarted and it worked ok.

    Computers are strange.
      My System SpecsSystem Spec

  3. #13


    Quote Originally Posted by Dellboy7 View Post
    Quote Originally Posted by chev65 View Post
    If you have the latest driver then Avast is the most likely culprit here.

    When I see a valid IP with no connection that means something is blocking the connection.

    Does it show up as connected but your browser won't go anywhere?
    No it shows up as not connected.

    BUT I went and rechecked the drivers, and the ethernet driver had gone back to 2006, so I reinstalled the 2011 driver and restarted and it worked ok.

    Computers are strange.
    Yes it sounded like a driver issue, driver went back to 2006, now that is strange. Glad you have it working now.

    Feel free to mark as solved.
      My System SpecsSystem Spec

  4. #14


    Posts : 65
    Microsoft Windows 8 Pro with Media Center 64-bit


    Quote Originally Posted by chev65 View Post

    Feel free to mark as solved.
    I'll wait till tomorrow. Don't like to count my chickens.
      My System SpecsSystem Spec

  5. #15


    Quote Originally Posted by Dellboy7 View Post
    Quote Originally Posted by chev65 View Post

    Feel free to mark as solved.
    I'll wait till tomorrow. Don't like to count my chickens.
    Good point, this could come back to haunt you.
      My System SpecsSystem Spec

  6. #16


    Posts : 65
    Microsoft Windows 8 Pro with Media Center 64-bit


    Seems ok today

    Thanks.
      My System SpecsSystem Spec

Page 2 of 2 FirstFirst 12
ethernet doesnt have a valid ip configaration
Related Threads
I'm having an issue with ipconfig /release I have uploaded a screenshot with the error I am getting, any help appreciated
A few days ago I had to restart my PC after a game froze. When I booted up again I found I was unable to connect to the internet. Troubleshooting gave the error 'Ethernet doesn't have a valid IP configuration.' I can connect to the modem with my laptop using the same cable, so I don't think its an...
Hello, Recently I have been intermittently getting disconnected from the internet while gaming / streaming. If I ran the troubleshooter, the error that I got was "Default gateway not available". Resetting my router/modem and restarting the PC every time it happened seemed to resolve this for a...
Hi Guys, I have a problem: at every boot i get a bluescreen and the error 0xc0000098. The Boot configuration Data doesnt contain valid information for an operating system. The last time i got this error i reinstalled windows, this was last week and today i have the same error again. I tried...
Hello all, I bought a new laptiop HP 650. The wireless was working fine for couple of days until i believe it stopped working after falling into sleep mode according to the user. now, it connects to internet fine when it connects using a cable but with wifi connection, it says limited...
Hi, I downloaded and installed Windows8 RP a few days ago in one of my friends PC. (Intel i3 processor with 6 GB RAM). It installed without any problem but when I setup up internet connection (wired broadband) it crashed and restarted showing some error which couldnt be read. When i tried to...
hello....i have been using win8 for 2 weeks now and all has been great but this morn i try to go online and get the error of invalid ip config. been working on it for several hours to no avail. can anyone tell me whats going on please? actually, i restarted the network and win8 fixed...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook