I have windows 8 permission which is driving mad

I have a desktop pc and htpc and both were running W7, with both being connected to an unraid server. This worked 99% of the time but sometimes files created on the desktop pc did not have permission to be read on htpc. I therefore created a windows credential on the htpc Device = tower user name = computer/root and password=nobody, this worked OK and all was well

I have updated the htpc to W8 and found that random folders on mapped drivers linked to unraid shares were not accessible. On the advice of an unraid forum member, I run the new permission script which solved the issue. I created the same credential as before but if this setup, W8 will allow access at all to the unraid server.

However I created a new folder on a mapped drive linked to a unraid share using the desktop pc, and again found that the htpc did no have access rights.

Running the new permission script again works, but I don't want to have to do this all the time

Does anyone have permanent solution, I don't a great clue about permissions as this was never a great issue when all computers were running W7, it looks like security is more of an issue with W8?