Windows 8 and 8.1 Forums

Cannot enable wireless adapter (desktop)

  1. #1

    Posts : 2
    Windows 8 Ultimate x64

    Cannot enable wireless adapter (desktop)

    First off, hello, I finally joined the forum after using it a lot to fix problems! I cannot find a solution to this issue.

    I have an HP ENVY H8-1414 desktop.
    My internal wireless adapter is a Ralink RT3290 802.11bgn.

    When I go to the right of the screen to connect to my network, it just says no networks found. My laptops and other devices work fine though connecting to my network.

    In the control panel the Wi-Fi adapter is disabled, when I try to enable it, it says "Enabling" and then "Enabled" but remains Disabled. I also have a USB Wi-Fi adapter (Belkin) that I have tried and it recognizes it in the network adapters but still to the right, it says no networks are found. The Wi-Fi light is lit on the front of my PC.

    To get internet on my desktop, I am using Internet Connection Sharing with an ethernet cord from my laptop to the back of my HP Envy desktop. This works fine, but I'd like to not have to do that, haha.

    I tried downloading the drivers from HP's website, then uninstalling the WiFi adapter in my Device Manager (checked the box to the delete the drivers too). I ran the HP exe for the drivers and they installed them and I restarted as requested. Still nothing.

    I'm an IT student majoring in Network Systems Administration and I usually never get stumped, ever, I just solve it myself or use Google, haha.

    Properties of Wi-Fi adapter in picture. Those two unchecked boxes, I don't know what they mean (still a sophomore going for my AS lol) looked odd to me.

    I checked the Microsoft LLDP Protocol Driver box and hit okay, it didn't help. If i try to enable the other one, it tells me that I am actually disabling it?

    I'm stumped.

    Anyone have any ideas or what other info do you need?

    Thanks for reading!


    I ran a system restore to a couple days back but once it comes back to my desktop, it says the restore failed. I will try an even older system restore, if that will work. Right now I am going to boot into safe-mode with networking and see if it works, to eliminate any third-party software issues. Reporting back soon.

    UPDATE: Back from Safe-Mode land, still nothing helped, not even the Belkin USB. I know it must be something small and simple... or I hope.
    Last edited by ecw90; 17 Dec 2012 at 08:28.

      My System SpecsSystem Spec

  2. #2

    I'm not clear on this but did the current driver ever work correctly?

    Is your router set up with WPA2 security with AES encryption, have you tried updating the firmware on the router?

    Do you have any third party anti virus software installed on this system?

    Have you tried using a different driver? This one might work for you.
    Ralink 802.11 b/g/n WiFi Adapter | HP® Support
      My System SpecsSystem Spec

  3. #3

    Posts : 2
    Windows 8 Ultimate x64


    I booted to safe mode and restored to about two weeks ago to a point labeled "Windows Critical Update" and all is well. Thank you for your input though, I don't know how the problem occurred but at least its fixed for now. Creating a fresh restore point as we speak.

    That driver you linked is the one I ended up using before and there was still no go. It couldn't be my router because I have neighbor's and none of their SSIDs showed up either, but my other wireless devices worked. Weird.

    Thanks again though.
      My System SpecsSystem Spec

  4. #4

    Posts : 2,156
    Win7 Ult on DIY; Win8 Pro on MBP/Parallels; Win7 Ult on MBP/Boot Camp; Win7 Ult/Win8 Pro on HP

    Were any Windows updates undone when you did your system restore?
      My System SpecsSystem Spec

Cannot enable wireless adapter (desktop)
Related Threads
I am working on a laptop for a friend who's wireless will not enable. I was told that the issue occurred around the same time that the battery failed. I'll attempt to recall all the steps I have taken so far to attempt to resolve this. When CAT5 is unplugged, the wireless icon shows now networks...
How to Enable or Disable a Network Adapter (NIC) in Windows A network interface controller (NIC, also known as a network interface card, network adapter, LAN adapter, and by similar terms) is a hardware component that connects a computer to a computer network. You need a network adapter to...
I am using a Netgear WNDA4100 wireless adapter on my new Windows 8 desktop computer. I had previously been using the WNDA3100 and it worked flawlessly; however I found a refurbished WNDA4100 online for half the price. Up until today, the WNDA4100 had not let me down. Every website I would type...
8.1 - Wireless Adapter shuts off in Network & Sharing
Hi, After a while when i'm browsing the web etc, my wireless connection goes to Limited and there are no other wireless networks available (when there should be 10+ networks). When i disconnect that limited connection, there are suddenly no networks found and my wireless adapter disables...
wireless adapter in Network & Sharing
which wireless adapter is cheap and compatible to use on a windows 8 desktop? i have recently purchased a new windows 8 desktop but as i don't know much about desktops i thought they had built in wireless like a laptop, my computer is in my bedroom and my modem is downstairs, this is why i need...
wireless adapter in Network & Sharing
Anyone having problems connecting wireless? I have a Netgear WNA 1100 wireless adapter and when I use the push n play feature to link my router & computer it crashes my machine with a irq error.
Solved Wireless Adapter Woes in Network & Sharing
So I partitioned the hard drive on my new laptop today in order to dual boot Windows 8 with Windows 7. All is working fine, with the exception of the wireless adapter. Windows 8 does not recognize the wireless drivers, and I'm currently uncapable of hardwiring the laptop due to the location of...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook