Windows 8 and 8.1 Forums


Same connection, different speed

  1. #1


    Posts : 7
    Win 8 Pro x64

    Same connection, different speed


    My laptop is ASUS A43SD with Ethernet Atheros AR8151 PCI-E Gigabit Ethernet Controller (NDIS 6.30)
    before i got this problem, i had problem with ethernet controller detection, and it is fixed.
    but now, in same connection, my friends get speed more than i am, even tough we use same cable, same router port, the only one who get worst speed is mine.
    how can i fix it? it happens in almost every connections i tried, not only in my current connection

      My System SpecsSystem Spec

  2. #2


    Posts : 2,156
    Win7 Ult on DIY; Win8 Pro on MBP/Parallels; Win7 Ult on MBP/Boot Camp; Win7 Ult/Win8 Pro on HP


    Is everyone running Win8? Maybe you need to update router firmware or driver. What happens comparatively if you and your friends connect directly to the modem?
      My System SpecsSystem Spec

  3. #3


    Posts : 7
    Win 8 Pro x64


    yes, everyone running windows 8
    the example is when my friends download from the same website, my friends get speed until 1 mbps, but mine is only get to 200 kbps maximum
      My System SpecsSystem Spec

  4. #4


    Posts : 2,156
    Win7 Ult on DIY; Win8 Pro on MBP/Parallels; Win7 Ult on MBP/Boot Camp; Win7 Ult/Win8 Pro on HP


    Quote Originally Posted by cruzz View Post
    the example is when my friends download from the same website, my friends get speed until 1 mbps, but mine is only get to 200 kbps maximum
    Probably won't matter, but I still are curious what happens comparatively when the different machines connect directly to the modem. And, have you searched to find out if there is a known problem with Win8 and your controller? Maybe there is an additional issue with your controller. Are all of you downloading with the same browser/download software?
      My System SpecsSystem Spec

  5. #5


    If everyone has their own separate link to the ISP, this would indicate a problem on your ISP link.

    Run a link speed test and see what results you get, compared to what your ISP link is supposed to be running at. If its low through a wireless and router, connect directly (wired) to the router and see if tht makes a difference, or directly wired to the modem.

    Speedtest.net - The Global Broadband Speed Test
      My System SpecsSystem Spec

  6. #6


    Posts : 7
    Win 8 Pro x64


    znod: i searched for it, but still i can't find the answer yeah, i downloaded it with same browser and download software
    fireberd: i don't understand
      My System SpecsSystem Spec

  7. #7


    Posts : 2,156
    Win7 Ult on DIY; Win8 Pro on MBP/Parallels; Win7 Ult on MBP/Boot Camp; Win7 Ult/Win8 Pro on HP


    I don't get it either. Maybe someone will rescue both of us.
      My System SpecsSystem Spec

  8. #8


    Posts : 7
    Win 8 Pro x64


    yeah, i hope so
      My System SpecsSystem Spec

  9. #9


    I missed that you are all using the same router. That suggests something in your PC. Since you had a problem and fixed it. did you install the correct Wi-Fi or NIC drivers from the PC vendor? If not give that a try, Windows does not always install the correct or latest drivers. Using the "update driver" in the Device Manager doesn't do it either.
      My System SpecsSystem Spec

  10. #10


    Quote Originally Posted by cruzz View Post
    My laptop is ASUS A43SD with Ethernet Atheros AR8151 PCI-E Gigabit Ethernet Controller (NDIS 6.30)
    before i got this problem, i had problem with ethernet controller detection, and it is fixed.
    but now, in same connection, my friends get speed more than i am, even tough we use same cable, same router port, the only one who get worst speed is mine.
    how can i fix it? it happens in almost every connections i tried, not only in my current connection
    If this is happening with every connection you try then the problem is with the driver you are using. Try looking for a different driver or try installing the one you are using in compatibility mode for Windows 7.

    Windows 8 Compatibility Mode The Digital Dilemma
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
Same connection, different speed
Related Threads
Hey, I have a strange problem in that my network speed to my laptop appears to be halved. I have a 152Mb/s service which comes through on my xbox one being on a gigabit network. My laptop is limited to 100Mb/s due to the speed of the network card. The speed I obtain however, is ~40Mb/s...
Dear friends Could you help me figure out why it is that I have trouble browsing in high speed despite the fact that the wireless adapter receives data at 1 Mbps minimum? I haven't been able to watch videos on Youtube, read the news etc because the browser takes ages to load the full page. I...
I have strange network problem these days. I have a desktop PC and installed Windows 8.1. And I have a LAN. The gateway IP address is 192.168.2.1. The network works fine when I start the PC. I can access Internet with IE, I can access the config pages of my gateway and I can SSH my local File...
so i ran a speed test with several different website and they all said my download speed is between 5 Mbps and 8 Mbps : 34005 however when i actually download something my download speed stay at 1 Mbps or when i watch videos ( youtube ) :cry: i dnt have this problem with my phone ! thank u
Hi all; Good day, I would like to know how to boost the read/ write speed of my Hard Disk Drive. Someone told me about some innovation in Windows 8 such as Superfetch, Prefetch, Ready Boost, etc - something that is supposedly utilizing the idle capacity of your RAM/ SSD to boost the read/ write...
hello when i connect my hp probook 4520s to my sony vpcyb4ajg with Ethernet cable on my Hp wireless disconnects and can not be connected until i disconnect lan cable. but on my sony i have both wired and wireless connections simultaneously hp:win8 x64 realteck Ethernet and atheros wireless sony:...
speed fan in Software and Apps
Is there a way to change what temp is being displayed in the notification area? In mine, it showing 31 degrees which is associated to Temp1 and HD1...being both are the same. I would like it to display my CPU temp.
Eight Forums Android App Eight Forums IOS App Follow us on Facebook