Windows 8 and 8.1 Forums


Got internet connection to some things, and not for others

  1. #1


    Posts : 2
    Windows 8

    Got internet connection to some things, and not for others


    Hi, i just got my new PC with Windows 8 and i've been dealing with it for 12 hours now.

    I am using a wireless broadband, got full 3G-connection all the time but some things just won't connect.

    Let's start with a problem almost everyone seems to have some problems with; updating and downloading apps.
    I have no problems with the Store but when i try to download an app, it just says pending or downloading and nothing happens. If i cancel some apps, some other apps may download 2-40% quickly then stop again forever.

    Since i didn't put anything of value on the HDD, i just reinstalled the whole OS and tried again, and after a while some apps started to drop in. But i still have a huge problem with this.

    I got Connection to Chrome and Internet Explorer, i can go around on the internet with no problems. Instametrogram works and Maps works well. But News, Sports, Weather, Games and such does not work, it says i have no internet Connection. I just managed to download eBay, i could log in to my account and see my bids BUT i can't search, cause... I have no internet Connection...

    Please someone, help me. /Alex

      My System SpecsSystem Spec

  2. #2


    Quote Originally Posted by Korallreven View Post
    Hi, i just got my new PC with Windows 8 and i've been dealing with it for 12 hours now.

    I am using a wireless broadband, got full 3G-connection all the time but some things just won't connect.

    Let's start with a problem almost everyone seems to have some problems with; updating and downloading apps.
    I have no problems with the Store but when i try to download an app, it just says pending or downloading and nothing happens. If i cancel some apps, some other apps may download 2-40% quickly then stop again forever.

    Since i didn't put anything of value on the HDD, i just reinstalled the whole OS and tried again, and after a while some apps started to drop in. But i still have a huge problem with this.

    I got Connection to Chrome and Internet Explorer, i can go around on the internet with no problems. Instametrogram works and Maps works well. But News, Sports, Weather, Games and such does not work, it says i have no internet Connection. I just managed to download eBay, i could log in to my account and see my bids BUT i can't search, cause... I have no internet Connection...

    Please someone, help me. /Alex
    With 3G there are some settings in the modem that can cause this problem to occur though I can't quite remember which settings they were I've seen this same problem fixed in the past. You should be able to Google this particular problem to get a more concise answer.
      My System SpecsSystem Spec

  3. #3


    I got ie 10 working but store does not open and neither does the mail
      My System SpecsSystem Spec

  4. #4


    Posts : 2
    Windows 8


    I have finally found the solution. And it was of course a simple one. Windows had a great tutorial, i just took me forever to find it cause i didn't know what to search for.

    The problem was that Windows set some automatic update-services on "hold" so it won't keep downloading updates for news, sports and such so that you have to pay extra on your wi-fi or mobile broadband. My explaining sucks. Just click the link.

    Metered Internet connections: Frequently asked questions
      My System SpecsSystem Spec

  5. #5


    no that did not work for me

    must be something else
      My System SpecsSystem Spec

Got internet connection to some things, and not for others
Related Threads
Read more: The Internet of Things: How to make it a reality | ZDNet
Read more...
Read more at: Emerging standards, and questions, about the Internet of Things | ZDNet
Read more at: Thing 1, Thing 2... Internet of Things starts to gain a developer following | ZDNet
Name of internet connection help in Network & Sharing
I was setting up a new router and changed the firmware a couple times but set it up with the same SSID and password. In the menu to join networks it says the regular name. When I mouse over it on the bottom right it still says "Name 3" instead of just name. I deleted all the other network profiles...
Windows8 Embedded Helps make the Internet of Things Possible
Eight Forums Android App Eight Forums IOS App Follow us on Facebook