I recently purchased a Asus Q400A, which uses the Intel Centrino Wireless-N 2230 internal adapter. Wifi has always worked properly until I installed VurtualBox. After VirtualBox installed new adapters, I completely lost my Wifi connection to the local network. I tried looking for my wifi through the network manager and Windows does not show any wifi networks. What I tried was uninstalling the wifi driver, reinstalling the wifi drivers form Intel and Asus websites. Manually deleting ALL the wifi Drivers then trying to reinstall. When using Intel's Wifi Network Manager, with this utility, I can see all the networks around and and actually connect with the tools, but that does not give me network back, and windows still won't see any networks.

I ended up restoring from a restore point and it went back to normal. The same issue occured when installing OpenVPN, when it added its' adapter, after reboot I lost Wifi connectivity again, and had to use a restore point.

I am hoping there is some fix before I take back the laptop.