Windows 8 and 8.1 Forums

Issue with Win8RP x64 on ASUS Eee Slate EP121 with Microsoft Keyboard?

  1. #1

    Issue with Win8RP x64 on ASUS Eee Slate EP121 with Microsoft Keyboard?

    Good afternoon to all the great folks on this forum! I have a strange issue which I hope someone can shed some light on?

    Up until now my Win8 usage has been limited to the Samsung Series 7 Slate, the ExoPC Tablet, and the Dell Inspiron Duo. Well, I got a great deal online on a new ASUS Eee Slate EP121 (i5, 4GB, 64GB SSD) and its a very nice robust tablet. HOWEVER....

    I have now installed Win 8 more times that I care to remember. However, I have never encountered this before. After installing the RP x64 edition, the system booted up with all devices in device manager recognized and working perfectly. It ran a couple of Windows updates, and still all was good.

    This table comes packaged with an ASUS rebranded Microsoft 6000 Bluetooth Keyboard. Initially after the installation, it paired beautifully within Windows 8 settings / devices. And it worked great.

    The next day, the kayboard was no longer in the devices list under Windows 8 settings, however it WAS listed in the device manager under bluetooth devices, as working normally. Trying to re-pair the keyboard has been fruitless - the tablet just no longer sees it.

    I try pairing OTHER brands of keyboards, like Logitech - and voila! No problem!

    So - I then uninstalled the Microsoft 6000 Bluetooth Keyboard from device manager, and rebooted. However, I had done this several times now - and upon each reboot, it shows up again in device manager! This is with the keyboard turned off and nowhere near the tablet. I uninstall it, reboot and there it is again.

    I also tried some of the usual "bluetooth fixes" that other have posted. Even though the latest drives from Microsoft seem to all work great, I installed the x64 bluetooth and WLAN drivers from ASUS. No change at all.

    Finally, I tried pairing this specific Microsoft bluetooth keyboard with my Dell Inspiron Duo and my ExoPC Slate, both running Windows 8 x86, and it paired immediately and works great.

    So - please, smack me hard in the head and tell me what the heck I am doing wrong? I like a puzzle just like the next guy, but this has become a frustrating exercise in futility. Help!

    Thanks all very much,


      My System SpecsSystem Spec

  2. #2

    Posts : 5,707
    Windows 8.1 Pro

    This is an odd one... I'll play ball!

    Ok, does there happen to be a Bluetooth device near the tablet or anything else wireless?

    Looking around on a Microsoft support article, I found this...

    1. Click Start, click Hardware and Sound, and then click Bluetooth Devices.

    1. If your device does appear in the list of devices, click Add, and then follow the instructions to add the device.

      If the device does appear in the list of devices, check the status. The following possible states exist:
    2. Authenticated

    • Connected
    • Last Seen

      If the device state is listed as Last Seen, try to use the device.

      If the status flickers between Authenticated and Connected, communication exists between the device and the computer. You can also try to Remove the device and Add it back in.

    1. Click Properties, and then click Services.
    2. Click to select the Drivers for Device check box.
    3. If the device has a check box next to it that is selected, click to clear it.

      Note If you use the wireless link to add the device, the device is not set as the default device.
    4. Click OK.
    5. Click Properties, and then click Services.
    6. Click to select the Drivers for Device check box.
    7. Click to select the check box on the wireless link properties.
    8. If the link is not reestablished, use Control Panel to remove the device, and then try to add the device again.
      My System SpecsSystem Spec

  3. #3

    Posts : 5,707
    Windows 8.1 Pro

    I also have to ask, how is using that Asus tablet with Windows? I was actually considering getting one of those but they're like a thousand dollars new. Very nice specs though!
      My System SpecsSystem Spec

Issue with Win8RP x64 on ASUS Eee Slate EP121 with Microsoft Keyboard?
Related Threads
Hello, I bought a new ASUS laptop a week ago. I was just watching something on Netflix and when I tried to decrease/increase the volume with the keyboard controls, it did not work. The mute button does not work either. Is there a way to fix this? I am hoping the three keys...
I am using Macrium Reflect to make a backup image of my system drive on my Asus Vivotab running Windows 8.1. I have made a USB rescue drive which recovers to the Macrium recovery screen ok but there is no keyboard Support (I have the Bluetooth Keyboard) . The USB rescue drive is Windows PE...
My bt keyboard connects fine but it doesn't stay connected. I go into pc options to reconnect but cannot. I tap the icon and nothing happens. I can only reconnect if I remove the device and start from scratch to rediscover it and connect. I saw advice to go into Device Manager and uncheck 'allow...
on my windows tablet the keyboard does not come up when i touch a box that needs typeing input like on my android tablet
I've been using my ASUS EP121 for over a year now and upgraded to the RTM version of Windows 8 but am experiencing repeated Bluetooth driver issues. Every ten minutes of so, my Microsoft Bluetooth Notebook Mouse 5000 and my Microsoft Bluetooth Mobile Keyboard 6000 become unresponsive. The fix is...
Hi folks I'm currently running the Windows 8RTM 64bit on my Asus eee Slate ep121. I have a dual boot of the RTM and Windows 7 Home Basic. I have several game including Plants vs Zombies and Angry Birds Space that run great on Windows 7, but they won't run on the Windows 8RTM. I keep getting...
Solved Hp Slate 2 Wireless driver issue in Drivers & Hardware
Hello I installed windows 8 pro on (32bit) on my HP Slate 2. I manged to install the drivers (in windows 7 compatibility) and it works fine, except wireless. The wireless I have is called "atheros ar6003" I manged to install it. The problem is that I cant get to work for more than few minutes...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook