Windows 8 and 8.1 Forums

Windows 8 very slow boot when raid controller is present

  1. #1

    Posts : 11
    Windows 7-SP1 / Windows 8.1 pro

    Windows 8 very slow boot when raid controller is present

    My motherboard is an MSI P67a-GD65 (B3) with a Marvell SATA 6G controller on it. I use that controller to mirror a pair of 1TB drives.

    When I go to install windows 8 (technet RTM\Final version) or even after I do install Windows 8, the inital boot screen will take about 3 1/2 minutes to load. I can see my USB keyboard go from power on to pwered off, then finally back on. Windows 8 will then continue the install or after the install, pop-up with a screen asking me which OS I want to boot.

    So even after a full install, I load all the drivers, everytime I reboot the system I have to wait 3 1/2 minutes for it to even offer me the option screen of which OS to boot to. Just the windows symbol and the Circle dots rolling around.

    I unplugged everything possible and disabled different intergrated components until I found out that it was the on-board raid controller that was causing the delay. With it disabled. Windows brings up the boot option instantly.

    Just for a test, since I was dual booting and wonder if the Windows 7 boot sector was the problem, I took out the SSD drive and put in a standard SATA drive and performed a clean install. Same results, with the Marvel controller enabled, Windows will just sit and poll for 3 1/2 minutes every time it is booted.

    I've upgraded the motherboard's bios to a bios thay was released July 26th 2012 (version 4.20). No change.

    Any idea what it's polling for and why it's hanging ? Any possible BCDEDIT options to tell it not to poll ?

    Thanks for any suggestions. I know I kinda skimmed alot of things you might want to know, Just trying to keep it short and concise.


      My System SpecsSystem Spec

  2. #2

    I do not know much about much, but I have found that a lot of Vista Drivers seem to work well with 8... Also take a look at this...
    [Solved] SATA 6G Marvell Controller Issues - Asus - Motherboards-Memory
      My System SpecsSystem Spec

  3. #3

    Posts : 11
    Windows 7-SP1 / Windows 8.1 pro

    I have used the Windows 7 driver for the Marvell controller, but in this case, the problem seems to be long before windows 8 even gets going. Once it's up and running, it worked fine without the driver if I had the controller set to IDE mode and only required the driver in AHCI mode. Either way, I've loaded all the newest drivers I could find.

    I may be stuck with just waiting around until something is released, assuming they ever do.

    Thanks for the reply.

    ** Update **

    Well, after getting a few leads, I was able to find a firmware update for the Marvell 91xx controller from 2010. Though some of the other threads I found reported it killed their cards. I opted to go ahead and give it a spin. Only negative side effect I had was when windows 7 booted it, it still saw the controller, said it was re-loading the driver and then I couldn't see the drives any longer after the next boot. Fortunately I had made a recent ghost of the system, so I was able to restore. Windows 7 loaded up and didn't have a problem on the next boot.

    Windows 8 now boots and loads normally. Yeah !

    I'll include a link to the drivers\firmware I found. Most of the directions are in french on the webpage, but the actual firmware install is english. Just boot off a win98 disk and run the Go.bat file.
    Marvell drivers
    Last edited by Dalexx; 17 Aug 2012 at 08:56.
      My System SpecsSystem Spec

Windows 8 very slow boot when raid controller is present
Related Threads
Solved SSD as boot, 2 HDD in raid 0 in Installation & Setup
Hi eightforums, I know some will ask "Why?". Suffice it to say. Because I have wanted to do this for years. This will be the only PC in my house. I haven't had one for 4 or more years. I will have an external backup drive in case the array fails. Is this the proper way to set this up on a...
RAID controller causing DPC timeout in BSOD Crashes and Debugging
I purchased this RAID 5 controller: Rosewill RSV-S5 SATA 3G 2.5" & 3.5" HDD 5-Bay RAID 0/1/5/10/5+spare/Spanning/JBOD Storage Enclosure System with 120mm cooling fan/ Port Multiplier/ PCIe card included/ Tray design - It has never worked. I have installed 5 1TB HDDs, and the...
Hi, my default drive configuration looked like this: SSD with Windows 7, and two drives paired with Marvell controller into RAID 0. And everything worked just fine. Yesterday I bought new, bigger and faster SSD, plugged into my PC and installed Windows 8.1. The problem is that my RAID config...
Hey, so I have a problem with a RAID 1 configuration on my computer. Basically Windows 8 won't boot and automatically launches the 'automatic repair' however it fails to repair the issue and so gives me the option of restarting or going to advanced options. At the same time as this, I've...
I have an HP EliteBook 8760w laptop (XU099UT#ABA) running Windows 8.1 64-bit with an Intel hardware RAID 0 array that contains two 750 GB WD hard drives (WDD7500BPKT-75PK4T0). I just upgraded the Intel RST driver to the latest version ( I recently discovered that if I go into the...
Here's a weird one - I have an Asus M5A97 LE R2.0 with an onboard Realtek Ethernet interface. If I load the latest driver (8.3.730.2012) it runs at 7Mbps - which is about as good as I get from my ADSL link. If I then reboot the system, it drops to 1.36 Mbps and stays there until I reload the...
I have windows 7, Disk 2, Drive C and am setting up a dual boot with win 8, Disk 2, Drive W. On my windows 7 setup I have a Raid 5, 3 disk array, that has all of my pictures on it, Disk 0. Will I be able to access it at all in windows 8? If so, is there anything I need to do when installing...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook