Windows 8 and 8.1 Forums


VC++ redistributable won't install... WTF?!

  1. #1


    Posts : 143
    Windows 8.1

    VC++ redistributable won't install... WTF?!


    Hi!

    I tried installing Microsoft Visual C++ 2010 Service Pack 1 Redistributable Package MFC Security Update and Microsoft Visual C++ 2010 SP1 Redistributable Package (x64) (also the x86 version). But every time it fails. And this is a new os installation....

    These were the lines marked in red as errors:
    Code:
    SetupResources.dll missing from 1038 directory
    
    Returning IDOK. INSTALLMESSAGE_ERROR [The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2203. ]
    MSI (d:\085fdbd6a7999ca571\vc_red.msi) Installation failed. Msi Log: Microsoft Visual C++ 2010 x86 Redistributable Setup_20160705_133158791-MSI_vc_red.msi.txt
    PerformOperation returned 1603 (translates to HRESULT = 0x80070643)
    Action complete
    OnFailureBehavior for this item is to Rollback.
    WTF is up with setupresources.dll? It so "fun" when things that always worked fail.

      My System SpecsSystem Spec

  2. #2


    Posts : 143
    Windows 8.1


    I keep researching and finding nothing. I also tried the redistributable for VC++2013 and 2015, but they also fail but with an even more useless and vague error. (Basicly the only say it failed...)

    I thought the windows installer might need an update, but that's not the case either. Version 5 is the latest, which I have.
      My System SpecsSystem Spec

  3. #3


    Posts : 143
    Windows 8.1


    Solved. But I don't know how. There were some files in the root of drive D which I deleted. Then I could install every VC++ redistributable...

    "Thank god" for braindead garbage installers that unpack crap into eclectic locations than copy them somwehere. 30+ friggin years Microsoft couldn't create a decend package format that can be used for installing stuff.
      My System SpecsSystem Spec

VC++ redistributable won't install... WTF?!
Related Threads
Hi everyone, I am trying to install microsoft visual c++ redistributable 2015 (x86) and (x64) but I keep getting an error code saying 0x80240017. does anyone know how to fix the issue? thank you
I just got a new laptop, a Lenovo X230, for which I paid extra to have the OS on it as Windows 8 Pro. So--now I have it, and Win 8 Pro 64 is installed and activated on it. I am a legal owner of Win 8 Pro. However, I would like to do a clean install of Win 8 on the computer, to have it free of...
It seems I need to install Microsoft Visual C++ 2005 Redistributable Package (x86) for an old program. But whenever I install, it stops at 'Gathering required information..' and terminates. How do I solve this?
I am unclear how the Microsoft Visual C++ redistributable installs are handled. I have 15+ versions installed, do I need all of those? can I uninstall all the old versions and keep only the most current? How does this all work? Thank you for any clarification a head of time
Fresh install, installed Tuneup 2014, AVG Internet Security 2014, Firefox, Creative SoundCard Drivers, Updated Windows to current, Motioninjoy, Winrar, Bitcomet, and Installed and updated GeForce GTX 780 drivers. Crash occurred during test of DS3 Tool. Checked reliability history. Information is as...
During a virtual install, there is a question to install upgrade which says will move everything to the (new) windows folder or to install clean. If I answer upgrade, will all my windows ‘stuff’ be MOVED from my Windows 7 Pro? When I close the virtual machine will there be nothing left for my...
Hi, I am trying to install the W8 CP using the tutorial provided on W7F. Instead of the install.wim file, install.esd is present. I attempted to use imagex on that file, but it did not work. Is there another way to install it fast?
Eight Forums Android App Eight Forums IOS App Follow us on Facebook