Windows 8 and 8.1 Forums


Re-enabling Secure Boot after returning to Windows 8.1

  1. #1


    Posts : 2
    Windows 8.1

    Re-enabling Secure Boot after returning to Windows 8.1


    Hi there!

    A couple of weeks ago, I made the decision to dual-boot Fedora Linux on my Lenovo notebook, which required me to disable the Secure Boot feature in UEFI settings. After a few hours I returned to Windows only, which I did by removing Linux partitions and deleting a few Linux-related boot entries.
    Yesterday, I noticed that Secure Boot is disabled, so I wanted to re-enable it, and I did this by changing an option in BIOS. And even though everything seemed to be fine in UEFI (Secure Boot enabled, UEFI only mode, OS Optimized Defaults for >Win8 enabled - pure UEFI mode), the status of the function in BIOS and msinfo32 was Off. So I thought that restoring the factory image would do the job - it did not. After trying out various options, including resetting BIOS to factory defaults, resetting the manufacturer's settings for Secure Boot and contacting Lenovo customer service, I still couldn't get it to this 'On' status.

    Would you have any clue how can I re-enable Secure Boot?

    What the BIOS tells me right now concerning Secure Boot is:
    • Secure Boot - Enabled

    A few greyed out statuses:
    • Secure Boot Status - Disabled
    • Platform Mode - User Mode
    • Secure Boot Mode - Standard

    I also can enter such menus:
    • Reset to Setup Mode (Clear PK, disable secure boot and enter Setup Mode) - it changes the above statuses to Disabled, Setup Mode and Custom, respectively
    • Restore Factory Keys (Restore all secure boot database to factory default include PK, KEK, db and dbx)


    I know SBoot is not that important, but considering how much time I spent resolving this issue myself, I really feel like I need to fix it at once

    Cheers!

      My System SpecsSystem Spec

  2. #2


    Posts : 13
    Windows 10


    Quote Originally Posted by opayq View Post
    I also can enter such menus:
    • Reset to Setup Mode (Clear PK, disable secure boot and enter Setup Mode) - it changes the above statuses to Disabled, Setup Mode and Custom, respectively
    • Restore Factory Keys (Restore all secure boot database to factory default include PK, KEK, db and dbx)
    "Secure Boot" - >Enabled<
    "Secure Boot Status" - >Disabled< (default is >Enabled<)

    1. UEFI Firmware Settings - Boot to from inside Windows 8

    2. Go to "security" and then "reset to setup mode"
    3. Then go to "exit" and then "exit saving changes"

    4. UEFI Firmware Settings - Boot to from inside Windows 8

    5. Go again to "security" and this time select "restore factory keys"
    6. Then go to "exit" and then "exit saving changes"
      My System SpecsSystem Spec

  3. #3


    Posts : 2
    Windows 8.1


    Osprey, you don't know how thankful I am to you! This worked like a charm! Thank you SO MUCH for your help!!
      My System SpecsSystem Spec

Re-enabling Secure Boot after returning to Windows 8.1
Related Threads
Solved Secure Boot and Windows 8 Activation in Installation & Setup
I'm just about to experiment setting up Secure Boot on my Gigabye GA-Z77X-UD5H motherboard running Windows 8 Pro Media Centre edition 64bit. Do I need to reactivate Windows 8 if I enable the secure boot settings in the BIOS? Does it matter whther secure boot is enabled when upgrading to Windows 8.1?
Solved enabling Secure boot in System Security
I am unable to enable secure boot unless i disable CSM. What it tells me in BIOS under Secure boot option if enabled by disabling CSM Secure boot can be enabled if 1. System running in User Mode with enrolled Platform key (Pk) 2. CSM function is disabled. Having no idea what # 1. means....
Windows 8.1 Secure boot in System Security
I have a new laptop (HP G7-2292NR) with Windows 8 and today I turned on the laptop for the 3rd time and I see in the bottom right corner Windows 8.1 Secure boot isnít configured correctly build 9600, what does that mean? I am so new to Window 8 that I cannot find a thing, bear with me I need...
I was using my Win 8.1 machine to develop some WP8 apps with Visual Studio 2013, which works great... until this week. After I installed all the Windows updates, the OS would not boot - it kept getting into "repairing OS..." mode and ending up to give me only to option to shutdown the machine....
Hi Guys, I got this 3F0 Error and i am 100% Sure that my HDD is in good shape. I formated yesterday, i try to enable UEFi and the 3F0 Error Pops out. If i switch back to Legacy Boot then the PC starts notmally Can you guys help me? Pavillion HP 14 e019tx 8670M 2Gb Gddr3
Hi, I'm sorry if this has been asked before but I was unable to find answers using search. Here's my situation - I have an existing Win7 installation on SSD and just bought a new SSD for Win8. I installed Windows 8 on the new drive. Now, my BIOS boots to the new "UEFI" option and then goes...
I am new to this forum so I apologize if I sound foolish. I have a Gateway desktop which came with Vista and now I run Windows 7. Anyway I ran a test to see if my computer can run Windows 8. I am good except it says my secure boot wont work. Can I still run Windows 8. What do I need to do so I can...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook