Windows 8 and 8.1 Forums

Installing Windows 8 using custom install.wim, key in BIOS

  1. #1

    Posts : 5
    Windows 10

    Installing Windows 8 using custom install.wim, key in BIOS


    I have to return a bunch of Samsung tablets to the factory default image to be on-sold but I'm running into trouble.

    I made an image using CloneZilla which works except pressing F4 on startup to restore the factory image doesn't work. I spent a couple of days trying to get that to work but gave up.

    I got the install.wim file from the recovery partition so I tried using a Windows VL ISO, used rufus to make a bootable USB and replaced the default install.wim from a Windows ISO with the factory image wim but got the error below. I've done this in the past with Windows 7 and it worked a treat, I guess not with Windows 8/BIOS product key.

    The product key entered does not match any of the Windows images available for installation. Enter a different product key
    This pops up before entering a product key. I'm assuming it's using the BIOS key.

    I figued it might not like the VL ISO so then I tried an ISO downloaded using the Windows 8 media tool but I have to enter in a key, I'm not able to skip it. Not an option. I'm not even sure if this will work with a .wim file rather than a .esd file?

    I used ShowKeyPlus to get the BIOS key type and it was

    Win 8 RTM Core OEM: DM

    I tried creating an EI.cfg file


    but got this error:

    Windows cannot display the images available for installation

    I'm not sure what else to try. The searching I've done has been people wanting to bypass the BIOS key by creating a PID.txt file and using an OEM key. I actually want to use the BIOS key. Is this even possible? Maybe I need an Win 8 RTM Core OEM: DM ISO?

    Last edited by Russell Coight; 10 Mar 2016 at 22:41. Reason: removed smileys

      My System SpecsSystem Spec

  2. #2

    Posts : 2,690
    Windows 3.1 > Windows 10

    You need to use WindowsRE to apply the Factory Image...
      My System SpecsSystem Spec

  3. #3

    Posts : 5
    Windows 10

    Quote Originally Posted by KYHI View Post
    You need to use WindowsRE to apply the Factory Image...
    Thanks KYHI

    I'm not overly familiar with WindowsRE. Is that part of MS DART/ERD?

    How would I get a copy of it?
      My System SpecsSystem Spec

  4. #4

    Posts : 2,690
    Windows 3.1 > Windows 10

    download and extract Recovery >
    copy the contents of the folder to a fat32 formatted USB ( the zip is the bootable x64 WinPE files and the 3 files required for use with WinRE)

    Mount the > Factory Install.wim
    And search for winre.wim (windows\system32\recovery\winre.wim)

    copy that winre.wim into the sources folder of the USB and then rename winre.wim to boot.wim

    unmounts the factory install.wim..

    then determine the size on the factory install.wim > if over 4GB you will have to use DISM to split the factory install.wim into install.swm(s)

    Dism /Split-Image /ImageFile:D:\install.wim /swmfile:L:\Sources\install.swm /FileSize:3800

    D:\install.wim = the location of the factory install.wim
    L:\Sources\install.swm = the USB Drive letter\sources\install.swm

    Now within that USB sources folder there is a > $PBR_Diskpart.txt

    that file will determine the partition sizes -
    you can change the values in MB's to suit your needs...

    once you have the winre.wim - renamed to boot.wim in the USB\Sources Folder
    and you have the install.swm.(s) in the USB\sources
    And you have the partition sizes set to your requirements in $PBR_Diskpart.txt
    ( Should only need to adjust Recovery Partition Size so as to have enough space for the install.swm(s) + 50MB )

    Boot from that USB and reset the PC...

    Recovery will reset the partition sizes, write the factory install.wim to the OS partition, Copy with files needed for WinRE, write the recovery image and register the Windows Refresh/Reset Recovery options...
    And it should use (find) the BIOS Activation Key to validate the windows installation..
      My System SpecsSystem Spec

  5. #5

    Posts : 5
    Windows 10

    Nice thanks for that.

    It works if there's a recovery partition on the tablet SSD, but doesn't work if the disk has been cleaned using diskpart. The error is 'Unable to reset your PC a required drive partition is missing'.

    Am I doing something wrong or this is expected behaviour?

    Thanks again for your help.
      My System SpecsSystem Spec

  6. #6

    Posts : 2,690
    Windows 3.1 > Windows 10

    That recovery media should work just fine on a clean drive... As it is Bare Metal Reset Recovery Media...
    Meaning it will create all the partitions needed, including the recovery image partition..

    But you have to make sure you have adjusted the recovery image partition (5) size correctly in the PBR_Diskpart,txt file

    As to how the process works >
    the drive is cleaned (reset partitions option, selected) the install.swm(s) are copied the recovery image partition
    The install.swm(s) are then applied to the OS partition..
    The Boot.wim is copied to the WindowsRE partition as winRE,wim
    then the recovery partitions are registered within the Windows OS..
      My System SpecsSystem Spec

  7. #7

    Posts : 5
    Windows 10

    Yeah that's how thought it would've worked.

    The recovery partition size of the original disk is 12GB so I added shrinkvolume=12000 (the size of the original recovery partition) to recovery partition 5, is this what I needed to do? I tried it but got the same unable to find partition error. Because shrinkvolume= it wasn't already there I didn't want to mess with it and just tried to restore using the defaults. I've also tried setting it to 40000 just as something to try, no luck either.

    I found this sample diskpart script and it's the same as $PBR_Diskpart.txt

    The comments mention to adjust partition 4 so it's large enough for the recovery image and not partition 5, am I missing something there? I tried adjusting partition 4 and 5 anyway but got the missing partition error.

    When are you asked to reset the partitions, is that after you select the OS?

    At the moment after the USB boots:

    - select language
    - Troubleshoot
    - Reset your PC
    - Here's what will happen.. > Next

    Then the Unable to find partition error pops up, nothing about resetting partitions.

    There's nothing I have to tweak in $PBR_ResetConfig.xml? Doesn't look like there is.
      My System SpecsSystem Spec

  8. #8

    Posts : 138
    Windows 8 Pro

    12GB=12288MB. 12x1024
      My System SpecsSystem Spec

  9. #9

    Posts : 5
    Windows 10

    12000 should cover it though, the install.wim (before shrinking) is less than 7GB.
      My System SpecsSystem Spec

Installing Windows 8 using custom install.wim, key in BIOS
Related Threads
I currently have a Windows snapshot made and I linked the wim to the refresh but I would like an image that already has multiple programs installed. I am curious if it is possible to reboot into sysprep Audit mode on my current setup and make an image? I would like an image that would take it to...
Recently when my laptop started up it gave me the 3F0 error and said that it couldn't boot the Operating System. I then decided to take my laptop to the shop, and the repairman downloaded Windows 8.1 Pro on it. The problem with this is when I try to factory reset my laptop it says that some...
Hey there, I am currently attempting to install Windows 8.1 64-bit to a desktop computer. I've got a 1TB HDD and a 8GB USB boot stick with Windows 8.1. I've booted from the stick and gone through the normal setup, however after selecting my HDD (the only one in the system) it goes to the...
Hello, I'm trying to install windows 8.1 to an external hard disk (solid state drive 128 gb usb3). I've tried easyUFEY WinToUS creator and AOMEI Partition Assistant Standard(Windows to go) with no luck. My bios has UEFI option only(no legacy). On my old laptop it works just fine(I had the...
Okay, this is the problem im facing. Back in 2012 I bought windows 8 for 16 dollars from Microsoft online. I was using it on my laptop but it recently died. I talked to Microsoft to disable it on that pc and they did that. Now I have built a new computer. I am wondering on how to install it on...
Install custom BIOS in my Acer Aspire v5-571g in Performance & Maintenance
I have an Acer Aspire v5-571g(53334g50makk) Ultra Book. With WIndows 8.1 Installed. The current bios in it is completely useless, it does not provide any options for me to alter, not even temperatures of the processor, graphic card etc... there for I want to know if I can install a different...
Good night everyone! Well, I'm here trying to dink around in getting a custom image of Windows 8 done. I want to do this as I know later on this year and next year probably, the amount of people asking to upgrade or to do a clean reinstall on an OEM PC will go up. Now, I generally install...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook