Windows 8 and 8.1 Forums

Cant mount ISO files on Windows 10

  1. #1

    Posts : 2
    Windows 10

    Cant mount ISO files on Windows 10

    Sorry for my bad english hope you understand

    I recently mount a ISO file on my computer, it work, then i unmount that ISO and a some hours later i needed that ISO again, so I tried to mount and its not working.
    Im using daemont tools ultra and i can mount a ISO but when i go to "my computer" i dont have there anythink...
    please help a fix it, i tried so many solutions and it still not working.
    My OS: Winfows 10

      My System SpecsSystem Spec

  2. #2

    Newport, South Wales, UK
    Posts : 573
    Windows 10 Pro x64 x2 Windows 10 Enterprise x64, Ubuntu

    You will find better help here ... Windows 10 Forums, as the handling of ISO mounting is OS dependent

    Things like demon tools for mounting ISO files have been obsolete for several years as the OS handles this natively
      My System SpecsSystem Spec

  3. #3

    Posts : 2
    Windows 10

    Thx man, going to that forum
      My System SpecsSystem Spec

  4. #4

    Posts : 275
    Windows 8.1 64 bit

    First steps would be a full power off & restart then try the system file checker command SFC / SCANNOW
      My System SpecsSystem Spec

Cant mount ISO files on Windows 10
Related Threads
How to Auto-mount a VHD at Startup in Windows 8 This tutorial will help show you how to have a VHD auto-mount as a drive at startup in Windows 8. You must be signed in as an administrator to complete these steps. If you like, you could also use Bitlocker to encrypt the VHD drive.
My OS formerly mounted ISOs with an Enter or double-click in File Explorer. Now I get an error 52607 Most remedies from a quick Google search don't apply: the ISO files don't have a sparse flag set 52608, so fsutil sparse setflag filename 0 does nothing, copying does nothing the native...
mount .bin.cue files in General Support
hi , having trouble mounting files in w8 always used diamond tools before (in vista) without any trouble. but now its not working at all, im mounting the file and all that happens is audio file(1kb) in the viritual drive. have been sitting here for like 4h and whatever i do nothing works..
I think it might be my solution to a BSOD issue
I just Download Office 2013 and Visio 2013 ISO, is not that great to be abble to install them right away without installing third apps like Deamon ? Not the first time I use the Mount function, but everytime I do , I really thanks MS for it. ...
WOW Windows 8 mount the ISO in Software and Apps
What a nice surprise , you can mount the ISO I just finish to install Visio ....
Eight Forums Android App Eight Forums IOS App Follow us on Facebook