Windows 8 and 8.1 Forums


Can't install Windows 8 on new rig with a UEFI motherboard

  1. #1


    Posts : 4
    Windows 8

    Can't install Windows 8 on new rig with a UEFI motherboard


    I put together a new rig with a new Asus Z97-A motherboard, 3.5GHZ Intel i5-4690 processor, 8 GB GSkill RAM, GE Force GT 650 and a Samsung 500GB EVO SSD plust two Western Digital 1TB mechanical hard drives. Both my Windows 7 and 8 DVDs are legitimate updates. Windows 8 came from Microsoft. I first tried to install Windows 7 and that would seemingly install but would never run past the opening screen when the balls spin and join. I then cleaned the SSD with diskpart to stop it from trying to boot to 7 and put the Windows 8 DVD in the drive. Following all the normal steps of a custom install it appeared that installation was going just fine. It installed all files without incident, rebooted and got to the "getting ready" screen and shut down quickly. The option I now have is to restart the computer and reinstall. That action results in the same result. In the UEFI BIOS I have CSM enabled and Boot Device Control is set to "UEFI and Legacy OPROM." I don't know if I have a failure with a new piece of hardware, a driver problem or am I setting something up wrong in the UEFI BIOS? Help me please.

      My System SpecsSystem Spec

  2. #2


    Posts : 123
    Win8.1


    I think that as you are are installing from a DVD you may be having an issue due to UEFI mode.
    I would install off a USB drive setup to boot in UEFI mode. Then use your boot manager (F12 or similar at BIOS screen) to select the "UEFI USB stick" - that way you will know for sure what mode your installing in.
    See UEFI Bootable USB Flash Drive - Create in Windows[1]=General Tips
      My System SpecsSystem Spec

  3. #3


    Posts : 879
    Windows 10


    Quote Originally Posted by Cecebee View Post
    or am I setting something up wrong in the UEFI BIOS?
    You should be able to install Windows 8/8.1 with the default UEFI settings.

    The Asus motherboard UEFI firmware (BIOS) settings. -> link

    How to download and create a bootable Windows 8.1 installation media. -> link
      My System SpecsSystem Spec

  4. #4


    Posts : 4
    Windows 8


    Thanks to everyone for the replies. Since receiving them I have downloaded a fresh copy of Windows 8 and built a bootable thumb drive. I have set all the UEFI firmware to all default settings. I also removed the 500 GB Samsung SSD from the system and replaced it with another brand new Samsung EVO 250 GB SSD. Finally I removed and re-seated the GSkill DDR 1600 memory. I have since tried to install Windows two times from the thumb drive. Each time it has installed files in what I would consider to be normal time, then it has installed updates very quickly indicating that it probably didn't do any downloading from Microsoft. Then it asked to remove the thumb drive and let the system reboot to complete installation. Next is quickly goes through "installing devices" and then when it hits "getting ready" it shuts the computer down to a black screen. I did this twice and decided that is is either a case of bad memory, bad mother board or bad processor The only other device that might shut the system down would be the video card but it works okay up until that point. Can anyone say what component is most likely to be the cause? I don't think it is a snafu with the Windows activation because I know the serial number I enter is a good one and Windows pauses for about 45 seconds to check it out before file installation ever begins.
      My System SpecsSystem Spec

  5. #5


    Posts : 123
    Win8.1


    Are you sure you are waiting long enough? I did the clean install of Win8 to a UEFI MB a few weeks ago, and I remember thinking the system went dead - I was just about to hit the power button when the next setup step started.
      My System SpecsSystem Spec

  6. #6


    Posts : 4
    Windows 8


    I just tried it all over again and let it sit for a full 10 minutes after it abruptly shut down. Got the same result. I am starting to think that maybe this kind of problem belongs in a different forum?
      My System SpecsSystem Spec

  7. #7


    Posts : 4
    Windows 8


    Just to provide a conclusion to this thread I can say that the problem turned out to be a bad out of the box motherboard. I have used a lot of Asus boards and never had a bad one until now. I hope I never have another because the RMA process is a PITA and unnecessarily slow to resolve. I may try another brand in the future but they are all probably just as bad as Asus has been?
      My System SpecsSystem Spec

Can't install Windows 8 on new rig with a UEFI motherboard
Related Threads
Hi everybody, I bought a new motherboard (Gigabyte 970A-DS3P) and DDR3 (8GB Team Group 1600MHz CL10), I did a fresh installation of Windows 8.1 (to have a clean installation of drivers) and since then I have regularly BSOD... Here is my configuration : Motherboard : Gigabyte 970A-DS3P CPU :...
Hello, I have MSI UEFI Mobo, when I try to boot on my Hard Drive in BIOS, it gives me: "Restart and select proper boot device" but I can boot using UEFI Windows Boot Manager, so I want to add legacy boot besides UEFI Boot. Thanks a lot. Regards, addas
I'm currently running a Gigabyte 990 FXA - UD5 motherboard with legacy BIOS. Thinking about upgrading the MB to a UEFI Bios. Looking for recommendations/issues/stay away from MB problems that you may or may not have issues with. Basically, what do you likes and why?
Hello, i have HP Pavilion g6 1360su with Insyde H2O F.6A. I have downloaded and installed the HP UEFI Support Environment from here: http://h10025.www1.hp.com/ewfrf/wc/softwareDownloadIndex?softwareitem=ob-119351-1&cc=bg&dlc=bg&lc=en...=. Is my PC compatible with Windows 8 UEFI? :think:
Changing from Bios motherboard to UEFI in Performance & Maintenance
I wish to change my system to use UEFI from the older bios system but I have run into the single problem of changing the disk from MBR to GPT I have lots of things I need to back up and i want my windows system to be how it is now. The problem is Windows system image apparently does not like ...
hey guys, done a solid few hours of my own research and havent managed to come to a solution for my particular issue. i am buying a new motherboard (GA-Z77X-UD3H) along with an intel i5. the current system is an older model gigabyte AMD mobo w/ a phenom X2 in it... the OS is on a SSD and...
Hi all, I was reading online that Windows 8 will just reinitialize itself if you make any significant hardware changes. Kind of like what it did during the first install/boot. So because of this I had not backed anything up (it's all replaceable I just would really rather not set everything...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook