Windows 8 and 8.1 Forums


Missing Operating System message while booting

  1. #21


    Posts : 1,875
    Windows 10 Pro Prieview x64


    You have a bootable USB, next is looking into the flashing cursor. There are lots of threads about this but a good start seems to be go into bios, reset defaults and try turning AHCI on (or perhaps off).

    Re-Installing Win7 / Process hangs in a black screen with cursor - Windows 7 Help Forums

      My System SpecsSystem Spec

  2. #22


    I believe that this is a problem with UEFI vs Legacy boot but I don't know how to handle it.
      My System SpecsSystem Spec

  3. #23


    Posts : 1,875
    Windows 10 Pro Prieview x64


    Nor do I - I've never installed UEFI. Hopefully some else will come along with a suggestion. You might want to open another thread called "Flashing cursor on clean install" though if no-one chips in as all the comments on this one might put them off.

    In the PLIST though there is this section

    Code:
    <key>PreUEFIModels</key>
        <array>
            <
    string>MacBook7</string>
            <
    string>MacBookAir5</string>
            <
    string>MacBookPro10</string>
            <
    string>MacPro5</string>
            <
    string>Macmini6</string>
            <
    string>iMac13</string>
        </array> 
    I know that my MBP will not boot windows EFI (Mine is MacBookPro10). Depending if you Sony is UEFI (or not) you might want to add or remove your mac model number here so it makes either a EFI or Legacy USB (and then resign the application).

    That really is only a guess though.
      My System SpecsSystem Spec

  4. #24


    Thank you so much for your help.
    How do I know if my sony vaio is EFI or Legacy USB?
      My System SpecsSystem Spec

  5. #25


    Posts : 1,875
    Windows 10 Pro Prieview x64


    You'd need to look it up with the full specs

    Looking into this https://tomstechnotes.wordpress.com/tag/boot-camp/ when compared to your YouTube video he changes the PreESDRequiredModels and PreEUFIModels as well as PreUSBSupportedModels.

    If you update these other 2 it should (might anyway) make you a USB that will boot Legacy. As your last USB doesn't boot changing these 2 should make the other type. So whatever it has made if you make the other it might work even if you don't know which is required (if you see what I mean).

    Worth a try unless someone has another idea... I don't know about UEFI I'm afraid - only what I've just read
      My System SpecsSystem Spec

  6. #26


    Pre means that the system is not using these settings at all?Because this guy is removing only the Pre- from PreUSBSupportedModels.
      My System SpecsSystem Spec

  7. #27


    Posts : 1,875
    Windows 10 Pro Prieview x64


    He is removing the Pre from PreUSBSuported models to make the box appear. For the PreUEFI and PreEXD he's adding his model. The way I read it is if you add your model to the PreUEFIModels you get a Legacy boot USB.

    This is what I have (by default) for MacBookPro10,2 that creates Legacy USB (also Yosemite). I didn't need to change PreUSB as I already had that option. Note the syntax drops the ,2 from the model so it is MacBookPro10 not MacBookPro10,2

    You can see my model is in the top 2 arrays but not in the bottom 2. If I add my model to PreUSBSupported I looses the ability to write to USB. If I leave it there and then remove the Pre suffix then writing to USB starts working again.

    I'd leave your PreUSBSupported change as it is (because it works) and just add your model ID to the top 2 if it isn't already there and remove it if it is.

    Code:
        <key>PreESDRequiredModels</key>
        <array>
            <string>MacBook7</string>
            <string>MacBookAir5</string>
            <string>MacBookPro10</string>
            <string>MacPro5</string>
            <string>Macmini6</string>
            <string>iMac13</string>
        </array>
        <key>PreUEFIModels</key>
        <array>
            <string>MacBook7</string>
            <string>MacBookAir5</string>
            <string>MacBookPro10</string>
            <string>MacPro5</string>
            <string>Macmini6</string>
            <string>iMac13</string>
        </array>
        <key>PreUSBBootSupportedModels</key>
        <array>
            <string>MacBook7,1</string>
            <string>MacBookAir3,2</string>
            <string>MacBookPro8,3</string>
            <string>MacPro5,1</string>
            <string>Macmini4,1</string>
            <string>iMac12,2</string>
        </array>
        <key>Win7OnlyModels</key>
        <array>
            <string>MacBook7,1</string>
            <string>MacBookAir3,2</string>
            <string>MacBookPro5,5</string>
            <string>MacPro2,1</string>
            <string>Macmini4,1</string>
            <string>iMac10,1</string>
        </array>
    Click image for larger version
      My System SpecsSystem Spec

  8. #28


    I believe that we see it wrong.These are the settings I would put if I would like to run windows on my mac.
    But I want to run windows on another laptop (sony vaio).
    So I thought something clever.
    I've downloaded Parallels 15-Trial which is full functional and now it downloads windows 10 tech preview.
    Then I will install rufus in this virtual machine and I will try again.
      My System SpecsSystem Spec

  9. #29


    Posts : 1,875
    Windows 10 Pro Prieview x64


    That will be easier certainly. Use a USB2 stick if you've got one - I don't know about Parallels, perhaps it is OK, but Virtualbox has problems with USB3.0. Good luck.
      My System SpecsSystem Spec

  10. #30


    Posts : 1,875
    Windows 10 Pro Prieview x64


    Quote Originally Posted by skiabox View Post
    Thank you so much for your help.
    How do I know if my sony vaio is EFI or Legacy USB?
    It looks like it is legacy and you want legacy set in bios windows 7 - Unable to boot from USB on Sony Vaio - Super User
      My System SpecsSystem Spec

Page 3 of 4 FirstFirst 1234 LastLast
Missing Operating System message while booting
Related Threads
Read more: Your next operating system: Your datacenter | ZDNet
No Operating System? in General Support
I started up my laptop as I always have and for some reason, the screen is black except for white words saying "No Operating System Found." I can't seem to get Windows 8.1 back up and running. Please help!
Greetings Friends, I have Installed Windows 8.1 Couple of weeks ago and before that i had windows 7 So now i have both means DUALBOOTED so i have windows 7 and 8.1 both But When The Boot Manager Appears i Hit Windows 8.1 it boots and works Smooth but if i hit windows 7 then it just Restarts but...
Solved "Missing Operating System" in General Support
I'm selling my PC and long story short I went through thorough steps to ensure that I didn't leave any traces, I didn't do a clean OS install or format because I had a digital copy of windows 8 via upgrade and after using CCleaner to free space, uninstalling unneeded software, and manually removing...
Hi, I have three operating systems on my pc. I only recently installed a windows 7 64 bit on a ssd but after doing so, I had to do a system image recovery to my windows 8 installation from a date prior to the new windows 7 install. This Windows 7 is not on the list of operating system options in...
Backing up the operating system in Installation & Setup
Hello everyone, just purchased a SAMSUNG Series 3 NP3530EC laptop running Windows 8. It came without a recovery disc. The laptops that I had in the past allowed you to make a copy of the operating system to DVDs. I can not work out how to do this with the Samsung. Any help will be greatly...
Second Operating System in Installation & Setup
I downloaded Ubuntu 12.10 from a pen drive onto a USB external hard drive, but after a mixed success I have decided to abandon Ubuntu. However one problem still remains, both the pen drive and external hard drive are NOT plugged into my laptop, when I press the following: Settings. Change PC...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook