Windows 8 and 8.1 Forums


EFI and MSR missing after Win 8.1 clean install

  1. #1


    Posts : 2
    Win 8.1

    EFI and MSR missing after Win 8.1 clean install


    Hi,

    Having a problem here. I've got a Lenovo Y570 with pre-installed Win 8.1. It worked fine except for it had continuous trouble with installing updates which couldn't be fixed with cmd or Refresh. So I did a clean install.

    After clean install MSR and EFI partitions were gone, the Boot menu stopped listing UEFI boot options (it either stays clear or lists ipv6 network stuff which fails to load anyway). I know my hardware supports UEFI but I can no longer boot via it. I am able to boot into Windows but only via Legacy Support mode. When booted, Advanced Boot options also show no UEFI firmware settings.

    Creating EFI partition manually via diskpart doesn't help: it either gives virtual disk error or makes it impossible to install OS into remaining part. Recovery doesnt seem to work either: gives "missing path/partition" error.

    I have a WD SSHD drive installed. I really want to bring back fast and secure boot. Thoughts?

      My System SpecsSystem Spec

  2. #2


    Sydney, Nova Scotia, Canada
    Posts : 6,490
    Windows 10 Education 64 Bit
      My System SpecsSystem Spec

  3. #3


    Posts : 2,690
    Windows 3.1 > Windows 10


    You appear to have installed windows 8.1 with legacy support..

    You need to disable CSM/Legacy support in your firmware settings and reinstall windows 8.1 from your setup media..

    UEFI uses EFI and MSR partitions - Legacy does not..
      My System SpecsSystem Spec

EFI and MSR missing after Win 8.1 clean install
Related Threads
I just did a clean UEFI installation of Windows 8 Pro on my laptop following this guide: https://www.eightforums.com/tutorials/2328-uefi-unified-extensible-firmware-interface-install-windows-8-a.html. Did a quick format and converted the drive to GPT before starting the installation process. The...
clean installation-missing drivers in Drivers & Hardware
hello today for first time i make a clean instalaltion of win 8.but in device manager i noticed:other devices -two are missing.the online searching did'not find anything.so i have the option to find from a list in my pc.but i don't know what is ...
I am trying to install Windows 8.1 onto a new PC a clean install. I boot from UEFI CD/DVD Drive with the windows 8.1 install disk in it and it gets to the "Press any key to continue" screen, I press a key and it just restarts my computer. Then I try to boot from just regular CD/DVD Drive it says...
Hi, My Samsung laptop will not boot due to missing partition. I do not have any recovery media, and have purchased a new version of windows 8 pro that I would like to install. Would be really grateful for any help - as I haven't been able to get any from the manufacturer. :mad: specs- Samsung...
Clean disk before clean install? in Installation & Setup
hello I had many problems with BSOD crashes, and decided to make a new clean install (SSD or harddisk). If I make a new clean install (no upgrade) is it enough to create 1 continuous unallocated disk and then it will make a clean install Or do I have to "clean up" my old disk first before making...
During a virtual install, there is a question to install upgrade which says will move everything to the (new) windows folder or to install clean. If I answer upgrade, will all my windows ‘stuff’ be MOVED from my Windows 7 Pro? When I close the virtual machine will there be nothing left for my...
Hi, I am trying to install the W8 CP using the tutorial provided on W7F. Instead of the install.wim file, install.esd is present. I attempted to use imagex on that file, but it did not work. Is there another way to install it fast?
Eight Forums Android App Eight Forums IOS App Follow us on Facebook