Windows 8 and 8.1 Forums


Copying userdir from SSD to HDD (permissions/sparse files)

  1. #1


    Posts : 2
    Windows

    Copying userdir from SSD to HDD (permissions/sparse files)


    Hi, all.

    New user, but I doubt I'll participate much. I am not a fan of the web forum format in general.

    But I will insofar as I have an issue I'm trying to resolve.

    I have a new WinEightPointOnePro install going here, running on an SSD in a smallish partition (about 60GBs' worth of a 120GB so I can install and boot another OS in the remaining space), and I would like to move my normal user directory onto an HDD. Mindful of the need to have an account with space on that drive, I have created a local administrative account that will remain on the SSD in cases of emergencies.

    The issues I've run into is that when I copied the files over, it does not keep permissions of the original directory on the SSD, even when I tried to disable inheritance on the parent directory I intend to put it in, which I will call H:\Users. Second, the files grow from a few megabytes to at least a gigabyte. I suspect that some of the files in my original user directory tree are sparse files. Most copy programs, including Windows' own core tools when used with defaults, seem to ignore this fact and expand those sparse files out to their full size anyway. Not cool. Also, I tried using RoboCopy's "cloning" function, /MIR, but it takes whatever links/junctions in my user directory tree and expands them out. Again, not cool.

    That said, is there a good way, whether via core Windows utilities or with third-party utilities, that can copy my userdir over in a completely intact state, maintaining both permissions and sparse files' "being sparse"? WIMP (Window Icon Mouse Pointer) and CLI tools will be given equal consideration; I use both, based on my needs and how easy one is over the other for a given case.

    Thanks!

      My System SpecsSystem Spec

  2. #2


    Posts : 2
    Windows


    Turns out that the files that I thought were "sparse" were hidden and some of the tools used couldn't see those hidden directories.

    No need for any help.
      My System SpecsSystem Spec

Copying userdir from SSD to HDD (permissions/sparse files)
Related Threads
Hi There is 3 hdd's installed to my rig: 1 is 55gb kingston ssd where i run my windows 2 is 1tb hitachi where i keep my games and other junk 3 is seagates 250gb laptop hdd. The main problem was that sometimes when opening or just clicking some folders freezes the file explorer and it...
Hi, i bought a Micro SD Card 32GB from eBay. Im trying to copy files to it so i can transfer them from my PC to my Laptop, however whenever it finishes copying files and i plug it into my Laptop, it needs formatting. I have tried copying files to it and them plugging it back into my PC but it says...
Okay, here are the simple instructions from "Windows 8 for Dummies" (p. 109): So I insert a blank CD into my new Dell Inspiron's D drive. Nothing happens. No "Notification box" or anything else appears in the screen's upper-right corner. So what am I supposed to do, please?
Can someone help me? I finally got a CD to work in my new Dell computer. The files on the CD that I want to copy onto my computer are shown listed on the Windows 8 desktop or rather whatever the page is called that shows "Library," "Documents," "Music," etc. But there is nothing that shows me how...
Hi everyone, I am running into an issue I have never seen. I had a friends laptop that i was upgrading from windows 7. I took out his hard drive and plugged it into my windows 8 machine and backed up the files to my pc and then formatted and installed windows 8. Once I got it all back up i...
Hello everyone, Recently I've been following the news about the latest windows 8 (pro) tablets and I'm very interested in buying an asus transformer book (if they finally decide to release it...). Now, on my main pc and laptop, I still use windows 7, so I don't exactly know how windows 8 works...
Stuck at copying files in Installation & Setup
So I downloaded the Release preview from Microsoft website. I burn it onto a DVD and boot it, but when it got to copying files, it stucks at 95% and won't go further. What might happen?
Eight Forums Android App Eight Forums IOS App Follow us on Facebook