Windows 8 and 8.1 Forums

Win 8.1 Blackscreen

  1. #1


    Posts : 6
    Win 8 32bit

    Auto-boot from uefi (Edit3)


    hey,
    my friend got Dell Vostro 2521 laptop and it was running windows 8 64 bit (corrected, sorry)
    its graphic card is Intel HD Graphics 4000
    what happened is we clean installed the windows (8.1 64bit version) and all good till (finished copying files) and after that it restarts and shows a black screen (all the screen is blacked no logo or cursor loading)
    i've tried:
    loading defaults of bios
    automatic repair
    reinstall again
    tried opening device manager like this thread and what happened is:
    used this command " bcdedit /set {default} safeboot minimal " like this picture


    and restarted it didn't work
    been like this for 2 days
    Edit (1) : Googled for 3 hours of reading and trying and no good
    shall i get back to windows 7 ? i hope i can find and answer beside changing windows as i doesn't have access to another computer except friends
    Edit (2) : can't backup it would take an effort and there's no problem with the windows itself, beside i don't think formating would help


    Edit (3) :


    the problem was that the setup from usb was uefi and it was booting from harddive and i have to change to boot from windows every startup
    like this:

    So now the problem is that i can't boot automatically
    can't find uefi in bios
    uefi firmware from advanced opens the same menu (Enter setup)
    can't find in bios an option change to uefi
    all i the system was win8 32bit and i used WinSetupFromUsb to make the flash bootable
    then used partition wizard to resize the partition then faced the problem "Windows 8 cannot be installed to this drive" and i don't remember if it was GPT or MBR

    Edit (4) :

    The problem solved by updating the bios from a08 to a13 and changed to UEFI boot on boot settings (it wasn't there in a08 bios)
    Last edited by Maun00; 23 Jan 2015 at 11:48.

      My System SpecsSystem Spec

  2. #2


    Posts : 2,690
    Windows 3.1 > Windows 10


    Where you get the windows 8.1 software? you can download 8.1 from the link in my sig below, re-run setup - delete every partition and allow setup to continue.. let us know how you make out..
      My System SpecsSystem Spec

  3. #3


    Posts : 6
    Win 8 32bit


    Quote Originally Posted by KYHI View Post
    Where you get the windows 8.1 software? you can download 8.1 from the link in my sig below, re-run setup - delete every partition and allow setup to continue.. let us know how you make out..
    the installition works well i tried it with 2 other friends and the black screen is a common problem as i saw an thread "Intel HD 4000 don't upgrade to win 8.1"
    Edit (1): i have seen other people with problems but they installed the windows
      My System SpecsSystem Spec

  4. #4


    Posts : 2,690
    Windows 3.1 > Windows 10


    Interesting goggle search.. the old driver does not work , nor does the new one..
      My System SpecsSystem Spec

  5. #5


    Posts : 6
    Win 8 32bit


    Quote Originally Posted by KYHI View Post
    Interesting goggle search.. the old driver does not work , nor does the new one..
    Yea it was a whole different story i wasn't booting anything
      My System SpecsSystem Spec

  6. #6


    Posts : 2,690
    Windows 3.1 > Windows 10


    Don't know how you did it, you have bios set to legacy mode, and have 32bit (x86) software - both of which are correct..

    But you have UEFI -GPT Partitions... Which is not correct for that setup..

    -------------------------------------------------------------------------------------------
    Try selecting windows boot manager as your first boot option..
    -------------------------------------------------------------------------------------------
    Change Boot Mode Setting - UEFI and install x64 software on GPT Partitions

    Change Boot Mode Setting - legacy and install x86 software on MBR Partitions
    -------------------------------------------------------------------------------------------

    Basically insert your setup media, remove every partition from partition screen until there is none, then allow setup to use that empty space, follow the prompts and that will fix the problem
      My System SpecsSystem Spec

  7. #7


    Posts : 6
    Win 8 32bit


    Quote Originally Posted by KYHI View Post
    Don't know how you did it, you have bios set to legacy mode, and have 32bit (x86) software - both of which are correct..

    But you have UEFI -GPT Partitions... Which is not correct for that setup..

    -------------------------------------------------------------------------------------------
    Try selecting windows boot manager as your first boot option..
    -------------------------------------------------------------------------------------------
    Change Boot Mode Setting - UEFI and install x64 software on GPT Partitions

    Change Boot Mode Setting - legacy and install x86 software on MBR Partitions
    -------------------------------------------------------------------------------------------

    Basically insert your setup media, remove every partition from partition screen until there is none, then allow setup to use that empty space, follow the prompts and that will fix the problem
    she's running win 8.1 64bit and the only problem is i can't change boot mode to uefi
    i can only change it by opening boot menu and choosing windows boot from UEFI boot
    oh it was running win 8 64bit sorry for that
      My System SpecsSystem Spec

  8. #8


    Posts : 2,690
    Windows 3.1 > Windows 10


    it has to be in a bios setting - try to disable legacy boot
      My System SpecsSystem Spec

  9. #9


    Posts : 6
    Win 8 32bit


    Quote Originally Posted by KYHI View Post
    it has to be in a bios setting - try to disable legacy boot
    nope it works with it enabled just like the pic in the Edit 4 ,
    the old bios had only legacy and didn't has an option to change between uefi and legacy
    just updated the bios to a13 and there it was
    ty
      My System SpecsSystem Spec

Win 8.1 Blackscreen
Related Threads
so yesterday i got a random blackscreen and my headset came with a buzzing noise,while i was watching youtube. there were no bumpfile nor anywhere in event viewer were it said something had crashed. ive took the card out and made sure that everything was plugged well in. today it happend again...
I recently was cleaning my pc (custom build, no disc drive, using usb to boot to recovery) of malware, after I restarted there was no windows loading screen, just black screen. I tried bootrec fixmbr fixboot and nothing. When i used scanos or rebuildbcd I get 0 windows installations. Don't have...
got an annoyance Black screen today. Before this happen my notification not work...when I try to go to Notification setting it said sth like"App cant not start Explorer in use(sorry i forget it but it sth connect to administrative privilege and ask me to restart explorer)" After a logo...
A Blackscreen Window 8.1 Explorer problem in Performance & Maintenance
got an annoyance Black screen today. Before this happen my notification not work...when I try to go to Notification setting it said sth like"App cant not start Explorer in use(sorry i forget it but it sth connect to administrative privilege and ask me to restart explorer)" After a logo...
Hi, I'm using Acer Aspire V5-573PG. Yesterday my laptop was until at night when I was editing some text file, it suddenly hang, (Not exactly because edit text file cause this error, just to clarify what I was doing) fine, then I was frustrated, so I shutdown my laptop and went to sleep. But today...
Heya every1 wasnt sure where to post this, hope u guys can help me. My computer randomly shutdowns when I use it for a while maybe 2hrs or 3, reboots by itselfs and windows cannot boot back, getting a blackscreen and nothing happens, So i manually turn it off and turn it on again to make it work....
Hi all, successfully installed windows 8 (32-bit),but after booting i am not able to access anything as black screen comes on, on each and every mouse movement...when i play any video content the screen totally turns into black ,i cant see anything also........at some how i try to...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook