Windows 8 and 8.1 Forums


Lenovo G50-30 Dual Boot Windows 7, 8.x - IMPOSSIBLE!

  1. #1


    Posts : 2
    Windows 8.1

    Lenovo G50-30 Dual Boot Windows 7, 8.x - IMPOSSIBLE!


    I have come to the conclusion that it is impossible to configure this laptop to dual boot Windows 7 and 8.1, unless anyone knows better. The issue seems to be with the BIOS settings which appear to be mutually exclusive to booting either Windows 7 or Windows 8.x – but not both.

    Whether opting for a MBR or GPT configuration, or installing Windows 8 directly from USB media or within Windows 7 the issue remains.

    I ‘downgraded’ the pre-installed, bloatware ridden Windows 8.1 on this laptop to a clean install of Windows 7 Pro with no problems using default Windows 7 BIOS settings (Win 7 OS, load default settings) on a 500GB partition using DISKPART as per directions on this site. The problem occurs when trying to install Windows 8.1 on the remaining unallocated 500GB partition on my hard drive using these Windows 7 optimised BIOS settings. When booting 8.1 directly from USB (downloaded 8.1 – same version - using Windows media creation tool as I have OEM key in BIOS) the installation will freeze (no mouse pointer) on the initial ‘select keyboard layout’ screen. If I attempt an installation from within Windows 7 it’ll get as far as to when it reboots then hang.

    Sure, I can load Windows 8 optimised settings in BIOS and then install 8.1. Problem is then when I select 7 from the bootloader, booting will freeze during the formation of the Windows logo with a BSD 0xA5 BIOS in system not fully ACPI compliant.. error – and there’s no ACPI settings in BIOS. If I then change back to Windows 7 optimised settings, I’ll get into a ‘Your PC ran into a problem and needs to restart...’ loop. I’ve updated BIOS from A7CN40WW to the latest A7CN43WW to no avail. I’ve also attempted an GPT/UEFI install and run into the same issue, and I’ve tried about ever permutation of BIOS settings available.

    Any help here would be greatly appreciated as I’m tearing my hair out over this one.

      My System SpecsSystem Spec

  2. #2


    Posts : 2,690
    Windows 3.1 > Windows 10


    windows 8 uses a partition that windows 7 does not so you need to create an extra 350mb partition at the end of the disk
      My System SpecsSystem Spec

  3. #3


    Posts : 2
    Windows 8.1


    Quote Originally Posted by KYHI View Post
    windows 8 uses a partition that windows 7 does not so you need to create an extra 350mb partition at the end of the disk
    Thanks for your input but can you please elaborate? You mean simply create a basic 350MB partition after the Windows 8 partition??? I don't see how this could help as I can't even install Windows 8 with Windows 7 optimised settings.
      My System SpecsSystem Spec

Lenovo G50-30 Dual Boot Windows 7, 8.x - IMPOSSIBLE!
Related Threads
Hi , my problem is that this new pc , that i got for 2 days , y50-70 , boots so slowly. It is literally 65 seconds. And i have no idea why..... Cant i enable somewhere some fast boot setting ? please help , this performance is terrible...
Hi I recently felt the urge to experiment with Linux and installed Ubuntu Mint and tried to set up dual booting. However I seem to have only suceeded in preventing Windows booting at all. I cannot get into the recovery drive to undo my wrong doing. How can I reset the windows boot manager...
My computer has Windows 8.1 Pro x64 on an SSD. It's that free Windows 8DL MS offered before Windows 8 was released. My son did the 8.1 upgrade. This is the boot drive. The second OS is Windows 7 Ult. x64 on an HHD. Until last week, the SSD had Windows 7, and 8 was on the HDD. The SSD is...
I've just had a new Lenovo Core i5 g500 arrive to test during Best Buy's 2 week return policy period. I've shrunk C, updated to latest BIOS, reset BIOS Boot tab to DIsable Secure Boot, UEFI choice. I then can only get into BIOS menu via Windows 8 Advanced Startup settings since no hotkeys...
Hi all, I have a laptop with pre-installed Win8x64 and wanted to try dual booting with an additional Win7x64 VHD install (on a single physical disk), in order to challenge performances. Everything ran quite fine (repartitioning, VHD attachment, install). But, at bootup-time, though I got the...
This happened about two days ago. By going in chronological order: I used to have a dual-boot setup, a Windows 7 and Windows 8 on two different IDE 80GB hard drives, named Drive A and Drive B, respectively. Both of these hard drives are quite old, and I'm worried that it may be near the end of...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook