Windows 8 and 8.1 Forums

New HDD, broken MBR (no bootable device found)

  1. #1

    Posts : 6
    Win 8.1 x64

    New HDD, broken MBR (no bootable device found)

    I've recently replaced my secondary HDD in HP Pavillion dv7 (primary is SSD@W8.1) and as soon as I booted up computer, I got error "no bootable devices found". The first thing that I tried out was bootable USB with Windows 8.1 whereas I ran "automatic repair" several times, without any luck.

    Then I opened up command prompt under advanced menu and ran:
    bootrec /fixmbr
    bootrec /fixboot
    bootrec /scanos
    bootrec /rebuildbcd

    None helped, probably because of "element not found" error. I also tried with diskpart where I manually selected (see screenshot) SSD system partition for active one, but still without any luck.

    I'm really out of ideas, nothing seem to work. I also created bootable Minitool Parition Magic USB and ran Rebuild BCD from there and it still didn't help.

    What else could I do, this is really frustrating?

      My System SpecsSystem Spec

  2. #2

    San Jose - California
    Posts : 2,847
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64

    Windows Boot Manager might be in your old HD. Re-connect your old HD and set it to the first boot device in BIOS to see if it will boot again. If succeeded then download: EasyBCD Portable | Portable X Apps. Run it, and follow the screen shot to move the Boot Manager to C: drive (SSD), disconnect your the old HD then try to reboot again.

    NOTE: From the screen shot, replace Z: to C:

    Click image for larger version
      My System SpecsSystem Spec

  3. #3

    Posts : 1,121
    Windows 8.1 x64

    It looks like you have set the first partition on the SSD as active. I assume this is the Windows install.

    That being the case, removing other drives as topguncp suggests is always helpful, but it may take 3 runs of a Startup Repair to replace the boot files in that partition. Since this is Windows 8, the Startup Repair option is, I believe, in the second occurrence of an Advanced Repairs option in the Recovery options.

    Or, you could make sure what the OS partition drive letter is and use the command below. You need to use the correct drive letter for the Windows partition, and in the command, I will assume it is C: but use what you show.

    bcdboot c:\Windows /s C:
      My System SpecsSystem Spec

New HDD, broken MBR (no bootable device found)
Related Threads
No bootable device error in Drivers & Hardware
So I recently bought a Kingston 120gb V300 SSD and I've been having some problems. I wanted to put the OS on it so I used AOMEI to clone everything from my 500gb hard drive (I only had about 100gb of data on it) and it seemed to go through the whole process just fine. It started up from the hard...
Solved No boot device found in General Support
Working on a HP Envy M6 laptop. Getting the "no boot device found" error when booting. Only thing I can access is bios. Its a windows 8 preinstalled machine so I do not know the product key nor have an install or recovery disk. I am able to access the drive when hooking up it externally to my...
Hello, I'm trying to install wi8 from a bootable usb device, i've this screen for more than 30 minutes now ..any help ? 25822 it's NTFS formatted.. i set the BIOS as the following: 1st boot dev. USB-ZIP, 2nd USB-HDD, 3rd USB-CDROM i made it via Windows7-USB-DVD-tool
So, I bought a new computer in April, and Windows 8 lasted for about 8 weeks before refusing to start. With the help of another thread here, I managed to get into a dos enviornment and copy my data (about 7700 photos). Who knew that I still remembered xcopy! Anyway that whole sad story is...
Windows 8 unknown device found in Drivers & Hardware
Hi everyone, So first I'll give you basic information about my computer and then I will tell you the rest. First my computer when bought came pre installed with Windows 7. As soon as Windows 8 came out I upgraded to Windows 8. My system is BIOS not UEFI. I have about 3gb ram and 500gb hdd...
Here is what happened. I bought HP Envy dv6 7201tx (i5,6GB,2GB nVidia,750GB,Win8 Pro) I used EaseUS Partition manager to resize "C:" and create a new partition in my notebook. Unfortunately it failed after restart.:shock: And windows failed to load and UEFI told that boot not...
Strange network device found in Network & Sharing
Hi all, Does anyone know who I delete network devices from my local network? For some strange reason there is a phone listed even though no mobile phones are connected to it. Just a little worried. Thanks a lot!
Eight Forums Android App Eight Forums IOS App Follow us on Facebook