Windows 8 and 8.1 Forums


Windows 8.1 Update Error 0xC1900101-0x40017 on Dell XPS 18

  1. #1


    Posts : 2
    Windows 8

    Windows 8.1 Update Error 0xC1900101-0x40017 on Dell XPS 18


    I have a Dell XPS 18 portable all-in-one machine that came with Windows 8, then I updated it to Windows 8.1 without any problems. It caught a nasty virus and I had to restore it to factory settings, which leaves me back at Windows 8.

    I have tried multiple times to install the Windows 8.1 update through the Microsoft Store but keep getting Error Code 0xC1900101-0x40017. I have tried the following but get the same result;

    • Ran all of Windows Updates that would come up
    • Verified that all drivers were up to date. Note: my video driver is NOT a Nvidia but an Intel. I've seen posts stating that this driver needs to be updated in order to fix the problem.
    • Ran Selective Start Up


    I don't know what else to do at this point because I have not been able to find anything online related to my problem. Please advise if you have any suggestions. Thanks!

    FYI: Antivirus running is Avast!

      My System SpecsSystem Spec

  2. #2


    Posts : 187
    Windows 8.1 Pro/ Windows 8 Enterprise


    Hi, many people with your problem blame Avast for preventing Windows 8.1 installation - "Couldn't update to Windows 8.1 - 0xC1900101 - 0x40017" - Microsoft Community. You can try to uninstall Avast and run the Windows 8.1 upgrade.

    Good luck, werty
      My System SpecsSystem Spec

  3. #3


    Posts : 2
    Windows 8


    I ended up calling Microsoft and they were able to guide me through some steps and we were able to fix the issue with the update. I wanted to post these steps in case anyone else is having the same problem.

    • Run sfc /scannow
    • Check for Windows Updates
    • Open Device Manager and update the Network Driver
    • Run all updates in the Windows Store
    • Run Windows Update again
    • Run Disk Cleanup
    • Uninstall Antivirus software
    • Delete all Temp files
    • Run "Prefetch" in the command bar and select all, then delete all
    • Restart the computer
    • Run the Windows 8.1 Update again.


    Once you do all of these and then run Windows 8.1 update, your screen will come to a point where you can see the User ID and the wheel spinning. I thought that the update got stuck but is was still running. This can take a little while (est. 1-3 hrs.) to complete, so be patient and once it's done, you'll have Windows 8.1 on your computer in no time.
      My System SpecsSystem Spec

  4. #4


    i tried this and wow!it worked! now i have windows 8.1 running on my laptop!thanks a lot!


    Quote Originally Posted by werty View Post
    Hi, many people with your problem blame Avast for preventing Windows 8.1 installation - "Couldn't update to Windows 8.1 - 0xC1900101 - 0x40017" - Microsoft Community. You can try to uninstall Avast and run the Windows 8.1 upgrade.

    Good luck, werty
      My System SpecsSystem Spec

  5. #5


    Posts : 1
    Windows 8.1


    Thanks man this work for me but avast is an other issues try to uninstall it before update your windows 8.1 from window 8
      My System SpecsSystem Spec

  6. #6


    Posts : 1
    windows 8.1

    Windows 8.1 Update Error 0xC1900101-0x40017


    Tried what Microsoft requested to Palarin and it worked the very first time I tried it.

    • Run sfc /scannow
    • Check for Windows Updates
    • Open Device Manager and update the Network Driver
    • Run all updates in the Windows Store
    • Run Windows Update again
    • Run Disk Cleanup (before restart)
    • Uninstall Antivirus software
    • Delete all Temp files
    • Run "Prefetch" in the command bar and select all, then delete all
    • Restart the computer
    • Run the Windows 8.1 Update again.


    The only thing I did different was I ran disk cleanup last before restart

    Thank you
      My System SpecsSystem Spec

  7. #7


    Jeddah
    Posts : 72
    w8.1 pro


    Damn that Avast
      My System SpecsSystem Spec

  8. #8


    Posts : 1
    Windows 8.1


    Many Thanks to Palarin, It worked me with the steps you mentioned.
    Initially I got error when upgrading to 8.1 "0xC1900101 - 0x4000D" , I tried around 8 times since 2014 Oct. the first culprit is to uninstall antivirus if other than microsoft defender. Then I got error "0xC1900101 - 0x40017", I followed your steps it worked well.
      My System SpecsSystem Spec

Windows 8.1 Update Error 0xC1900101-0x40017 on Dell XPS 18
Related Threads
I have Asus X54hr with windows 8 pro. I have already updated all my drivers, at least I think so. And I dont have third party antivirus program, only defender, which I shut off before update. Run update with clean boot and gone though several suggestions how to install w8.1 like this...
windows 8.1 error 0xC1900101-0x20017 in Windows Updates & Activation
trying to update windows 8 to 8.1, when I've completed the download and I restart the computer I get an error message saying I need to restore, with error message: 0xc0000225 When I turn off the computer, and back on It says it wasn't able to update to 8.1, and it did changed back to regular...
This update failure has occurred 5 times in the past three days on 32 bit system. My Win 8 update was purchased from MS in Nov. 2013 and installed then. During this recent update process I have updated Nividia card w/latest 32bit drivers and updated motherboard Intel chipset. This morning I ran...
its been bugging me since day 1, I tried many ways to no avail, just curious has anyone got this sorted out?
8.1 install error 0xC1900101-0x40019 in Installation & Setup
8.1 install error 0xC1900101-0x40019 and 0x80070652 and Windows 8.1 installation failed and reverted back to Windows 8.0 I'm lucky the computer even came back to life. I have an Intel HD Graphics 4000 video card, so the review from ADRStudio replied on February 15, 2014 on page 18 could...
I have a Sony Vaio 32 bit machine 4gb RAM. It gets stuck at about 80-84% when updating then it says "Couldn't update to Windows 8.1 - 0xC1900101 - 0x40017" I haven't ever been able to find decent info on the actual microsoft site. I have no devices plugged in, no partitions, etc. Why is this...
from 8 pro 64bit (with media centre) to 8.1, tried many times, no luck, always end up getting the same error code 0x20017, then rolled back to 8, every driver has been updated and there no external driver whatsoever, any help, please.
Eight Forums Android App Eight Forums IOS App Follow us on Facebook