Windows 8 and 8.1 Forums

Installing W8.1 - Legacy vs. UEFI - Dell XPS15 - Problem!

  1. #1

    Installing W8.1 - Legacy vs. UEFI - Dell XPS15 - Problem!

    I'm new to Legacy and UEFI terminology, so please go easy...

    Dell XPS15 with Samsung 840 250GB SSD (replaced original mechanical drive) + 32GB mSATA drive (still present). It was set up to boot from UEFI when the Dell technician installed the OS on the new Samsung drive. Am I correct in saying the mSATA drive is not being used at present as the new Samsung SSD replaced the original mechanical drive?

    Problem: Today I've wiped the 250GB SSD and installed W8.1. Problem is I installed it in Legacy mode as I couldn't get the W8.1 DVD to boot in UEFI mode. I think this was a mistake. I thought I could switch it back later from legacy to UEFI. The laptop will not boot now in UEFI.

    Is there any way to switch back to UEFI for faster booting? I have a macrium reflect image of the new install, or would this just use Legacy again?

    Is a complete reinstall needed, this time in UEFI mode and via USB?


      My System SpecsSystem Spec

  2. #2

    Posts : 1,121
    Windows 8.1 x64

    You need to install as UEFI. The DVD will boot as UEFI, just select it with that designation in the Boot Device Menu then make sure and hit a key if it is necessary. If you get a message about the SSD being the wrong configuration, you may have to remove all the partitions on the drive in the partition selection window so it can be configured as GPT.

    You may want to set the system back to a Secure Boot configuration so it won't even show the legacy boot devices.

    The 32 GB drive was the acceleration drive for the HDD and you do not need it when using an SSD. It did not have software installed, but was being used as a cache for the HDD.
      My System SpecsSystem Spec

  3. #3

    So basically wipe the drive and start again? No way of saving a days work with the ISO and all the software I'd reinstalled?

      My System SpecsSystem Spec

  4. #4

    Posts : 1,121
    Windows 8.1 x64

    You could try copying the OS partition somewhere and then copying it back after you do the new install. Not sure if that would work or if it did, whether your system would be stable.

    Maybe someone else will have more information.
      My System SpecsSystem Spec

  5. #5

    Quote Originally Posted by Juice370 View Post
    So basically wipe the drive and start again? No way of saving a days work with the ISO and all the software I'd reinstalled?

    Yes, in order to have a UEFI Boot your system has to be UEFI and disk GPT. You will have to reinstall and during the install Hit the F10 Key this will bring up a Command Prompt you will use Disk Part to Clean your SSD.
    Put your DVD in and Start up. You'll have to find out what Key Dell uses to bring up a boot menu. Asus is Esc I don't know what Dell uses.
    At the boot menu select UEFI DVD/CD drive
    once the windows files finish loading and the install window opens hit the F10 and bring up the Command Prompt
    list disk
    Select your Disk
    Convert to GPT
    and continue installing windows 8 as normal. You will have a UEFI Booting install of window 8
    On first boot if you have more than one drive, you may have to hit that KEY that brings up the Boot Menu, select your SSD that should be the last time you'll need to do that if you do.

    Here's a better Guide I think I missed a couple of steps!!
    Booting and partitioning of GPT for Windows 8:
    1.Boot from the Windows 8 install media (You must initiate this boot from a device labeled as a UEFI device, or the installation of Windows 8 will produce an error that the OS cannot be installed to a GPT partition) These UEFI boot devices will have a prefix UEFI: "name of your device", and show as a boot option in your UEFI.
    2.After booting to the UEFI device you see the Install Windows 8 screen, press Shift + F10 to open a command prompt.
    3.Type Diskpart, press Enter
    4.Type List Disk , press Enter
    5.Type Select Disk # (where # is the number your drive shows up as), press Enter
    6.Type Clean, press Enter
    7.Type Convert GPT, press Enter
    8.Type Exit, press Enter.
    9.Close the Command Prompt window.
    10.Click the "Next" button.
    11.Click the "Install now" button.
    12.Put in your product key and click the "Next" button.
    13.Accept the terms and click the "Next" button.
    14.Choose "Custom: Install Windows only (advanced)."
    15.Select the partition and click "Drive options (advanced)"
    16.Click "New" and then click the "Apply" button. Four partitions should appear. Click the bottom partition.
    17.Click the "OK" button and then click the "Next" button.
    18.From then on follow the on screen instructions till you get to the desktop.
    Note: If you can't boot after the install you need to make sure the boot is set to "Windows Boot Manager" in the UEFI. Also, important info.
      My System SpecsSystem Spec

  6. #6

    I've followed your instruction to the letter. However the Samsung 250GB SSD (main drive) isn't showing up under UEFI boot options, it's only under Legacy. This drive is GPT in diskpart. Windows installed to this drive but now on boot it's showing both a W8 (the new install from DVD) and W8.1 (which was the previous install pre "clean").

    Any thoughts please?
      My System SpecsSystem Spec

  7. #7

    I've now completely wiped the 250GB SSD with parted magic, set the Boot Mode to UEFI with Legacy OPROM; Secure Boot Off as this is the only option left to try. Now when it boots there are 4 windows options. Where are these things installing, on the mSATA cache drive? I now have 4 OS installed somewhere. The main SSD is GPT but its not EFI in Computer > Manage.

    I'm lost. Should I boot from USB instead?
      My System SpecsSystem Spec

  8. #8

    Posts : 77
    Win 8.1 Pro x64

    This may not work for you at this point, but Macrium has a repair bootup feature. If you get the SSD installed with Windows again and you can't boot to Windows then that might help. It worked for me before.
      My System SpecsSystem Spec

  9. #9

    I just don't understand why on boot its now showing 4 x Windows OS, which aren't even there really. The main SSD has just 20GB taken with Windows install and only the 1 partition.

    Is there a way to clear the boot loader or whatever its called? I hate Dell more and more each time i mess with this thing. I'm a send them a bill for 2 days labour!
      My System SpecsSystem Spec

  10. #10

    OK EasyBCD did the trick. Now to find out why UEFI is not working.
      My System SpecsSystem Spec

Page 1 of 5 123 ... LastLast
Installing W8.1 - Legacy vs. UEFI - Dell XPS15 - Problem!
Related Threads
I have an Acer V3-731. Owner's nephew somehow put W-8 Enterprise on. Received a complete set of Recovery CDs from Acer. I want to do a complete recovery, no data. First CD, "System" started and said needed UEFI The BIOS is set Security Supervisor Password-Clear Secure Boot Mode-Standard
and if so, will it perform slower? Or only boot time will be affected? Any other disadvantage of doing so? Thanks
Solved Switching from Legacy BIOS to UEFI in Installation & Setup
Hello, Right before I performed a clean install of Windows 8.1 x64 on my Inspiron 3520, I switched to the Legacy BIOS *facepalm*. When I enter the legacy BIOS and enabled "secure boot", I performed a restart that gave the following message "internal hard disk drive not found, to resolve this...
So my computer is a Windows 8 Laptop, with UEFI on it..... I want to have Legacy instead of UEFI, and I was told on this site that I could do it, but I needed to reinstall Windows 8..... Any help with this?
I Made a bootable usb drive...using ROFUS..(i.e, UEFi supported):thumb: But this Laptop Fails to boot from usb drive... It Just Boots to Installed Os.. Please Help me to Resolve this Issue.. i Want to Install Windows 8..ASAP :(:confused: :cry:
Uefi to legacy mistake :( in General Support
My system: acer v5 471p-6843 windows 8 64 bit So basically I was messing with my bios settings and I changed it to uefi to legacy and when I restart it it says no operating system with that pxe When I try to boot into bios via f2, f12 , esc , del all of them don't work. Now I'm stuck unable to...
Solved UEFI/Legacy in General Support
I am not a happy camper with Windows 8. I am confused with the Legacy and the UEFI boot methods. The reason I am confused I think, is because I read to darn much on the Internet. One bit of confusion is with respect to changing from UEFI to Legacy. It would appear from some comments that if I...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook