Windows 8 and 8.1 Forums

Installing W8.1 - Legacy vs. UEFI - Dell XPS15 - Problem!

  1. #21

    Posts : 1,121
    Windows 8.1 x64

    So Dell had the system set back to the AHCI controller? I suppose a reboot after replacing the drive will tell if the old drive will boot like that. You may end up setting it back to RAID.

    Wiping the mSATA drive will delete your ability to boot into your current install... up to you.

    When you do the bcdedit, make sure and use the full command.

    bcdedit /enum all

    If you want to put it on your desktop as a text file, use this command.

    bcdedit /enum all > %userprofile%\Desktop\bcdtext.txt

    The OS Loaders are not always grouped together, so look through the listing for the Ubuntu.

      My System SpecsSystem Spec

  2. #22

    Excellent info. Yes the Ubuntu is on volume 5. Why it won't delete permanently with easybcd is anyone's guess. While the laptop is for sale I'm going to set it up with the SSD and then the original SATA drive to ensure it works. Then I'll bang the SSD 'as is', in my PC (ASUS Z87-Pro) when it sells and put the original SATA drive back into the laptop. It may take a while to shift.

    Please see the doc here if you have a minute to spare:

    Having seen the doc, would you once again advise me to start by wiping the bootloaders and then reinstalling the OS following this guide: UEFI (Unified Extensible Firmware Interface) - Install Windows 8 with

    Thanks a lot
      My System SpecsSystem Spec

  3. #23

    In addition to the above, how is the best way to unbind the main SSD from the cache SSD so that I can install 'all' of Windows 8 on the main SSD without the EFI going onto the mSSD cache like it has done in the past? I now see this is the real issue. Is it a case of physically disconnecting the mSSD drive while installing Windows on the main SSD?

    I've found some good articles on how to set up the Intel Smart Response Technology AKA RAID again so I think this bit will be pretty easy:

    Enabling 32GB SSD Cache on XPS 2720 - Desktop General Hardware Forum - Desktop - Dell Community

    Intel Smart Response Technology Configuration | Dell US

      My System SpecsSystem Spec

  4. #24

    Posts : 1,121
    Windows 8.1 x64

    If I understand, the only entry which is bothering you is the Ubuntu entry. You an remove that. You have other things which could be removed, but it won't hurt to leave them.

    If you want to check which ones are important, start with the current OS Loader. Look at the recoverysequence and find the ramdrive which is set up for it. Then use the GUID number in it to find the Device options entry. But again, leaving the other entries alone is probably the safest choice.

    You enable or disable the mSATA by using the Intel utility and disabling Acceleration. When you go through the utility you should be able to understand how it works. Just an advisory, but if the mSATA were to still being used as a cache, when you disable acceleration, give it some time to unwind the configuration, which may take a few minutes.
      My System SpecsSystem Spec

  5. #25

    The Dell guys did disable acceleration last year before switching the SATA mode to ACHI. I definitely recall this. But why is the EFI installing on the cache drive if its disabled, this is the problem I see now?

    I need to and somehow unbind the cache drive (maybe physically disconnect it?) in order to install the FULL OS on the main SSD only without it putting EFI on the cache again - no idea why it did this. Then use the Samsung SSD as is for now until its sold and then simply put the SATA drive back in and activate ISRT and this will pick up the cleaned cache drive.

    For the cache drive and setting up ISRT they recommend cleaning the cache in Diskpart but not formatting it, so that the ISRT will pick it up again when back in RAID mode at re-sell time.

    I may as well get it all sorted now while I'm in so deep with regards time.
      My System SpecsSystem Spec

  6. #26

    Posts : 1,121
    Windows 8.1 x64

    If acceleration is disabled, the mSATA is just another drive. If it is listed as first in the Bios priority, it will be considered the primary drive and get the EFI partition.

    The normal process is to install the OS to the HDD, then enable acceleration. But you have to make sure you are installing to the HDD as the primary drive.
      My System SpecsSystem Spec

  7. #27

    Because ISRT AKA RAID is disabled in the BIOS and the Rapid Storage Tech software not doing much at present - this should not be pertinent while working with the Samsung SSD so I'm told. I tried switching ISRT back on last night in the BIOS and of course it wouldn't boot as it has no cache drive to use - this needs to be completely empty according to the Dell forum. And it's not empty because of this damn EFI which seems to insist on installing on the cache drive, whereas the rest of the OS goes on to C as expected. I'm still stumped as to why this would happen, maybe it's inconsequential now as I'm starting from scratch and wiping the lot.

    Because I'm using an SSD as main drive, not cache - ISRT is disabled, won't work. So I'll start formatting everything now and remove the cache to ensure the OS installs fully on the main SSD C drive. I'm still not 100% if this is the only way to unbind the cache from main drive?
      My System SpecsSystem Spec

  8. #28

    Hafnarfjörður IS
    Posts : 4,376
    Linux Centos 7, W8.1, W7, W2K3 Server W10

    Hi there

    1) Go to BIOS
    3) Now set ALOW LEGACY BOOT (menu might have slightly different expressions but if you allow legacy boot then you can boot both UEFI and NON UEFI systems).

    If you now want to have a UEFI OS - ensure the boot HDD in the computer is GPT formatted. Then simply install the OS.
    If you want a Bog standard OS - format the HDD in MBR mode. Up to you.

    I've found on laptops usually I prefer to have the NON UEFI system -- I often make PORTABLE Linux systems on external devices and if you have a UEFI OS the Linux boot loader gets written to the laptops HDD rather than to the external device. This can screwup Windows boot. However that's your choice. The thing is to ENSURE LEGACY BOOT if you want to be able to boot any type of OS from an external device and above all disable PROTECTED BOOT.

      My System SpecsSystem Spec

  9. #29

    Easy when you know how!

    I cleaned the 32GB cache drive with Parted Magic 'Secure Erase' feature to ensure sure everything was gone! I then used Diskpart to clean the main C drive SSD. Next was to set up UEFI again in the BIOS and installed the OS from the DVD again on C drive, however this time I used this key process 'Step 7 & 8' here: UEFI (Unified Extensible Firmware Interface) - Install Windows 8 with which I hadn't even seen before. Ensuring that the UEFI drive had 4 partitions and the OS was installed on the correct partition.

    Once the OS was installed, the cache drive was now completely empty (and awaiting RAID / IRST set-up, if and when I sell the laptop and replace the C drive SSD for the original SATA drive). And the UEFI OS was now only on the main SSD C drive 100%. At last!

    So simple when you know...

    Some useful resources for Dell users that have both a Hard Drive, plus a supporting Cache SSD drive:

    ISRT: Intel Smart Response Technology Configuration | Dell US

    Enabling SSD Cache drive: Enabling 32GB SSD Cache on XPS 2720 - Desktop General Hardware Forum - Desktop - Dell Community

    Replacing the SSD Cache drive with a larger SSD drive: Adding msata drive to XPS8500 - Disk Drives (HDD, CD/DVD, Blu-ray) Forum - Disk Drives - Dell Community

    Apologies to anyone trying to extract help from my monotonous thread. Thanks to all for your input esp. Saltgrass.

    I may be back if the SATA drive install (when laptop sells) doesn't go according to plan. :-)

    P.S. Only just seen your post jimbo45, some good tips there, luckily I'd done as suggested, so all looks good at the minute.
      My System SpecsSystem Spec

  10. #30

    Made an emergency boot usb stick in W 8.1.
    Tapping F2 @ logo works only once out of 25 times, and there's no obvious boot order setting in the bios.
    How do I boot from the stick?

    F12 nor F8 work...
    In the F2 bios I saw it's set to "secure boot".
    Should I change that?
      My System SpecsSystem Spec

Page 3 of 5 FirstFirst 12345 LastLast
Installing W8.1 - Legacy vs. UEFI - Dell XPS15 - Problem!
Related Threads
I have an Acer V3-731. Owner's nephew somehow put W-8 Enterprise on. Received a complete set of Recovery CDs from Acer. I want to do a complete recovery, no data. First CD, "System" started and said needed UEFI The BIOS is set Security Supervisor Password-Clear Secure Boot Mode-Standard
and if so, will it perform slower? Or only boot time will be affected? Any other disadvantage of doing so? Thanks
Solved Switching from Legacy BIOS to UEFI in Installation & Setup
Hello, Right before I performed a clean install of Windows 8.1 x64 on my Inspiron 3520, I switched to the Legacy BIOS *facepalm*. When I enter the legacy BIOS and enabled "secure boot", I performed a restart that gave the following message "internal hard disk drive not found, to resolve this...
So my computer is a Windows 8 Laptop, with UEFI on it..... I want to have Legacy instead of UEFI, and I was told on this site that I could do it, but I needed to reinstall Windows 8..... Any help with this?
I Made a bootable usb drive...using ROFUS..(i.e, UEFi supported):thumb: But this Laptop Fails to boot from usb drive... It Just Boots to Installed Os.. Please Help me to Resolve this Issue.. i Want to Install Windows 8..ASAP :(:confused: :cry:
Uefi to legacy mistake :( in General Support
My system: acer v5 471p-6843 windows 8 64 bit So basically I was messing with my bios settings and I changed it to uefi to legacy and when I restart it it says no operating system with that pxe When I try to boot into bios via f2, f12 , esc , del all of them don't work. Now I'm stuck unable to...
Solved UEFI/Legacy in General Support
I am not a happy camper with Windows 8. I am confused with the Legacy and the UEFI boot methods. The reason I am confused I think, is because I read to darn much on the Internet. One bit of confusion is with respect to changing from UEFI to Legacy. It would appear from some comments that if I...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook