Windows 8 and 8.1 Forums

Installing W8.1 - Legacy vs. UEFI - Dell XPS15 - Problem!

  1. #11

    Quote Originally Posted by Juice370 View Post
    OK EasyBCD did the trick. Now to find out why UEFI is not working.
    If your SSD is GPT then UEFI has to be working as BIOS/MBR can not work with GPT.

      My System SpecsSystem Spec

  2. #12

    Posts : 1,121
    Windows 8.1 x64

    If you could get a picture, either from Parted Magic, or Disk Management if you can get into Windows, it might help. Make sure we can see all the partitions so we can get an idea of the configuration.

    It almost sounds like another drive is involved, maybe the 32 GB one..
      My System SpecsSystem Spec

  3. #13

    I have a feeling this is a 'Dell thing' and I also wonder if the 32GB cache drive is somehow getting involved. But, it may even be working as it should now as it boots without issue in all 3 Boot modes below (before it didn't boot to any UEFI modes), however the boot times are the same for each mode, about 18-20 seconds.

    Also it's not showing as UEFI or alternatively EFI (as the cache drive suggests) in Computer Management, image below. Looks like I followed everything to the letter and the C drive SSD is definitely GPT in Diskpart.

    As the image below, this main C Drive SSD (Samsung 840) is not showing under the UEFI Boot (F12), but the original 32GB cache drive (not being used), does. And I have no idea why the Ubuntu option is still showing as Dell supposedly deleted that 12 months ago when they set this new Samsung SSD up for me over remote desktop support. Any ideas how to remove that one?

    Boot Modes:

    UEFI with Legacy OPROM; Secure Boot: Off
    UEFI Secure Boot Off (this one is currently selected)
    UEFI Secure Boot On

    Disk Management:

    Click image for larger version

    F2 UEFI Boot: (not showing the Samsung SSD = C Drive)

    Click image for larger version

    F12 Boot Modes:

    And this is how Dell left it 12 months ago, post removal of SATA drive and install of new Samsung 840 SSD: (I took this photo pre-format/install yesterday). They left the 32GB cache drive in situ.

    Click image for larger version

    What is the Ubuntu option? Basically when I bought the Samsung 840 SSD 12 months ago to replace the original SATA, I tried to set up a dual boot, it didn't work and that's why I phoned Dell. So we agreed to replace the original SATA with the new Samsung, leave the 32GB cache in place (for when I sold the laptop to replace the SATA), and just wipe Ubuntu and start again with a clean W8 install on the new Samsung 840 SSD. This is supposedly what Dell did.

    Do you have enough to go on to confirm if UEFI is now working and if the 32GB cache drive is somehow interfering, maybe even that Ubuntu option, and how to get rid?

    Attached Thumbnails Attached Thumbnails Management.png  
      My System SpecsSystem Spec

  4. #14

    San Jose - California
    Posts : 2,847
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64

    Yes, you are running in EFI mode. However, with mSSD connected, Windows installation put the EFI System Partition on it and the Recovery Partition right after the C: Drive. In addition, there is a hidden 128MB unallocated partition which Disk Management does not show. To find out where it is, you need to run diskpart then type: List Disk, select disk # where # is disk number, list partition
      My System SpecsSystem Spec

  5. #15

    Initially I thought the EFI on the mSSD was just there from the original setup. Is any of this a problem, or is it running optimally now even though it's on the cache drive? Also should I switch it to 'Secure' or is this not required?

    And can I do anything to get rid of the old Ubuntu install on the mSSD?

    Diskpart says that the 128MB is on the main C Drive. Problem or OK?

    Click image for larger version

    Thanks a lot
      My System SpecsSystem Spec

  6. #16

    Posts : 1,121
    Windows 8.1 x64

    The picture is of a Dell XPS system, with the 32 GB mSATA drive. You don't see the mSATA because it is set up as RAID in order to take advantage of the Intel Smart Response Technology. You control that technology from the Intel panel in the hidden icons on the taskbar.

    It looks like Dell, reset your system in a strange way, and doing it remotely is probably pretty hard. So I suppose it is up to you how to proceed. I would reinstall, but the system will run the way it is. You can clear the Boot loader by using bcdedit.exe.
    Attached Thumbnails Attached Thumbnails DskMgmt5.PNG  
      My System SpecsSystem Spec

  7. #17

    Basically a shambles since Dell set it up, and the bootloader according to bcdedit is on C drive. So I'm putting the old SATA drive back in today and its going on eBay. Had enough of Dell and faffing about.

    Thanks for your detailed help guys. Appreciate it.

    I may be back...
      My System SpecsSystem Spec

  8. #18

    Posts : 1,121
    Windows 8.1 x64

    Just putting the old hard drive back in may cause some problems. So first, when you boot with it in, make sure the system is booting to that drive and not the mSATA. You probably need to go into the bios and set the Windows Boot Manager on the HDD as the first boot priority.

    You may have error messages concerning the mSATA. The system probably still shows the mSATA as in a RAID configuration with the hard drive. During boot, you may have the opportunity to break that link in a RAID OPRom or use the Intel Rapid Response Utility in the hidden icons on the taskbar to disable acceleration on that system. A best practice might have been to unwind that configuration before you removed the HDD originally.

    Bcdedit will show a system looking at the EFI partition for the Boot Manager, then the winload.efi on the C: partition..this is normal.

    Anyway, good luck.
      My System SpecsSystem Spec

  9. #19

    Yeah thanks, I've had a read online about the SATA setting needs to be changed from ACHI back to IRST. Dell definitely worked with the IRST and disabled it for me, only the Rapid Storage was left on my machine and the Rapid Start one was removed I believe, not compatible. I'm ready to make the switch later.

    One thing that is really annoying is this Ubuntu bootloader, it created all the hassle in the first place and may cock up the cache reactivation. I can see it in EasyBCD as the main bootloader (1 of 3) and I can delete it, but on each restart, it reappears. However it's not visible via bcdedit. I just hope that when setting up Intel Rapid Start again, it will format this cache drive where it resides and remove the thing. But bcdedit and easybcd both tell me that the Windows bootloader is on C, which is what we wanted.

    Is it possible to wipe the cache drive pre IRST install/activation or not?

    Thanks as always
      My System SpecsSystem Spec

  10. #20

    You're probably right about it still being in RAID, hence the nonsense experienced. I went to Dell as I had no clue at the time, and it was 12 months ago so not sure exactly what they did, but I do recall them disabling the IRST as above. But having said that everything points to it still acting in RAID. RAID is off in the Bios as we ll though. Think we'll blame it on Dell or that Ubuntu install which I did.
      My System SpecsSystem Spec

Page 2 of 5 FirstFirst 1234 ... LastLast
Installing W8.1 - Legacy vs. UEFI - Dell XPS15 - Problem!
Related Threads
I have an Acer V3-731. Owner's nephew somehow put W-8 Enterprise on. Received a complete set of Recovery CDs from Acer. I want to do a complete recovery, no data. First CD, "System" started and said needed UEFI The BIOS is set Security Supervisor Password-Clear Secure Boot Mode-Standard
and if so, will it perform slower? Or only boot time will be affected? Any other disadvantage of doing so? Thanks
Solved Switching from Legacy BIOS to UEFI in Installation & Setup
Hello, Right before I performed a clean install of Windows 8.1 x64 on my Inspiron 3520, I switched to the Legacy BIOS *facepalm*. When I enter the legacy BIOS and enabled "secure boot", I performed a restart that gave the following message "internal hard disk drive not found, to resolve this...
So my computer is a Windows 8 Laptop, with UEFI on it..... I want to have Legacy instead of UEFI, and I was told on this site that I could do it, but I needed to reinstall Windows 8..... Any help with this?
I Made a bootable usb drive...using ROFUS..(i.e, UEFi supported):thumb: But this Laptop Fails to boot from usb drive... It Just Boots to Installed Os.. Please Help me to Resolve this Issue.. i Want to Install Windows 8..ASAP :(:confused: :cry:
Uefi to legacy mistake :( in General Support
My system: acer v5 471p-6843 windows 8 64 bit So basically I was messing with my bios settings and I changed it to uefi to legacy and when I restart it it says no operating system with that pxe When I try to boot into bios via f2, f12 , esc , del all of them don't work. Now I'm stuck unable to...
Solved UEFI/Legacy in General Support
I am not a happy camper with Windows 8. I am confused with the Legacy and the UEFI boot methods. The reason I am confused I think, is because I read to darn much on the Internet. One bit of confusion is with respect to changing from UEFI to Legacy. It would appear from some comments that if I...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook