Windows 8 and 8.1 Forums

"Error. - 1603 Fatal Error during installation"

  1. #1

    Posts : 2

    "Error. - 1603 Fatal Error during installation"

    Hi All,

    This forum was recommended by a friend for honest and helpful answers. Hope someone can help me. I have only basic/medium computer skills so I have hit a wall with this problem. My laptop is hp and running windows 8.

    I have received software from a friend via CD. The software is Trimble Terramodel 10.12 - Software used for surveying and other Civil Engineering functions. When I load the CD, locate the set.exe file, and run it, the installing gets to approx. 45% and then stops and a window displays the message
    'Error: - 1603 Fatal error during installation
    Consult Windows Installer help (Msi.chm) or MSDN for more information'

    When I type the problem into google I am directed to download this, that, and the other to fix the problem which are obviously fake advertisements.

    My question is:
    1.) Is the setup file corrupted etc. and beyond repair?
    2.) If file can be repaired, can someone with limited computer skills such as myself do this?

      My System SpecsSystem Spec

  2. #2

    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit

    Hi pmitch123 and welcome to the forum! First question is this a copy or original CD? If a copy it could very well could be corrupted.

    Also, make sure all drivers are up to date including graphics, BIOS too. I would then run a memory test and see how that goes.

    You could try installing it in compatibility mode. Right click on the .exe and select "Troubleshoot compatibility".

    I see it was made for older OS here: Installing Terramodel 10.12
      My System SpecsSystem Spec

  3. #3

    Posts : 2

    Hi popeye,

    The copy I received is a copy.! All drivers are up to date as far as I can see.... tried running in compatibility mode but no joy.!
      My System SpecsSystem Spec

  4. #4

    Posts : 1

    Terramodel Installation

    If you would like to send me an email ( with your address details I can send you the latest Terramodel Installation (10.61J) DVD.
      My System SpecsSystem Spec

"Error. - 1603 Fatal Error during installation"
Related Threads
Hi Everyone, First post here, allow me to thank you in advance for your good help - people like me who have limited information on diagnostics and repair owe a deep debt of gratitude for your service. :) I own an Acer Aspire V5-571P-6815, which has put up the Recovery blue screen of death,...
Hello, Following the forum guidelines I am posting a compressed file from your SF Diagnostic tool. This was done shortly after a BSOD. Thanks for your support in helping me understand what is the cause of those frequent BSOD. Joce
"Activation error not found", error 0xC0000022 in Windows Updates & Activation
Hey guys, I'd really appreciate some help here. Much thanks in advance to anyone who can solve this problem... I took my Acer laptop into a repair shop to fix a broken power button and ever since then Windows 8 has been asking me to activate. I don't know how this happened as the repair guy...
Hi every one i bought my windows 8.1 copy last month and ever since i wasn't able to install dropbox i tried many many times downloading the application from the official site but keeps giving me this message during the installation "Dropbox wasn't successfully set up" check the attachment i...
hello all. I just got my new pc with MS Windows 8. I tried to set up the "People" app and I keep receiving an error which tells me that "Your password has changed. Please enter your password." Howvever there is no place to re-enter my password nor did I change my password. Since I get...
can't install VIA HIGH DEFINITION(HD) AUDIO DRIVER in Windows 8 Dev. Preview x64.tried 4 to 5 different versions.but none of them would install.i can't get FRONT PANEL HEADPHONE output with default Windows audio.speakers works fine. error : ...
When I tried to click on "internet" I receive a "run time error"/ application error. This has never happened before. I restarted my computer, but the same thing came up. I started to panic, but then I hit my favorites and I do have access to them. Do you think this may have something to do with...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook