Windows 8 and 8.1 Forums

dcom errors. explain this one!

  1. #1

    Posts : 27

    dcom errors. explain this one!

    Okay, this isn't a problem but I really cannot work it out.
    Happily had a Windows 8.1 pro desktop. Bought a laptop with 8.1 on also.
    Both work fine, except everything you do on the laptop creates dcom 10016 clsid permission errors, hundreds a day.
    No ill effects so I have lived with it.
    I just re installed Windows on the desktop, now the laptop gets NO errors at all but the desktop gets hundreds?
    What is this gremlin?
    They are both on the same microsoft account and are on a homegroup.
    sooo, I guess the latest addition to the home group gets these errors?
    It's not effecting anything I just wondered how the heck this happened.
    Any ideas?


      My System SpecsSystem Spec

  2. #2

    Posts : 2,191
    Windows 8.1

    It is very difficult to try and explain what you can't see. Is there anything common in those errors? Anyway, take a look here and see if this will give you any clues. If not, I would post a few of those dcom errors and note if there are any similarities among the hundreds you are receiving each day:

    Numerous event id 10016 errors win 8 pro 64 bit
      My System SpecsSystem Spec

  3. #3

    Posts : 27

    Hi, it's literally everything you do. But it doesn't effect performance.
    Example I just opened the Weather app and got 94 "The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID {C2F03A33-21F5-47FA-B4BB-156362A2F239}
    and APPID
    to the user Stratoc\Adam SID (S-1-5-21-3465054690-2783474740-3381997831-1001) from address LocalHost (Using LRPC) running in the application container Microsoft.BingWeather_3.0.1.174_x64__8wekyb3d8bbwe SID (S-1-15-2-2040986369-264322980-3882385089-1970153872-3662121739-3363227934-2464603330). This security permission can be modified using the Component Services administrative tool."

    I tried for three days to fix on the laptop. Ending up re installing.
    It's just bizarre that I have discovered it only does it on the last install on my network.
    I am reinstalling my laptop now to see if it goes back!
      My System SpecsSystem Spec

  4. #4

    Posts : 1,121
    Windows 8.1 x64

    All I can tell you for sure was I was getting those errors during the transition to 8.1. I thought it might be related to the version of Bing Weather being run. If you start the Weather App and then open Task Manager, you can look at the properties information and it shows the version.

    My system, which is a original 8.1 install, shows where yours shows This might be related to your location, not really sure. You might check the versions on the two systems.

    I think I might try uninstalling the App and then reinstalling to see if it helps, unless of course you have already tried that.
      My System SpecsSystem Spec

  5. #5

    If you ever figure this out, please post the solution. I have been dealing with this since updating to 8.1 with no success in finding the answer. Thanks!
      My System SpecsSystem Spec

  6. #6

    Posts : 27

    cheers all, Everything used to create them on the laptop and now I havnt seen one since re installing my DESKTOP? It has to be probably the most bizarre Windows experience I have seen.
    When I do a fresh install I use the 8.1 home disk from the laptop, then add features (only way I can get my license number to work without installing 8 then upgrading to 8.1.
    As it was a fresh install maybe the store will update my apps and solve some of these logs, I havn't been on it today.
    Thanks for the replies.
      My System SpecsSystem Spec

dcom errors. explain this one!
Related Threads
DCOM errors when upgrading to Windows 8.1 in BSOD Crashes and Debugging
DCOM error: The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID {C2F03A33-21F5-47FA-B4BB-156362A2F239} and APPID {316CDED5-E4AE-4B15-9113-7055D84DCC97} to the user NT AUTHORITY\LOCAL SERVICE SID (S-1-5-19) from address ...
I've uploaded 2 images for your reference to my problem. As you can see from the image, for image1(ControlPanel), image2(Mail) , both are enclosed with a white bracket, if im not wrong, the bracket indicated that you can start navigate the pages using up down right left arrows. This feature...
Reagent.xml - explain details in Installation & Setup
In order to backup any reagent.xml I had, and understand how it works, i saved different version of the file: version 1 1.the one inside the USB recovery (recovery partition included) 2.the first one from the original installation inside c:\windows\system32\recovery the same version 1 i found...
Can anyone explain how to retrieve both passwords? in User Accounts and Family Safety
hi all.. I've got a sony viao ultra book running win8.1. My user account is set to open with a four digit pin. Unfortunately, although I know the PIN number, I have forgotten both the user and the admin password. So I can't load any new software as it asks me for the admin password every time. Can...
hey guys I keep getting distributed Com error The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID {C2F03A33-21F5-47FA-B4BB-156362A2F239} and APPID {316CDED5-E4AE-4B15-9113-7055D84DCC97} to the user NT AUTHORITY\LOCAL...
I have had my windows 8 laptop for bout 2-3 months and ever since I brought it I have had troubles with my games and apps staying open. When I am playing games, not sure why but every now and then when I start moving the mouse around it minimizes the game and takes me back to the desktop. ...
I have a folder with python scripts off my c drive. They don't come up when I search by name from the Start (Metro) interface. Is the only way to have things show up is by including their location in the indexing? If not, why don't these "python" files (all with "python" in the name, show up? ...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook