Windows 8 and 8.1 Forums

this is weird

  1. #1


    Posts : 79
    windows 8 single language

    this is weird


    i have to galaxy s2 one of of the can't connect to the pc and the other one can.
    the one which dosn't connect a messege pops up ( the last device you connected to this computer malfunctioned and windows dosen't recognize it

      My System SpecsSystem Spec

  2. #2


    Posts : 11
    Windows 8.1 x64


    xbladeoo2oo3,

    You can try any of the following options in order to troubleshoot your SG2 USB connection (note: since your other SG2 is not having any problems connecting to your PC, it's most likely a phone related issue and not a PC one):

    1. Ensure your SG2 "connect to your PC" is enabled under USB mass storage
    2. Swap out the USB cable.
    3. Uninstall and re-install Samsung Kies (USB Driver) to the latest version.
    4. Try debugging mode via Android.
    5. Clean your SG2 microusb port (ex. toothbrush)
    6. Perform a factory reset on your SG2.

    If none of these options work, it is possible your Galaxy S2 may have a defective microusb port.
      My System SpecsSystem Spec

  3. #3


    Posts : 79
    windows 8 single language


    Quote Originally Posted by Kasv View Post
    xbladeoo2oo3,

    You can try any of the following options in order to troubleshoot your SG2 USB connection (note: since your other SG2 is not having any problems connecting to your PC, it's most likely a phone related issue and not a PC one):

    1. Ensure your SG2 "connect to your PC" is enabled under USB mass storage
    2. Swap out the USB cable.
    3. Uninstall and re-install Samsung Kies (USB Driver) to the latest version.
    4. Try debugging mode via Android.
    5. Clean your SG2 microusb port (ex. toothbrush)
    6. Perform a factory reset on your SG2.

    If none of these options work, it is possible your Galaxy S2 may have a defective microusb port.
    Thank you I will try all that
      My System SpecsSystem Spec

this is weird
Related Threads
Weird icon bug in General Support
Hi, I've been having a weird icon bug for some time now, and i was hoping it would fix on it's own, but no luck. So, sometimes, some icons simply disappear, as shown in the picture below, and it takes some time to load everything, like 1 minute. All of the files shown in the picture below...
Weird USB Problem in Drivers & Hardware
Heya, I've got weird USB problems, and can't seem to work out what's wrong. I'm using Windows 8 x64, all updated, which had been working without problem for about 8 months now. I noticed my internel card reader drives (9 pin USB header) kept disappearing and reappearing quickly, in both My...
Solved Weird Problem in General Support
I'm having an issue I've never seen before. It seems to happen maybe a couple times a day (haven't paid that close attention yet). I'll be sitting there and notice the hard drive activity light is on steady and won't even blink. I can work on the system normally though. However when I try to...
Solved keyboard going weird in Drivers & Hardware
i booted up my pc and the keyboard changed , her i show whats it lik now azerty456* qsdfgh123- wxcvbn any help and i have tried changing it but it doesnt help
Solved Weird Error... Please help!!! in General Support
Can somebody plsss help me with this problem.. I just noticed it today when i try to Unpin one of my programs from the Start Menu.. I'm really having a headache on how to resolve this problem.. Somebody plsss help me :cry::cry::cry::cry:
Weird Weird Problem! in Network & Sharing
I have the strangest problem with my internet since updating to W8. My internet works absolutely fine all day, up until later in the day (not sure what time exactly this happens) but it stops working! It says it is connected but it simple can't find a network. I am connected via LAN to an...
Now things get really weird in General Support
You may remember that Win8 kept mucking up all my partitions as described in this thread. I had originally installed Win8 in my old Vista partition which was a primary active. I thought it may have had something to do with the Vista legeacy. So I completely cleared that partition, made it...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook