Windows 8 and 8.1 Forums

Unable to use built-in ASUS recovery partition

  1. #261

    Posts : 1,121
    Windows 8.1 x64

    The reagentc is working because it is pointing to the Windows 8 Recovery Tools Partition (2) and not the Windows 8.1 Recovery Tools (5).

    Some folks seem to be able to just reset the Recovery partition GUID and it works. When I did my testing, that did not work and I had to change the partition to a Primary GUID, reboot and then change it back to the Recovery GUID. I even had one system which would not change until I did the operation through another install or even bootable media.

    These types of operations go much faster when you use the up arrow key to backup to a prior command in the command window.

      My System SpecsSystem Spec

  2. #262

    Posts : 9
    Windows 8.1 pro

    Quote Originally Posted by genet View Post
    Quote Originally Posted by lancersc View Post
    Attachment 52345

    got this fixed... but still no luck. " some files are missing "still the same problem..
    Note: How do you fix the error message: "Could not find the recovery environment", if the ID for the recovery partition type is incorrectly set to OEM? -> link

    Attachment 52349
    Click image for larger version
      My System SpecsSystem Spec

  3. #263

    Posts : 9
    Windows 8.1 pro

    sorry if im not doing good... im just not that good at this stuff. xD
    and my laptop is pre installed with windows 8 btw.. i want to reset it.
    Sooo first problem was...
    Cannot find recovery environment..
    i did things in this forum. and also replace the reagent.xml and still the same problem.
    Then i did this.. Could not find recovery environment
    now when i reset it says " files are missing ... "
      My System SpecsSystem Spec

  4. #264

    Posts : 1,121
    Windows 8.1 x64

    Some ASUS folks have had some luck with the ASUS Backtracker utility you can download from their site.

    And it isn't your fault the problems arose. Even if you had not used EaseUS, you still would not have been able to Reset.
      My System SpecsSystem Spec

  5. #265

    Posts : 9
    Windows 8.1 pro

    Quote Originally Posted by Saltgrass View Post
    Some ASUS folks have had some luck with the ASUS Backtracker utility you can download from their site.

    And it isn't your fault the problems arose. Even if you had not used EaseUS, you still would not have been able to Reset.
    i actually used easeus.. O.O
    aaand.. i dont have a USB stick.. >.< man this sucks
    but imma try my external HDD..
      My System SpecsSystem Spec

  6. #266

    Posts : 2
    Windows 8

    Hello, I am having the same problem of not being able to Refresh/Reset using the Recovery. You can refer to my attached image for the partitions.

    Need help here badly. Thanks in advance!

    Click image for larger version
      My System SpecsSystem Spec

  7. #267

    Posts : 1
    Windows 8.1 64 Bit

    Need Urgent Help

    Quote Originally Posted by SIW2 View Post
    d/l this:

    slightly different versions.

    extract like this:

    Attachment 35428

    you will have this:

    Attachment 35424

    put your 8.0 winre here:

    Attachment 35425

    Run as admin on cmd file:

    Attachment 35426

    It will ask if you want to d/l recuva to be included. Up to you.

    It also asks if you want to make an iso. Up to you.

    After it has finished ( about 2 mins) you will see a folder called iso.

    Copy all the folders from inside that (not the iso folder itself - all the folders from inside it ) onto your fat32 formatted flash drive.

    Attachment 35427

    Then copy your install.wim, or install.swm files into the sources folder on the flash drive.

    That's it.

    Boot it up and you will get a menu. To install from .swm files, click the SWMINSTALL button on the menu. Browse to the Install.swm file. You will want to select the image called Push Button Reset or similar, it is probably image 2.
    Quote Originally Posted by Qub1 View Post
    Hey, I'm back and I'm happy to say the problem is resolved

    I used your tool and it worked great, until I selected my install.wim file. It said that the file contained multiple recovery images (or something similar) and it gave me the option to choose from a list of about 4 images. I didn't know which one to choose so I decided to come back to the forums to ask. And then I saw the post ariftwister made. EaseUS had set the type of my recovery partitions from Recovery to OEM, and so Windows had trouble finding them (since it was looking for a Recovery partition).

    So I did the following to fix it:
    - Open CMD
    - Type diskpart
    - Type list disk
    - Select the disk with the recovery partition, using select disk # (mine was select disk 0)
    - Type list partition
    - Select the recovery partition, using select partition # (mine was select partition 6). The partition has OEM listed as its type.
    - Then I used set id=27 to set the id to that of Recovery, but since my drive was GPT and not MBR, it didn't work.
    - So, I did some Googling and found that for a GPT disk I had to use set id=DE94BBA4-06D1-4D40-A16A-BFD50179D6AC
    - So I did set id=DE94BBA4-06D1-4D40-A16A-BFD50179D6AC
    - It succeeded, so I again typed list partition and it was now listed as Recovery!
    - Rebooted into the Recovery Environment, and it detected my Restore partition and allowed me to reset.

    I couldn't be happier
    And also thanks to everyone for the help, and even though I didn't fully use your tool SIW, I'm sure it can help others a lot, and I really appreciate you making it.

    I'm going to restore now, and if it succeeds I'll come back here and mark this thread as solved.

    Hello community

    I need your help to try to understand what is going on here, i read all this thread, but everybody has itīs own opinion, so i follow the procedures of this 2 posts

    the thing is that none have worked, the SIW2 method doesnīt take me anywhere, because it simply donīt boot from the pen...., then i tryed the Qub1method and after i put the ID above, nothing happen either, same error/problem, it says that one partition is missing....

    I already checked and i have the partitions ok, i tried also to create a recovery boot, from the windows system restore menu, he bootīs up from the pen, but then same problem, even if i make a bootable pen, he enters the windows blue menu, but he gives me the same error, i donīt know why, since the recovery partition, is included on the bootable pen that i have created.

    Then i have an Image Backup, that i made when i got my Asus G750JX, i try to go from there, i put the windowsimagebackup folder, and the image, in the pen, try to boot with F8, go to restore from image, and doesn't even recognize it, it only says that nothing is in there, and i canīt get access to the pen, where the image is.

    ASUS Backtracker utility, doesn't work either, it simply freezes

    so iīm running out of options here and i really need help, since Microsoft donīt even care about this problem, and i donīt know where do i have to go, to someone give me a direction to a complete tutorial on how can i solve this problem.

    Thank you for your kindness and attention i really appreciated, been all night around this....
    Last edited by AlJourgensen; 01 Dec 2014 at 05:32. Reason: Some errors
      My System SpecsSystem Spec

  8. #268

    Posts : 1
    Windows 8.1

    I don't know if this will help everybody in this thread but it worked for me just now. My problem scenario was an Asus S200E which had been 'upgraded' to Windows 7, from original Windows 8 OEM. The original recovery partition was no longer present, just the 100MB Asus system partition showing. Luckily I have an MSDN license, so I redeemed a key ready to use that, after giving up hope of using the original OEM license key.
    I went to the microsoft site to create the Windows 8.1 installation media: Create installation media for Windows 8.1 - Windows Help

    Followed the steps and installed from the USB key which launched from the BIOS
    Windows 8.1 installed and I was ready to use my MSDN license key when prompted.

    However, I was never prompted and after install the PC Info shows an OEM license key.

    Note - this was performed on a Windows 7 install, on a PC that originally came installed with Windows 8.
    Last edited by bielby; 08 Dec 2014 at 23:46. Reason: additional info
      My System SpecsSystem Spec

  9. #269

    Posts : 2,676
    Windows 3.1 > Windows 10

    Here is what is happening here.. Your OEM created 5 partitions... When you updated to Windows 8.1 took your last partition and created the partitions it needed...

    Now if you want to restore the factory image.. you have to tell you New Windows Installation to use the Recovery Tools and to use the OLD recovery image Partition..

    you have to use diskpart to assign letter=r to the last recovery partition whish you will then find your recovery image (install.wim)

    Once you find that file on the R drive run this command as (admin)

    C:\Windows\System32\Reagentc /Setosimage /Path R:\RecoveryImage /Target C:\Windows /Index 1

    r:\recoveryimage would be what ever folder you may have the install.wim in..

    reboot your pc

    from a command prompt (admin) type

    reagent /info

    you should now see a windowsre refferance
    and an image refferance
      My System SpecsSystem Spec

  10. #270

    Posts : 7
    win8 64 bit

    Quote Originally Posted by lancersc View Post
    Quote Originally Posted by Saltgrass View Post
    Some ASUS folks have had some luck with the ASUS Backtracker utility you can download from their site.

    And it isn't your fault the problems arose. Even if you had not used EaseUS, you still would not have been able to Reset.
    i actually used easeus.. O.O
    aaand.. i dont have a USB stick.. >.< man this sucks
    but imma try my external HDD..
    and i am one of those lucky ones .... .... (backtracker)
      My System SpecsSystem Spec

Page 27 of 54 FirstFirst ... 17252627282937 ... LastLast
Unable to use built-in ASUS recovery partition
Related Threads
I have recently attempted to reset my laptop to factory and i get this issue Computer specs: Asus VivoBook S550CM 8gb Ram 1. 50015 2.50016 HELP, Need more info? please post on thread
Hi all I have an i7 ASUS Ultrabook (HDD is 2xssd in raid0, UEFI, GPT partitions.) which is great but have an issue where wifi profiles don't retain and i'm not too concerned about retaining the data on the ultrabook so after attempting to fix the wifi profiles not saving (Have been through the...
I have some problems with my laptop ASUS K55VD. I had windows 8, but with the store of windows I have updated to windows 8.1. I have tried to use the recovery partition, but every time I try appears a message. Failed to reset your computer. A partition of unity necessary is missing. 48360For...
ASUS Recovery partition in Installation & Setup
Hi All, I've read a lot of posts and a little confused. I upgraded ASUS S400CA to 8.1 . I just need to create a recovery disk with the option of copy from recovery partition which is graded out as many of you know. Can you please provide me with the steps of what I will have to do to create a...
Hello i buy new asus X550CC-XO028H ultrabook with windows 8 preinstalled.I upgrade windows 8 to 8.1 over windows store.I get many erros in event viewer.So now need restore windows 8 from recovery partition.Install all programs and upgrade to 8.1.But i cannot to do this.Windows 8.1 cannot find...
Hello everyone, I'm a technician at TigerDirect, and for one of our services we create recovery media for newly purchased machines. For Windows 8 machines (As I'm sure you know) we cannot create recovery disks, and have to create a recovery drive using a flash drive. On multiple occasions...
My tablet is running fine, but I did something (not bright) which could leave me in a lurch later. Here's what I did, and what I'm looking for. Soon after I purchased my Asus VivoTab Smart, I made a USB recovery disk, complete with recovery partition. Then, to save disk space on the tablet, I...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook