Windows 8 and 8.1 Forums

EFI System Partition missing files, Repair Disk won't boot

  1. #1

    Hello everybody.
    While I was messing around with my laptop, I decided to add on a fourth operating system, Arch Linux. I suppose I was pushing my luck a bit . Anyways, during the installation, I accidentally deleted the EFI system partition from my laptop, which contained the Windows Boot Manager and necessary files to boot. Great. I only made things worse by trying to troubleshoot, and broke grub as well.

    I have a Windows 8 repair disk I made using the Windows 8 built in utility, but it does not boot: the computer turns on, and just hangs at the Toshiba splash screen.
    I also can obviously not access the Toshiba recovery partitions, as they are booted into just like Windows itself.
    I found a bootx64.efi file on one of my system's recovery partitions (Toshiba seems to have some really complex system going on) and placed it in \EFI\boot\bootx64.efi. According to this site, FGA: The EFI boot process., I need to place the bkpbootmgfw.efi (on my system, that was what it was called, but I suspect boot-repair (ubuntu tool) messed something up when I was first setting up grub and the ESP and the bkp stands for backup) back onto the EFI System Partition.

    The BIOS and underlying GPT all seem to be working, as I am typing this from a Linux Mint live USB. If anyone who has a UEFI based system (probably any computer that came preinstalled with Windows 8 has such a system) could acces their EFI partition and upload it for me, I suspect my computer will boot again and from there I can get on to fixing grub. Even better would be someone with a Toshiba computer, as this post (grub2 - Unable to boot Windows 8 after Ubuntu installation - Ask Ubuntu) makes me suspect all Toshiba systems are the same in this regard. Someone with a Toshiba could then provide me with the system specific .efi files which are used to boot into the recovery partition.

    If not, someone with experience with WindowsRE could perhaps tell me where to look for in the various Windows Imaging Format .wim and .swm files I have laying around my recovery partition(s) in order to extract the necessary EFI files. Most pertinent information can be found in this thread: EFI System Partition deleted - can only boot from Live CD / Newbie Corner / Arch Linux Forums . I would also much appreciate if someone was willing to supply a Windows Repair iso that works for them. I will edit this post shortly for the exact error code Windows Boot Manager gives me (i can access it from that lone bootx64.efi file I placed on the ESP).

    Thank you very much for your time and support.
    I put in some files from recovery partition, and now get this:

    Imgur: The most awesome images on the Internet
    Last edited by Brink; 20 Sep 2017 at 23:10. Reason: restored post

      My System SpecsSystem Spec

  2. #2

    Posts : 5,592
    ME, XP,Vista,Win7,Win8,Win8.1

    Someone with a Toshiba could then provide me with the system specific .efi files which are used to boot into the recovery partition.
    You can use the Toshiba Recovery disks to do repairs.

    Did you make the OEM manufacturer's Recovery Disks?

    information   Information

    We always assume you have made your Recovery Disks using the OEM manufacturer's Recovery Media Creator app the first day you had your new PC.
    & made the Startup Repair CD.
    Recovery Drive - Create with USB Flash Drive in Windows 8
    System Repair Disc - Create in Windows 8

      My System SpecsSystem Spec

  3. #3

    I selected "Copy contents from the recovery partition to the recovery drive" when following the built in Windows recovery drive creation. Of course, that drive does not boot. If worst comes to worst, I can purchase the OEM recovery drives from Toshiba.
      My System SpecsSystem Spec

  4. #4

    Posts : 5,592
    ME, XP,Vista,Win7,Win8,Win8.1

    From the Repair CD/USB:
    How to do a Auto Repair:
    Automatic Repair - Run in Windows 8
    Note: You may need to do startup repair 3 to 4 times.
    Startup Repair - Run 3 Separate Times - Windows 7 Help Forums

    How do a Refresh:
    Refresh Windows 8
    Click image for larger version

    How to do a Reset:
    Reset Windows 8
      My System SpecsSystem Spec

  5. #5

    But my drive does not boot. I also tried making one from my desktop (running "stock" window 8, not an oem version), but that one does not boot either.
      My System SpecsSystem Spec

  6. #6

    Posts : 5,592
    ME, XP,Vista,Win7,Win8,Win8.1

    You can order the Microsoft official OEM Recovery disks from the OEM manufacturer's website.
    Toshiba Service Portal - Laptop Recovery Media Services - Toshiba
      My System SpecsSystem Spec

  7. #7

    " But my drive does not boot. I also tried making one from my desktop (running "stock" window 8, not an oem version), but that one does not boot either. "

    When I was dual booting Windows and Linux Mint I had to turn on CSM Legacy mood in my BIOS. This presented me with the option to boot from several devices, DVD, USB flash, Windows Boot Manager, etc. Just a thought, do you have it turned on? It should give you the option to boot from A DVD or Flash Drive. I have an ASUS K55n DS81 laptop.
      My System SpecsSystem Spec

  8. #8

    Well, I tried that, and grub came up, so I can now get into Linux. I still am unsure of the best way to repair windows - the repair drive still doesn't work. Does anyone have an idea why this might be so? Are there alternative repair drives I can download? I have both my OEM product key and one I purchased to upgrade my desktop.
    Last edited by aenda; 30 Nov 2013 at 19:34. Reason: Typo
      My System SpecsSystem Spec

  9. #9

    Posts : 1,121
    Windows 8.1 x64

    Did you really delete the 100 MB EFI partition, and if you did, how did you replace it?

    Any chance you could get us a picture your hard drive partition configuration using a third party partition manager like GParted or Partition Wizard?

    The BCDboot command will normally replace the System partition files and allow you to boot.
      My System SpecsSystem Spec

  10. #10

    I did delete the EFI system partition. I accidentally did it using
    mkfs.ext4 /dev/sda2
    , which, as I understand it, does not in of itself format the partition, but its small size and all the reading and writing done to it means I have probably lost all the files now. I did recover some files using PhotoRec, but most seem corrupted.

    My EFI partition has a folder called \linuxmint, which contains shimx64.efi, which was automatically created by boot repair. It seems to be used for the grub boot loader, but I can only access grub from legacy boot mode (do you know where legacy boot mode looks for files? the MBR?). There is another folder called \EFI. This contains \EFI\linuxmint once more, which has another shimx64.efi, as well as grubx64.efi and a copy of my grub.cfg configuration file. These were also all made by boot repair.

    I also manually made two folders called \EFI\boot and EFI\Microsoft\Boot. I had read online that in Windows NT systems on UEFI, boot files are located in \EFI\Microsoft\Boot\ and I made a copy of a folder called EFI on my recovery partition to that location. I also made a folder at \EFI\boot, which contains bootx64.efi, which I found once more, in the recovery partition, and which was the only file name I actually recognized (my EFI partition used to have \EFI\Microsoft\Boot\bootmgfw.efi, \EFI\Boot\bootx64.efi (both of these took me to windows), as well as \EFI\Toshiba\Boot\bootmgfw.efi, which took me to the recovery partition. (You can see I am rather ignorant as to the inner workings of the boot process).

    Here is a screenshot of gparted : .

    Edit: I just found this, which has sort of dampened my hopes. I suppose that realistically, I just want to find out what my options for boot repair are without purchasing a repair disk. What are possible reasons that mine won't boot?
      My System SpecsSystem Spec

Page 1 of 6 123 ... LastLast
EFI System Partition missing files, Repair Disk won't boot
Related Threads
SFC cannot repair my corrupted system files in Performance & Maintenance
Hello, After getting infected and buying an antvirus and clenaed my system i run "sfc /scannow" and it says some protected system fiels are corrupted but its not able to fix them. Any idea as to what needs to be done plase?
Hey So I did a disk repair for one of my hard drives (not the system drive ) using check disk because I could not open my folders it would say they were corrupted. This followed me powering off my pc while it was shutting down. So after the chkdisk repair my drive was now functioning ok except for...
Hello! I'm new here(obviously). Well, last week I bought a laptop(ASUS N56JR) with a 750gb hdd. And today I went to Microcenter, saw a PNY XLR8 240gb SSD for $100 and bought it. I used a cloning software EaseUS Todo Backup to clone my OS partition of the HDD to SSD(It's only 90GB worth of...
Cannot Boot From Startup Repair Disk in Performance & Maintenance
Hello, I have a Toshiba Laptop Satellite L875D-S7332 Part No. PSKFQU-008003 With Windows 8 x64 Preinstalled. I created a Startup Repair Disk with a DVD. My problem is i cannot boot from this DVD. I changed the Bios to boot from DVD but it still doesn't work! Can Anyone help me? Thank You, heaven5733
On my friend's Dell Inspiron laptop, Windows 8 will not boot. I want to boot to the repair disk to restore an image I had created. F12 on boot does not show the DVD drive as an option. I went into Setup/Boot and disabled Secure Boot, still did not show the DVD as a boot option. I went back to Setup...
Solved System Repair Disk in Chillout Room
So I ended up inheriting a Windows 7 64-bit computer, and unfortunately I can't install any files without the administrator password. I burned a system repair disk from another Windows 7 64-bit computer, and when I put it in nothing happens. Is there some key to running it that I'm missing?
Hello, I am trying to create a system repair disc, and I am getting the message: "do not have the files to create system repair disc". Why? How do I get those files. Never had a problem like this trying to create a system back up in the past. Running Windows 8. Thanks!
Eight Forums Android App Eight Forums IOS App Follow us on Facebook