Windows 8 and 8.1 Forums

Pos Showstopper W8 -- How do I share a USB printer (Printer on W8)

  1. #1

    Hafnarfjörður IS
    Posts : 4,376
    Linux Centos 7, W8.1, W7, W2K3 Server W10

    Pos Showstopper W8 -- How do I share a USB printer (Printer on W8)

    Hi there

    (note Pos in title of post means Possible -- not the other meaning often shortend to pos !!).

    Not being able to share printers easily WILL be a drawback.

    I've run into what I hope is MY error but I can't see any way around this

    Computer is running W8 Development Preview X-64 with a USB Epson 1290 Printer attached.

    Printer works fine -- so no driver probs etc.

    I want now to print from a Wireless Laptop running W7 X-64.

    Normally it's easy between W7 machines or a mix of XP and W7 machines on the W7 remote machine add new local port \\BLACKDOG\Photoprinter

    Then no prop.

    (W8 Hostname is BLACKDOG, old shared name of the printer is Photoprinter).

    On the W8 machine I can't find ANYWHERE to be able to set the printer shared name so not unnaturally the W7 remote machine can't connect.

    I've got round the problem in a bit of a kak handed way -- I've got a W2K3 server VM also running on the W8 machine --so I've attached the USB printer via the VM settings to the VM W2K3 server machine -- now my remote W7 laptop can print.

    (In the VM just disconnect the printer from the HOST and attach it to the VM -- then in the VM enable the printer as SHARED in the usual way and proceed just as if its a physical machine -- I've posted how to share printers between a mix of XP and W7 machines on the W7 Forums).

    Here's the Shared setting for the printer I'm missing in W8 Where I can set the Shared Name

    I hope that this get around isn't necessary but I haven't found a way round it yet -- I'm sure there must be one.

    Click image for larger version

    Last edited by jimbo45; 13 Nov 2011 at 10:47.

      My System SpecsSystem Spec

Pos Showstopper W8 -- How do I share a USB printer (Printer on W8)
Related Threads
Solved Can't Seem To Share Printer in Network & Sharing
New HP 8.1 64 bit laptop. Connected the (non-wireless) Epson printer to the laptop and it automatically set itself up without a CD or any Epson download. Printing worked perfectly. Then I set up file sharing. I wrote down the network sharing key, and specifically turned on printer sharing. I...
Hi: I have 5 pcs with 8. The printer is fully installed in a Windows Vista pc. However only one pc can print correctly. I created a homegroup in this pc and it can print just fine. However when I try to connect the other pcs to the homegroup windows 8 displays say it can do it anymore. ...
Hi there If you use one of these there is a driver for it on the Epson site for Windows 8.1 but download THE DRIVER not the utility. When installing you need to watch the popup window very quickly and select MANUAL when it asks you to choose the port (USB connection). If you don't do this the...
Hi there everyone! Windows 8 machine sharing printer with 8 and 7 machine. Under Advanced sharing settins, I've enabled Network sharing in private, public/guest and all networks and disabled password protected sharing. Under printer properties, I have selected to share the printer under the...
Hello, I have an Epson color 580 printer from like 15 years ago. Worked great with XP. When I tried to print with W8.1, it directed me to save the file as an .xps or something. I couldn't get the .xps to print. I did some reasearch and people said to disable the windows .xps viewer or...
Printer Help in Drivers & Hardware
Hello, Got a problem with printers on my installation of win 8 64bit. I have installed and configured two printers (via TCP/IP ports) and they print ok from applications but nothing shows up in Devices and Printers. I can see the printers in printmanager and from word/illustrator, but not...
Hi, I am running windows8 pro 32 bit, with a Xerox workcentre 3119 laser printer attached to it, by usb. It prints fine. But... I have a homegroup with a windows7 home premium 64 bit machine on it. I did a clean reinstall on the windows7 pc, and now I can't print to the Xerox from the windows7...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook