Windows 8 and 8.1 Forums

sysprep in Windows 8.1

  1. #1

    sysprep in Windows 8.1

    I've been running sysprep on Windows 7 machines for some time. My custom unattend file created for Windows 7 worked with Windows 8 and I never had a problem sysprepping it.

    Enter Windows 8.1;
    When the "old" unattend file didn't work, I gave it little thought and downloaded the latest ADK specifically for 8.1 and created a new unattend file, first with nothing but "CopyProfile=True" and later with all the settings I used under 7. It always failed if I had installed anything, no matter how seemingly simple it was. The only successful sysprep was with a pristine installation of Windows, updated via Windows Update, and a few drivers necessary to make the "bangs" disappear in Device Manager. Success was limited however by the fact that Windows couldn't seem to build a profile for new users, the desktop was blank, and almost nothing I clicked on worked.

    My next step was to install everything in Audit Mode, which I had never had to use before and consequently forgot. This led to a successful sysprep, even with a load of third party applications installed, but I still had the problem mentioned earlier where Windows couldn't build a profile.

    Reviewing articles I had previously looked at I noticed this;
    If you deploy an image using Microsoft Deployment Toolkit 2013 or Unattend.exe and include CopyProfile=true in the answer file, the deployment will fail with a “location is not available” error or each new login attempt will create a new temporary user account profile.To avoid this, do not use CopyProfile=true in the answer file. There is no other workaround at this time.
    From this article;
    Note: The article references Server 2012r2, but it and Windows 8.1 share a code base.

    Sysprep is broke it seems. I ran it again on a fresh image with the CopyProfile entry removed and it all seems to work just fine. The only issue I have is that it resets the default administrator's profile, which may be related to the failure to copy it. You can't copy something that's being changed. (generally speaking)

    Hopefully, Microsoft will fix this by the time 8.1 is released. Meanwhile, maybe this thread will help someone else who's pulling his / her hair out trying to sysprep 8.1

      My System SpecsSystem Spec

  2. #2

    If you update a store app prior to running sharper, we have found that sysprep can then fail.. there are TechNet discussions about this.
      My System SpecsSystem Spec

  3. #3

    Hafnarfjörður IS
    Posts : 4,376
    Linux Centos 7, W8.1, W7, W2K3 Server W10

    Hi there
    Windows 8.1 is still essentially in BETA so (IMO) I wouldn't waste a lot of time trying to do sophisticated things like sys-prepping it / deploying to loads of machines.

    I think your time might be more profitably spent in testing the core features - some of these still need fixing a bit --and IE11 is totally IMO not ready for productive use in any sort of environment -- certainly not a business one where applications often depend on the use of a decent browser --things like ERP software / CRM stuff / Shopping carts etc etc.

    The Windows 8.1 to go is an interesting feature -- you might get more mileage in going that route rather than the sys-prep if you are in an organisation with access to W8.1 Enterprise.

    Ms need though to get its finger out with 8.1 / IE11 -- with the imminent demise of XP I doubt whether many businesses will upgrade to 8.1 directly from XP - especially if it's still a relatively untested OS and of course the whole IE11 nonsense. Ms really needed IE9 / IE10 to work on W8.1 as well as IE11 is still for a lot of people a show stopper.

      My System SpecsSystem Spec

  4. #4

    Quote Originally Posted by pparks1 View Post
    If you update a store app prior to running sharper, we have found that sysprep can then fail.. there are TechNet discussions about this.
    Acknowledged. That's not it in my case. None of them were updated or changed in any way. I saw the articles you're talking about.
      My System SpecsSystem Spec

  5. #5

    Quote Originally Posted by jimbo45 View Post
    Hi there
    Windows 8.1 is still essentially in BETA so (IMO) I wouldn't waste a lot of time trying to do sophisticated things like sys-prepping it / deploying to loads of machines.
    Believe me, I'm putting it through its paces. I consider sysprep to be one of those paces though, so I still hope they get it fixed.
    WTG is in fact my next project. I'm putting this one on hold for now (more on that in my next post) and starting with WTG Thursday morning barring too many fires to put out.

      My System SpecsSystem Spec

  6. #6

    As workaround I installed Windows 8 fresh, installed and configured all my apps and sysprepped it. That worked fine. I then upgraded to 8.1 choosing to keep my settings.

    This worked for the account I created at the OOBE under 8, but when I create a new account after the upgrade, I was greeted with a blank blue screen which reminded me of trying to reason with a teenager.

    After leaving it that way for over an hour, a couple of things started to show up on the screen so I started clicking until I got a few tiles. Clicking the Desktop tile, I was greeted with the same error message I got when sysprepping 8.1 (see the article linked to in my first post)

    This leads me to conclude that the mechanism that creates new profiles under 8.1 is botched. That's why I'm pushing that project to the back burner and working on Windows To Go starting Thursday. (I'm off Wednesday and I have plenty of HoneyDoo's to keep me busy at home)

    I'll post a separate thread about WTG. I'll make it a tutorial if it all works out.

      My System SpecsSystem Spec

  7. #7

    Posts : 1,121
    Windows 8.1 x64

    Since I am not normally involved in Syspreps, I was just thinking about trying one. But I found another article with the same information as your link that mentioned Windows 8.1 specifically.

    You might also note, I was just unable to find your referenced site..may have been taken down.
      My System SpecsSystem Spec

  8. #8

    Posts : 31
    Windows 8.1 Pro

    Hey you're a lifesaver!

    I had the same issue with windows 8.1 clean install using ISO downloaded from Microsoft SetupBox tool. I relocated the Users folder as per User Profiles - Relocate to another Partition or Disk . Then I created the 1st user : worked perfectly.

    Now when I try to create a new user, it fails in JUST the manner you describe : blank screen and minimal functionality, not even explorer.

    So I should be fine if I don't use audit mode? Is that the conclusion? Or is it not possible to create a new user at all in windows 8.1? That would be a MASSIVE shortcoming, I'm sure it would not release that way.

    The linked TechNet site does not hold the info you put there. Nor does any other site seem to talk about it.
      My System SpecsSystem Spec

sysprep in Windows 8.1
Related Threads
Today I used sysprep.exe to rebuild my windows image. But it always said "a fatal error occurred while trying sysprep". Then I went to check log file , it shows that 2015-01-06 21:51:29, Error SYSPRP Package Microsoft.Internal.Media.PlayReadyClient_2.3.1678.1_x64__8wekyb3d8bbwe...
sysprep on windows 8.1 in Installation & Setup
hi all! I have upgraded /updated (whatever it is!) from windows 8 pro wmc to windows 8.1 pro wmc using store free update. I though I will sysprep and keep an image; in order to remove the current user profile I went into audit mode and from control panel --> user accounts successfully deleted...
So it seems Sysprep no longer works when you upgrade to 8.1 So you can't move the program files or users folders in accordance with the tutorial. So has anyone here figured out how to do it yet? or know of a tutorial that does work? thanks!
do i really need sysprep ? in General Support
Hi, i have installed windows 8 on vmware. This is my "master copy" with preinstalled software. Now i want to copy this windows to my laptop or another computer pc. Is it strongly recommended to use sysprep before copy? I will not use a few copies at same time so i'm not afraid of SID conficts....
Source: Removal of Windows 8 built-in provisioned Appx package causes Sysprep to fail
Title says it all. Anyone tried sysprepping a system yet with an unattend file and copying the over the default profile. I tried manually copying over the profile with a tool we have and while it worked with out error, it did not seem to change the default profile.
Eight Forums Android App Eight Forums IOS App Follow us on Facebook