Windows 8 and 8.1 Forums


HDD not detected during Windows 8 installation in UEFI

  1. #1


    Posts : 4
    Windows 8

    HDD not detected during Windows 8 installation in UEFI


    ok well this is a little complicated to explain so m gonna summarize it as much as possible.


    i have a HP Sleekbook 15-B002xx which came with a windows 8 OS installed already. due to some reasons, i tried to shift it back to windows 7. After many unsuccessful tries, i finally managed to install windows 7 by changing my boot sequence to Legacy Boot.
    later on, due to lack of drivers for win 7, i installed, rather upgraded to win 8 which was running on legacy boot (using MBR if im not wrong). now, i want to install a fresh copy of win 8 with UEFI but the problem is when i change my boot sequence to disable legacy boot, then during installation of win 8, i cannot see my HDD ... im using a flash drive to install win 8 which is already in UEFI (i used diskpart for that).
    also, when i use legacy boot and try to install windows, then the HDD appears and when i format the HDD and create new partitions, it creates 3 partitions (System, MSR, Reserved) and the fourth one for OS. i tried installing the windows like this but after install, when i change the boot sequence to UEFI again, it fails to boot


    now, i want to install windows to UEFI... and i really need help with this please ... i hope i have explained the scenario... if anyone would like to ask anything, please do ... as i really need to get this away... and also, i'd like to ask that how can i check if my HDD has been changed from MBR to GTP?


    im not that much expert with this stuff so i hope i have used the terminologies right... awaiting answer people ..


    Thanx in advance

      My System SpecsSystem Spec

  2. #2


    Posts : 5,592
    ME, XP,Vista,Win7,Win8,Win8.1


    Welcome to EightForums.


    Quote Originally Posted by mak712
    change my boot sequence to disable legacy boot, then during installation of win 8, i cannot see my HDD ... im using a flash drive to install win 8 which is already in UEFI (i used diskpart for that).
    also, when i use legacy boot and try to install windows, then the HDD appears and when i format the HDD and create new partitions, it creates 3 partitions (System, MSR, Reserved) and the fourth one for OS. i tried installing the windows like this but after install, when i change the boot sequence to UEFI again, it fails to boot
    You are resetting the UEFI/BIOS firmware to UEFI boot & booting the DVD/USB in UEFI mode, than installing in UEFI mode, than after install you are resetting the UEFI/BIOS firmware to Legacy boot.
    Last edited by theog; 15 May 2013 at 16:15.
      My System SpecsSystem Spec

  3. #3


    Posts : 4
    Windows 8


    see the problem is, if i initially use the UEFI settings in BIOS, then use the UEFI usb to boot the win 8 installer, the installer does not show the HDD to install on. thats why i used the legacy boot, because with legacy, it shows the HDD and allows to create partition and everything.

    also, can you please tell me that "as mentioned earlier, when i format the HDD, it creates 4 partitions, 3 system (unusable) and 1 on which to install windows", does that mean that the HDD is using GTP instead of MBR?
      My System SpecsSystem Spec

  4. #4


    Posts : 5,592
    ME, XP,Vista,Win7,Win8,Win8.1


    Quote Originally Posted by mak712
    also, can you please tell me that "as mentioned earlier, when i format the HDD, it creates 4 partitions, 3 system (unusable) and 1 on which to install windows", does that mean that the HDD is using GTP instead of MBR?
    It means the UEFI/BIOS firmware is set to UEFI boot, the DVD/USB is booting in UEFI mode, & installing in UEFI mode. Also GPT mode.
      My System SpecsSystem Spec

  5. #5


    Posts : 4
    Windows 8


    but see the problem occuring is that when i try to install windows 8 in UEFI boot settings, there is no HDD showing to install on. also, i tried the Diskpart utility from the command prompt of windows recovery utility, it does not show the primary HDD....

    please please help as this is becoming a real issue for me ...

    and also, i forgot to mention that when i install the windows with the BIOS set as Legacy, it does not show any D drive... i.e., the partition where windows is not installed....

    i'd really appreciate help on this please...
      My System SpecsSystem Spec

  6. #6


    Posts : 5,592
    ME, XP,Vista,Win7,Win8,Win8.1


    Quote Originally Posted by theog View Post
    Welcome to EightForums.


    Quote Originally Posted by mak712
    change my boot sequence to disable legacy boot, then during installation of win 8, i cannot see my HDD ... im using a flash drive to install win 8 which is already in UEFI (i used diskpart for that).
    also, when i use legacy boot and try to install windows, then the HDD appears and when i format the HDD and create new partitions, it creates 3 partitions (System, MSR, Reserved) and the fourth one for OS. i tried installing the windows like this but after install, when i change the boot sequence to UEFI again, it fails to boot
    You are resetting the UEFI/BIOS firmware to UEFI boot & booting the DVD/USB in UEFI mode, than installing in UEFI mode, than after install you are resetting the UEFI/BIOS firmware to Legacy boot.

    As you have install Windows UEFI mode,
    1) Do as you did above
    2) Do not reset UEFI/BIOS firmware to Legacy after installing Windows.
      My System SpecsSystem Spec

  7. #7


    Posts : 4
    Windows 8


    sir, there seems to be a bit of confusion here... what i said was that i initially installed the windows in legacy bios and then after install, tried to run in UEFI. it was then that the windows was unable to boot. and if i try to install in UEFI mode, then the hard disk not detected thing occurs. and also, if i install the windows in legacy and keep on using the legacy boot, then the rest of the HDD (the part not in use for OS) cannot be seen.

    what i just want to ask is that how can i get rid of this HDD error... how can i get the HDD to show while installing the windows in UEFI boot?
      My System SpecsSystem Spec

  8. #8


    Posts : 5,592
    ME, XP,Vista,Win7,Win8,Win8.1


    Quote Originally Posted by mak712
    when i format the HDD and create new partitions, it creates 3 partitions (System, MSR, Reserved) and the fourth one for OS
    For UEFI mode.
    Do as you did above
    UEFI (Unified Extensible Firmware Interface) - Install Windows 8 with

    For Legacy mode.
    1) Set UEFI/BIOS firmware to Legacy.
    2) Boot the DVD/USB in Legacy.
    3) Clean the HD Drive, using the CLEAN command (no need to use CLEAN ALL) in Step One in this tutorial:
    SSD / HDD : Optimize for Windows Reinstallation - Windows 7 Help Forums
    4) Install in Legacy.
    Clean Install - Windows 8
      My System SpecsSystem Spec

  9. #9


    Posts : 1,121
    Windows 8.1 x64


    This thread has become a little confusing. If you have a currently working Windows system, could you use the snipping tool and take a picture of your Disk Management window, then attach using the paperclip on advanced replies. Please expand the window and label the partitions, if able.

    im using a flash drive to install win 8 which is already in UEFI
    The flash drive has both options so can be booted either way. Your bios may not allow one or the other depending on how it is set.

    To boot into a UEFI install, you boot to the Windows Boot Manager. To boot into a Legacy (MBR) install you boot to the drive. If you are trying to boot directly to the drive in a UEFI system, it will not work.

    You can use DiskPart and its List Disk command to see if the drive is GPT. There will be an asterisk on the right side of the listing for that drive.

    Once we understand your current situation, we might be able to help with your problem. But your original question about the install not being able to see the hard drive does not depend on whether you boot using UEFI or MBR. The install will see the drive, just not allow you to install to it if the configuration does not match.
      My System SpecsSystem Spec

HDD not detected during Windows 8 installation in UEFI
Related Threads
My friend has an ultrabook (hp envy 6-1113tx) which came with windows 8 pre-installed and after of more than 1 year of usage the OS became unstable and sluggish so he wanted to do a reinstall. I made bootable usb and enabled the legacy mode in BIOS after which the usb became visible in boot...
Hi guys, I recently bought a new SSHD for my laptop and after initial problems with trying to install Windows in UEFI, I turned to Legacy and that worked. But now when I change it to UEFI, it just comes up as "Operating system not found". :cry: Any ideas or solutions would be greatly...
Hello all. My first post on these forums. Hope I don't break any rules in it :p I'll try to be short and clear in describing my problem, but please bare with me here as it's not the simplest of issues (not to me anyway). I got a (at the time new) MSi laptop several months back with just a regular...
Hi All, I bought a new Acer V5-572 Laptop which came pre-installed with Linux and BIOS was UEFI mode selected. To install windows 8.1, I made a installable USB of windows 8.1 and selected Legacy boot in BIOS to boot from it. While installing I formatted the harddisk completely using DISKPART...
Solved UEFI installation in Installation & Setup
I bought a new dell laptop and found it full of bloatware and so I installed windows 8 from my previous usb key. Later I found out about UEFI and decided to reinstall windows 8. I followed a guide from this site and made a usb using rufus. Now when I put that usb drive, my laptop does not...
uefi installation of windows 8 in Installation & Setup
ok... i upgraded from win7 to win8... and now i got to know that win8 would boot even more faster if it has uefi configuration,but to my bad it wasn't enabled in my intel dh55pj motherboard bios... now how do i install windows 8 again with uefi config. ?? i really have no idea about the...
Hi I'm new to eight forums, I hope i can become a valued member soon. I purchased a laptop in Korea not long ago, i came with the option of Win7 or 8 but i chose to get it without an OS because I didnt want an OS in hangul. I installed Windows 7 on it and I've been using it fine ever since. Now...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook