Windows 8 and 8.1 Forums


Clean install on SSD keeps failing at Detecting Devices..

  1. #1


    Posts : 4
    Windows 8

    Clean install on SSD keeps failing at Detecting Devices..


    Hello everyone...

    I have a brand new Acer Predator AG3620. It has an Intel I7, 12 GB of RAM and an NVIDIA GeForce GT 630 2GB video card. It shipped with a 2 TB hard drive and Windows 8 which worked fine.

    I installed a Mushkin Chrone 240GB SSD drive and wanted to install a clean copy of Windows 8 on there to remove all the Acer bloatware. This is where my life ended... After an unfortunate series of incidents, I am finally at the point where the BIOS (or whatever they call it these days) recognizes and boots from the drive. However, the Windows 8 installation will not complete.

    It gets to "Detecting Devices" and after it gets to 69%, 72% or 79% (it changes all the time), the system reboots and I get an error message, "The computer restarted unexpectedly or encountered an unexpected error. Windows installation cannot proceed. To install Windows, click "Ok" to restart the computer, and then restart the installation." After searching tirelessly for a solution, I realized that Acer had a BIOS update which I installed and I am STILL having the same problem.

    I suspect there is some type of hardware compatabilty issue but I am not aware of any logfile that can help guide me. I have done this installation about 20 times in the last few days and it is absolutely maddening. It just WILL NOT work! I have read every post I could find and tinkered with every setting in the BIOS, port on the motherboard and SATA cable I have. I have gone from ACHI to IDE, unplugged the original hard drive, unplugged every device other than the monitor, etc. You name it, I have done it.

    I have been at this for days and I am really at my wit's end. I really hope someone out here can give me some advice or further troubleshooting steps. Thanks for reading and thanks in advance for your help!

      My System SpecsSystem Spec

  2. #2


    Your suspicions are correct. I have had the same problem on several different models, since the earlier public previews. There have been three or four solutions offered, even on this site, none of which have worked. In particular are older HP models, especially the Envy15, but some Acers are also experiencing the problem.
    Bu you could be lucky. Do you not have any restore disks which you could experiment with? Final solution for you is, of course, to return the old HD to the machine and hope all is well.
    Popular theory is that it is the graphics card. This idea doesn't sit well with me, as when I have encountered that particular problem with other machines, it merely reverts to the Default VGA screen, which, of course, it has been using right through the install process.
      My System SpecsSystem Spec

  3. #3


    Posts : 4
    Windows 8


    Don't get me started on HP! This is actually my SECOND new PC and SECOND SSD drive. This story is part of a much longer saga. It is all going in my book one day.

    There is a restore disk that I need to create but I don't have a 16GB thumb drive. That is my absolute final resort which I will try tomorrow but that is going to leave me with an Acerized Windows 8. I wanted a clean copy.
      My System SpecsSystem Spec


  4. #4


    I empathize! But if you prowl around here, there are several posts with good advice on ridding yourself of the bloatware. Someone will surely pop up on this thread with a good solution.
      My System SpecsSystem Spec

  5. #5


    Posts : 5,592
    ME, XP,Vista,Win7,Win8,Win8.1
      My System SpecsSystem Spec

  6. #6


    Posts : 4
    Windows 8


    I am going to try the recovery disc route today. I am concerned that that still might not work though. I have introduced foreign matter (an SSD) to the system so it is not exactly as it is shipped. Isn't the recovery disc built for the EXACT shipping configuration?

    If THAT doesn't work I guess I will try WIndows 7, but I fear that might have the same issue...
      My System SpecsSystem Spec

  7. #7


    Posts : 4
    Windows 8


    Just a quick update to this mess...

    Unless my previous computer, Acer requires you to copy the recovery disc to a 16 GB USB drive. It will not accept DVDs. So I had to go buy one...

    It took a couple of hours to install using the recovery disc but it did indeed work! I now have Windows installed on the SSD, and the original 2 TB hard drive as the secondary. I really wanted a clean copy of Windows 8 but it just does not look possible with my current configuration.

    On the bright side, Windows boots up in about 5 seconds once the logo appears. Pretty sick!
      My System SpecsSystem Spec

  8. #8


    Posts : 5,592
    ME, XP,Vista,Win7,Win8,Win8.1


    Well done.
      My System SpecsSystem Spec

Clean install on SSD keeps failing at Detecting Devices..

Similar Threads
Thread Forum
Update KB2973201 failing to install repeatedly
Hello out there. I am in dire need of expert help. I have two desktops running Windows 8.1 Pro x64. In one of them, Windows Update KB2973201 is failing to install. (I have installed at least two other updates after this, so the problem is not related to Windows Update not working.) The...
Windows Updates & Activation
Device Manager re:devices after Windows clean install
Can I trouble you for your feedback on something else. Every few months I clean install the Windows operating system on my PC. Is it the same for you in that sometimes the Windows 8 setup picks up all of the devices (it usually only misses one..a Bluetooth peripheral device with a question mark....
Installation & Setup
Cannot install any driver, failing for invalid data
I have a client running Windows 8.1. The original problem was that he could not install an HP 6700 printer, the installer package failed every time. I got the same error; I attempted to update all his drivers and noticed that all the installers failed. I then attempted to install it manually and I...
Drivers & Hardware
Installation failing once “getting devices ready” @ 100%
Hello all, I have a Gateway DX4831 desktop PC which is currently running Genuine Windows® 7 Home Premium 64-bit, I am trying to install Windows 8 using the download assistant. I have uninstalled all of the software that the assistant recommended that I review and I have updated Windows 7 and...
Installation & Setup
Clean disk before clean install?
hello I had many problems with BSOD crashes, and decided to make a new clean install (SSD or harddisk). If I make a new clean install (no upgrade) is it enough to create 1 continuous unallocated disk and then it will make a clean install Or do I have to "clean up" my old disk first before making...
Installation & Setup
Power off after "Getting Devices Ready" with clean install
I upgraded from XP SP3 to Windows 8 a week ago using the Assistant program with no problem. Then 2 days later that HDD crapped out. So I made the DVD/USB media on another PC and tried a clean install. After 10 attempts to clean install with all the "tricks" I could find on the net the installation...
Installation & Setup
Bluetooth devices not detecting?!?!
I've got an Acer Aspire S3-951, just installed Windows 8 Release Preview Build 8400. All devices have installed, the bluetooth module shows up in the device manager. I've downloaded and installed the Atheros Bluetooth driver from the Acer website. However when I try to add a bluetooth device it...
Drivers & Hardware

Eight Forums Android App Eight Forums IOS App Follow us on Facebook