Windows 8 and 8.1 Forums


Dual Boot - No timeout in Legacy Bootloader?

  1. #21


    Sofia
    Posts : 135
    XP, Win7, Win8_Eval


    @Saltgrass your observations are correct - the BCD is altered who knows how.

    SiPolicy (Integrity Services) is missing from bootmgr and Windows 8 loader ?
    Some device elements are "unknown"....

    I would run this command when booted to Windows 8:
    bcdboot c:\windows

    Yet better "Dual-boot Repair" tool -> "Automatic Repair" from Visual BCD package.

    This would at least reset Windows 8 entry to default and fix {bootmgr} elements (30 sec. boot delay).

    Then I would delete all loader entries except Windows 8.
    Then I would add Windows 7. (Visual BCD -> "Create missing Windows loaders").


    Fixing Advanced Boot Options when in Windows 8 (and when Win 7) is done using
    ReAgentC utility:
    ReAgentC /disable
    ReAgentC /enable

    Hope this helps.

      My System SpecsSystem Spec

  2. #22


    Posts : 14
    Windows 8 Pro


    This is a new machine that came pre-loaded with Win 7

    I installed Win 8, when it first booted in gave me the GUI boot screen, I changed the timeout to 5s and default OS to win 7.

    The next time it booted it gave me the text boot screen with no timeoutdespite the timeout being set for 5s.

    I changed the bootmenupolicy for Win 8 from Standard to Legacy to see if that would enable the timeout - it makes no difference.

    I have tried Bootrec /rebuildbcd - no difference.
      My System SpecsSystem Spec

  3. #23


    Posts : 14
    Windows 8 Pro


    Thanks for your reply boyans, tried your suggestions - no joy.

    When I tried ReAgentC /disable ReAgentC /enable it returned an error, is there something I'm missing? should it be ReAgentC /disable something?
    Last edited by Rob; 23 Nov 2012 at 06:06.
      My System SpecsSystem Spec

  4. #24


    Posts : 165
    Windows 8


    I think the problem is the "identifier {default}" - I never heard of an identifier with name "{default}".

    Try this:
    • Make a copy of the identifier "{default}":
      bcdedit /copy {default} /d "Windows 7 new"
      You will get a new long identifier No.
    • Set this identifier to default:
      bcdedit /set {bootmgr} default {new long identifier No.}
    • Test this. You should get a menu with "Windows 7", "Windows 7 new" and "Windows 8". If timeout is now working you can delete the identifier "{default}":
      bcdedit /deletevalue {default}
      My System SpecsSystem Spec

  5. #25


    Posts : 14
    Windows 8 Pro


    Thanks for you reply, if I had used the /v switch on bcdedit it would have shown the full identifier number instead of default, that's all.

    I have done a bit more investigation and found that the timeout works if there is a single OS listed in the BCD and displaybootmenu is on.

    As soon as a second OS is entered, the timeout stops appearing for some reason
      My System SpecsSystem Spec

  6. #26


    Sofia
    Posts : 135
    XP, Win7, Win8_Eval


    Thanks for your reply boyans, tried your suggestions - no joy.
    What do you mean ?
    That bcdboot is not working ?
    This is a MS-utility which has been proven to work on "zilions" of systems.

    ReagentC comes last after you have fixed all other inconsistencies in BCD
    ReagentC hadles install/deinstall of recovery environment.
    Last edited by Brink; 27 Nov 2012 at 06:45. Reason: cleaned up unneeded comments
      My System SpecsSystem Spec

  7. #27


    Posts : 14
    Windows 8 Pro


    The probem is not with the BCD, it is configured correctly - the exact same BCD shows the timeout when on another machine.

    There must be something in the makeup of this particlar machine that is suppressing the timeout.
    Last edited by Brink; 27 Nov 2012 at 13:43. Reason: cleaned up unneeded comments
      My System SpecsSystem Spec

Page 3 of 3 FirstFirst 123
Dual Boot - No timeout in Legacy Bootloader?
Related Threads
♫ Just bought a Dell Optiplex 7010 Mini-Tower with Win 8 Pro 64-bit, 8 GB RAM, 500 GB hard drive and an Intel i5 3470 processor. Right now, it has Dell BIOS version A16. It is normally in UEFI ON and Secure Boot ON, so that F12 on bootup (one-time boot options) does NOT normally show the...
Hi everybody, I posted this issue in the BSOD section, but have been suggested to post it here instead. My system is a Windows 8 x64 Pro with Boot Camp 5 running on a 2011 Macbook Pro. I'm experiencing Windows crashes and distorted screen images with artifacts (see attachment #1) almost every...
Hello, first post here... First, some context: I have a Dell Inspiron 15R SE that came with Windows 8. I've managed to get a working dual-boot system with Ubuntu 12.10. I can't remember exactly how I done that, but I remember that I had to disable secure boot. I think that the boot...
Boot Ubuntu from win8 bootloader in Installation & Setup
I have the blue win 8 bootloader with my os's but this is what it says when I choose Ubuntu http://imageshack.com/scaled/large/703/esbm.jpg
Solved can't change boot timeout in General Support
I've tried everything and the boot timeout always reverts to 30 seconds. I've used the internal boot menu, msconfig and easybcd to change it to 10 seconds but it always reverts back. I even tried using the win 7 text menu with the same results. Currently I use the graphical menu because I like it...
Dear Windows 8 users I call myself an experienced user. I had multiboot installations with Windows from even before the 21st century. I fixed millions of problems with Windows OS'es. However, this time I don't have the time to search for days. I did my best for a few hours, but I became a busy...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook