Windows 8 and 8.1 Forums


Error during in-place Upgrade

  1. #1


    Posts : 154
    Win7

    Error during in-place Upgrade


    Am trying an experimental in-place Upgrade 7>8. I downloaded the MSDN Win8 DVD image, burned to disk, ran Setup as Admin from WIn7 desktop and it only offers to allow me to save Files or nothing.

    So I thought it might be a problem with using Win7 Ultimate, decided to extract the ISO to add the ei.cfg file to Sources to unlock all versions as suggested in How to unlock all editions from Windows 8 ISO Image

    Now when I run Setup from extracted files with ei.cfg added it gives me this error in the screenshot below (Why can't I shake this link ):


    Click image for larger version

    Any suggestions? I want to check performance on an in-place.



      My System SpecsSystem Spec

  2. #2


    Posts : 22,577
    64-bit Windows 10


    Hey Greg,

    From what I read about that error number, it appears to be related to not having permission. Some have it related to being blocked by a AV or firewall program.

    I extracted the ISO to another partition than the one being installed to using step 2 in OPTION TWO below. It was pretty darn fast.

    https://www.eightforums.com/tutorials...ndows-8-a.html
      My System SpecsSystem Spec

  3. #3


    Posts : 154
    Win7


    Thanks Shawn -

    Yeah I'd extracted ISO to my Storage partition so wondered if that could somehow be causing hidden permissioning issue.

    Just ran Upgrade Asst with few conflicts but when it offers to let me save all apps, files, settings it does then say I need Win8 Pro version only offering a purchase link.

    I guess I shouldn't have to unlock all versions but need a clearly Pro product key. But MSDN and Technet only offer Pro downloads in N and VL which are not available to my subscription level. Any suggestions?
      My System SpecsSystem Spec

  4. #4


    Posts : 22,577
    64-bit Windows 10


    I used a MSDN ISO without the ei.cfg, so that may be part of the issue. The key number determined if it was Windows 8 or Windows 8 Pro though.
      My System SpecsSystem Spec

  5. #5


    Posts : 154
    Win7


    Man, am I a 8 noob!

    I didn't notice the Pro Product Key when I claimed one. Was planning to do a Clean Install so didn't matter to me at the time!

    (slinking back to 7F)




    Thanks, Shawn,.
      My System SpecsSystem Spec

  6. #6


    Posts : 22,577
    64-bit Windows 10


    LOL, don't feel bad. It took me a bit to figure out why they didn't have a Pro download at first as well.
      My System SpecsSystem Spec

  7. #7


    Posts : 1,308
    Windows 8 enterprise x64


    Brink , you Ninja me the time I make a Screenshoot , lol, yes it's miss label it'S really a pro , also technet will not give Home Edition of software




    Quote Originally Posted by Brink View Post
    LOL, don't feel bad. It took me a bit to figure out why they didn't have a Pro download at first as well.



    Lol , same here, I even call to know what is the requirement for the VL.
      My System SpecsSystem Spec

  8. #8


    Posts : 154
    Win7


    Now I realize however that the (twice-)extracted files never even asked for Product Key before throwing up the error. I wonder if the unneeded ei.cfg workaround fouled them out.

    Running Setup as Admin from DVD now with Pro Product Key gets the full in-place option. And I'm off to the button wall.
      My System SpecsSystem Spec

  9. #9


    Posts : 5,592
    ME, XP,Vista,Win7,Win8,Win8.1


    Hi greg

    Welcome to EightForums

    Ray.
      My System SpecsSystem Spec

  10. #10


    Posts : 154
    Win7


    Thanks, Ray.

    I imaged over my 7 to another partition to try an in-place of 8 and now have it in place: easy enough and stable from start-up.

    But the button WALL chases me back to Seven until I can find some time to install the closest replica of the 7 Start button Menu? Any suggestions that give Menu?
      My System SpecsSystem Spec

Page 1 of 3 123 LastLast
Error during in-place Upgrade
Related Threads
I've found that on my Windows 8 64-bit PC whenever I try to install a new version of iTunes it always gives me an error. The only way to upgrade to the latest version is to uninstall iTunes completely, reboot, then install the new version of iTunes. Has anyone else ran into this issue? Could it...
On an Asus laptop with Windows 8 preinstalled, I have secure boot on, AV off, but every time I try to install the update from the Windows Store I get as far as: Getting the update ready This App wasn't installed, - view details. Something happened and the Windows 8.1 couldn't be installed....
My First Impressions: I have just installed the latest TechNet version of Windows 8.1 (ISO) (choosing the "upgrade" option) over my existing Windows 8 Pro 64-bit installation, using my existing Windows 8 product key. (After doing a full original system backup to an external hard drive). The...
hi, I've recently joined the beta of windows 8 and downloaded from official Microsoft connect site,i've burned the iso and tried to install int but when i try to install a message error appears : unable to register embedded dll '' and setup close .there is the info provided from the log file...
Windows 8 upgrade error in Installation & Setup
I have Windows 7 ultimate PC. I have bought Windows 8 Pro DVD & when I try to upgrade to Windows 8 an error comes up: Error - 0x8007045a This comes up even before the first restart within 5 minutes of starting the installation. I have done all this: Removed all incompatible softwares Removed...
Windows 8 upgrade error in Installation & Setup
When trying to upgrade to windows 8, I get to 100%, and then my computer restarts. The blue microsoft logo comes up, and it says getting ready. Then an error message comes up and says ATTEMPTED_EXECUTE_OF_NOEXECUTE_MEMORY. It then reverts my OS back to windows 7. Any idea how to fix this error?...
I'm looking to do an in place upgrade of Win7 Ultimate to Win8 Pro. I am running a Lenovo Thinkstation with SAS Raid, 2 quad core processors and 24 gig of memory. The raid is configured raid 10 and is one 500gb partition (C Drive). I have a secondary 2 TB sata drive that I used for swap and...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook