Windows 8 and 8.1 Forums


  1. #1

    Posts : 1
    Windows 8


    Why wont windows 8 let me delete windows.old. I have unticked read only when I go into the folder properties. When I click apply it won't give me permission to do this, it says I need permission to apply read only to certain files and takes me back to the ticked folder. I have taken full ownership but still won't delete says I need permission of SYSTEM but when I check UAC I have administrator access but SYSTEM seems to have its own account which I don't/Can't access..SOO frustrating...spend last four hours googling it and tried everything but can't get control of SYSTEM to get the permission to delete the folder.

    Please help..I am losing the will to live there is over 100gig there I want back..!!

      My System SpecsSystem Spec

  2. #2

    You have to also change Auditing and Effective Access...
      My System SpecsSystem Spec

  3. #3

    Posts : 22,564
    64-bit Windows 10

    Hello John, and welcome to Eight Forums.

    You might see if using any of the other options in the tutorial below may be able to delete the Windows.old folder for you.

    Windows.old Folder - Delete in Windows 8

    Hope this helps,
      My System SpecsSystem Spec

  4. #4

    Posts : 5
    windows 8

    I went through the same frustration as John and definitely no happy ending. I still have a big fat Windows.old folder smugly sitting there. It ignores everything from disk cleanup (no option to "clean up system files" anymore) to power admin commands and even though administrator has full control, that appears to be a lie. I'm sure MS in their finite wisdom thought it would protect users but I am down to 2GB of free disk space and getting a little desperate. Has anyone managed to delete windows.old in the production release version of W8? And if so, how? I may be able to do it if I create a linux boot disk on a flash drive but if there is an easier option that would be great.
      My System SpecsSystem Spec

  5. #5

    Posts : 740
    Windows 8.1

    Safe Mode - Start Windows 8 in

    That being said, I just took ownership and changed the permissions so only I had full access. then it mostly deleted, except for a couple 4kb files that were pretty stubborn
    Last edited by Brink; 30 Oct 2012 at 23:18. Reason: updated link for the same here
      My System SpecsSystem Spec

  6. #6

    Taking ownership worked for me too
      My System SpecsSystem Spec

  7. #7

    Posts : 5
    windows 8

    Ok, I booted into safe mode but no change. I still can't delete windows.old. So I removed system ownership of the directory so that only the administrator account has full access to it. And ... same result: "you need trustedinstaller approval to delete these files." Beats me. later I'll download a copy of ubuntu and try to delete using that.
      My System SpecsSystem Spec

  8. #8

    Posts : 5,360
    7/8/ubuntu/Linux Deepin

    If you fancy a smaller download - I think it's only 50mb, you could try Paragon's linux based free rescue .

    Rescue Kit Free Edition - CNET

    Normal Mode>File Transfer wizard.

    Select the WINDOWS.OLD and click the big red X.

    That should nuke the annoyance.
      My System SpecsSystem Spec

  9. #9

    Posts : 5
    windows 8

    "nuke the annoyance" - I love it! Ok dinner first and then let the nuking begin.
      My System SpecsSystem Spec

  10. #10

    Posts : 131
    Win7-8 Dual Boot on a Commodore 64

    Gone Missing???

    In reply to mickchev....

    I used Brinks tutorial. l used option one [Disk-Cleanup] and it deleted the windows.old folder completely.
    Although I no longer have an interior listing for "Previous Windows installation(s)" ;
    there is still the option/radio button to click on "Clean up system files".

    I've no idea why yours disappeared. Strange?

    Click image for larger version
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
Eight Forums Android App Eight Forums IOS App Follow us on Facebook