Windows 8 and 8.1 Forums


Microsoft Basic Display Adaptor &Intel HD 3000 don't work

  1. #1

    Microsoft Basic Display Adaptor &Intel HD 3000 don't work


    Dear Eightforum users,


    I've got a serious issue with my screen resolution on win8 (asus k53d). Actually this annoying problem has been living with me since two years.

    The problem is that what ever I do, I can't install display driver (even Microsoft basic driver) and the screen resolution is always fixed on 1024*786.

    I've tried the following steps:

    Installing the appropriate win 8 display driver form Asus support > Doesn't work after installation and restarting the windows

    Updating the driver from the device manager > Doesn't work after installing an restarting.

    In fact the windows cant recognize the Microsoft basic driver and Intel HD 3000 as there is always a yellow danger sign there.


    I would really appreciate your help
    Can I solve it? or the issue is related to hardware?


    Click image for larger versionClick image for larger versionClick image for larger versionClick image for larger version

      My System SpecsSystem Spec

  2. #2


    Horrible gaming performance on ASUS K53SD [Solved] - Laptops - Laptop Tech Support


    your model doesn't even show up buddy.. only the "SD" model shows up..not k53d..

    what is the page you are getting your drivers from??

    try running display driver uninstaller
    Download Display Driver Uninstaller - MajorGeeks
      My System SpecsSystem Spec

  3. #3


    Quote Originally Posted by brooksndun View Post
    Horrible gaming performance on ASUS K53SD [Solved] - Laptops - Laptop Tech Support


    your model doesn't even show up buddy.. only the "SD" model shows up..not k53d..

    what is the page you are getting your drivers from??

    try running display driver uninstaller
    Download Display Driver Uninstaller - MajorGeeks
    Well, its K53SC > first uninstalled the previous malfunctioning driver and know downloading the intel graphic driver through asus support (v10.18.10.33). When I search my laptop model no VGA card appears on the screen for win 8.1 but there is the intel driver for win7. Therefore, im download the universal version (yet im not sure it will work or not).
    My two concerns are:
    1. My graphic card is Nvidia GeF 520mx 1gb, so should I install interl graphic driver prior to Nvidia? (Considering the point that Ijust want the highest resolution for screen , I dont play games)
    2. Will the current model of VGA Intel work on my laptop, though on the Asus website there is no specifically determined version for my model?
      My System SpecsSystem Spec

  4. #4


    try the intel update utility..

    Intel® Driver Update Utility


    also just download the correct geforce driver from nvidia

    Drivers - Download NVIDIA Drivers




    and do make sure you have the latest bios update .. be very careful and read everything on how to check this..

    https://www.asus.com/support/Downloa...3TFaWwIvxq/36/
      My System SpecsSystem Spec

  5. #5


    Quote Originally Posted by brooksndun View Post
    try the intel update utility..

    Intel® Driver Update Utility


    also just download the correct geforce driver from nvidia

    Drivers - Download NVIDIA Drivers




    and do make sure you have the latest bios update .. be very careful and read everything on how to check this..

    https://www.asus.com/support/Downloa...3TFaWwIvxq/36/

    Whatever I do, Intel driver utility fails to install. Besides, my BIOS version is 2.7 and the are new BIOS versions available.

    But the problem with Asus website is that 2.7 is the only available BIOS version for my laptop and the newer versions appear in not-specified model section. Hence, I can't download the newer versions because they may not work on K53SC model! The system may prabably install to BIOS drivers on on motherboard and BOOM!

    Still wondering if it is related to hardware malfunctioning !
      My System SpecsSystem Spec

  6. #6


    DO NOT install a bios that is NOT for your specific motherboard or from ASUS..

    Your Bios should actually be smart enough to stop that anyway, and will not let you install an incorrect version..

    why on earth are you having a problem installing intel auto update??
    What is the error with Intel Auto Update?


    that is absurd that you have these errors, as these are one of the most common and simple driver errors to fix by installing the correct driver made for your specific windows version..

    So if you know exactly the model of your graphics cards, then go to the website of the makers and download the EXACT models drivers for windows 8.1 or the exact version of windows you have.. 32bit or 64bit etc...

    its not difficult...

    for example if you have a "Geforce Nvidia 800m" ... then you select "Geforce 8 series", and then select "800m" driver for windows 8 64bit... etc..

    Example 2 - if you have "intel 4000HD" , then go to intel website and download intel 4000HD driver for win 8.1 64bit

    its' extremely simple.. you just need to know what version of windows you have ... 8 or 8.1.. 32bit or 64bit.. and then know the exact model numbers of your video cards..
      My System SpecsSystem Spec

  7. #7


    Posts : 187
    Windows 8.1 Pro/ Windows 8 Enterprise


    Hi,

    the latest BIOS for your K53SC is version 221 which updates Video BIOS and may be it will solve the problems you have. Please follow this instructions carefully to update the BIOS Update BIOS - How to use Easy Flash to update the Notebook BIOS version?.

    Good luck, werty
      My System SpecsSystem Spec

  8. #8


    Quote Originally Posted by werty View Post
    Hi,

    the latest BIOS for your K53SC is version 221 which updates Video BIOS and may be it will solve the problems you have. Please follow this instructions carefully to update the BIOS Update BIOS - How to use Easy Flash to update the Notebook BIOS version?.

    Good luck, werty
    Thnx for your suggestion. I just figured out that bios version 305 (last update 2011) for K53SJ is installed as I saw the version on bios setting. But my laptop is labeled K53SC and once I sent my laptop for repairing to Asus centre they had installed bios for K53SJ instead! Now i'm thinking if it is possible I can again switch to K53SC bios (as update is available and probably solve my graphic problem). Do you think this will cause a problem, considering the point that the two bios have same model K53S
      My System SpecsSystem Spec

Microsoft Basic Display Adaptor &Intel HD 3000 don't work
Related Threads
Just threw the consumer preview of windows 8 on an old desktop that was previously running 7, and now I can't get it to recognize my graphics card. It's just an integrated AMD chip, the Radeon X200. I found a copy of the legacy drivers for vista online and ran the installer in compatibility mode,...
I have installed windows 8.1 on my Dell dimension 9150. I have all of the drivers apart from my graphics card driver because it isn't supported in Windows 8.1. Is is there any way I can set the resolution to 1366x768 without a driver?
I recently bought a pretty old, upgraded desktop that came running Windows 8. It's fine for what I need but I can't find the ancient Radeon 1200 graphics card in device manager. I'd only really need it so my son can play some basic games that work on another even older PC I use. I know it's...
Running Windows 8.1 Preview x64. I was attempting to update my graphics drivers on my Vaio SE2C5E using those provided here. Things were already a bit messed up before hand, with the switchable graphics ability randomly disappearing one day. Thinking that I was uninstalling the existing drivers I...
Hey guys, I have nc6400, with ati mobility radeon x1300 and 6 hours ago I've installed win 8.First I wanted to encounter graphics card problem. It doesn't recognize card, it just says Microsoft Basic Display Adapter. I tried updating it with Browse and let me pick option, but without any success....
C It says they are compatible but I dont see any driver availbale for win 8
Hi everyone. I have installed Windows 8 onto my Inspiron 1501 notebook. The installation was good, but when I ran the digital adivsor for Media Center I receive an error message saying the display driver has to be updated. I looked in the device manager and the it is the microsoft basic display...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook