Windows 8 and 8.1 Forums


Corrupt video in Windows 8...

  1. #1


    Florida
    Posts : 26
    Windows 8 Pro With Media Center x64

    Corrupt video in Windows 8...


    Hey all.

    Having some issues in Windows 8 with my graphics card (EVGA GeForce GTX 550 Ti).

    For some reason the video in Win8 comes up very corrupt whenever I use this particular GPU with the system. There are artifacts all over the screen, the image looks like it's "blinding" (having an effect similar to vertical blinds), and the mouse creates movement trails. To read anything, I have to mouse over it constantly and use the mouse trail motion to try to "clear up" the text.

    I tried installing Nvidia drivers on the system but that doesn't seem to correct the problem (and, truthfully, it seems lower than that because even in Safe Mode, without any display drivers present, it still comes up jumbled and artifact-ridden). Erratically, I managed to get it to display smooth video ONCE but after another restart, I was right back to the same problem with the dense artifacting.

    I'm about to give up and reinstall the MSI Radeon HD 4850 I was using before I swapped to this card (it worked just fine) but I thought I'd ask first in case I missed something.

    This card did work in my other computer that runs Windows 8 but it was just replacing a card I had sent away for RMA. That particular card is back home now so I thought I'd put this in my other computer to give it a bit of a boost but when I did I hit this issue. My motherboard (Gigabyte GA-M61P-S3) is kind of old but I read that PCI-e 2.0 spec is backwards compatible with 1.0a devices and vice versa.

    I can let you know anything else you need to diagnose this issue. Thanks for any help you can offer.

      My System SpecsSystem Spec

  2. #2


    Florida
    Posts : 26
    Windows 8 Pro With Media Center x64


    Well, this was a bust. Decided it wasn't worth waiting for a solution so I just reinstalled the 4850.
      My System SpecsSystem Spec

Corrupt video in Windows 8...
Related Threads
After upgrading to Windows 8.1, I started experiencing a weird boot issue. When I boot Windows I only get a black, empty screen. As soon as the BIOS splash disappears the computer stops booting. No disk activity, nothing. My first instinct was to run bootrec /fixmbr and bootrec /fixboot from the...
Windows 8.1 pro corrupt files/ unable to fix in Windows Updates & Activation
I am running Windows 8.1 Pro WMC I Found KB2938527 in windows update and it downloded perfectly. But when i installed it showed errors: WindowsUpdate_80073712 and WindowsUpdate_dt000. When I ran sfc /scannow the I get the following output C:\Windows\system32>sfc /scannow
BASIC PROBLEM Apologies if this is covered elsewhere, if so please redirect me. In a nutshell, when I boot my Thinkpad x200s it offers me two OSes to boot into:" Windows 8 (on volume 1)" and "Windows 8". The "Windows 8" installation is corrupt (explained below) and I need help to get rid of it. ...
Windows 8 is corrupt? in General Support
My pc got stuck on a black screen after i restart it one time. When it finally lets me log in after turning the computer on and off manually, all of my programs were deleted, i couldn't access my computer's hard drive(?)(c:\windows) , and i couldn't access system restore (or msconfig / any of the...
On opening the Task Scheduler I get a message " Task MP scheduled Scan. Task image is corrupt or has been tampered with ". I look in Library, Microsoft, Windows Defender and the Task MP Scheduler is not there. Real time protection appears to be working and I can do a manual scan through the...
I searched the web a lot but could not find anyone resembling my problem. I have Windows 7 Professional in my laptop. I downloaded the 32-bit Windows 8 Release Preview iso from Microsoft's website using Free Download Manager. I used the Windows7-USB-DVD tool to copy the iso to a flash drive (I...
Hello Guys..! I'm facing a serious problem in my windows 8 cp...! I have a dual booted my windows 8 with windows 7... Everything was going fine but from last 2 weeks my video app isn't working... whenever i play a video thru my video app the audio of the video is played n the app hangs after 10...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook