Windows 8 and 8.1 Forums


Win 8 AMD Switchable Graphics FAQ

  1. #391


    Quote Originally Posted by HOODY View Post
    yup sounds about what I may end up using.

    Got a note back from this Wes guy at HP today too, sad my unit was now being "tested" and the driver should show up soon on the download page, now what sp number that will be is anybodys guess.
    see, so they are testing again....

      My System SpecsSystem Spec

  2. #392


    VA USA
    Posts : 349
    W8.1up1 Pro x64 w/media center


    Quote Originally Posted by aleseba77 View Post
    Quote Originally Posted by HOODY View Post
    yup sounds about what I may end up using.

    Got a note back from this Wes guy at HP today too, sad my unit was now being "tested" and the driver should show up soon on the download page, now what sp number that will be is anybodys guess.
    see, so they are testing again....
    LOL aleseba77, I think your more anxious than I am at this point lol.
    Anyway here is the exact text I got, you decide what he means.
    ========================================================================

    There are ID differences between the driver packages that may cause problems. sp59850, according to my contact, is being tested now for your model and will be updated to include the model when done. I'll have more when I know more.

    -wes

    response i got "Yes, (your model condename) have been added to SMR (release process) and are in test. Not exactly sure why they did not include them from the start."
      My System SpecsSystem Spec

  3. #393


    Quote Originally Posted by HOODY View Post
    Quote Originally Posted by aleseba77 View Post
    Quote Originally Posted by HOODY View Post
    yup sounds about what I may end up using.

    Got a note back from this Wes guy at HP today too, sad my unit was now being "tested" and the driver should show up soon on the download page, now what sp number that will be is anybodys guess.
    see, so they are testing again....
    LOL aleseba77, I think your more anxious than I am at this point lol.
    Anyway here is the exact text I got, you decide what he means.
    ========================================================================

    There are ID differences between the driver packages that may cause problems. sp59850, according to my contact, is being tested now for your model and will be updated to include the model when done. I'll have more when I know more.

    -wes

    response i got "Yes, (your model condename) have been added to SMR (release process) and are in test. Not exactly sure why they did not include them from the start."
    LOL again Hoody, i guess sooner or later we re going to have the god damn driver...again is the last time i bought an HP or an ATI graph!!
      My System SpecsSystem Spec

  4. #394


    VA USA
    Posts : 349
    W8.1up1 Pro x64 w/media center


    Yeah I hear that, but I can't say I will never buy a HP again, depends on the deal, however I damned sure will look for a green/blue graphics label, ie "Gforce"
      My System SpecsSystem Spec

  5. #395


    VA USA
    Posts : 349
    W8.1up1 Pro x64 w/media center


    well Aleseba77 here is still another "updated" driver lololol it just goes on and on buddy
    ----------------------------------------------------------------------------------------------------

    ftp://ftp.hp.com/pub/softpaq/sp59001-59500/sp59407.exe



    Originally Posted by HOODY8Right, now the question is would that sp59147 posted here on page 1 be a better choice? since you stated that it had a more updated intel driver?

    However sometimes those Intel drivers can cause problems themselves, I haven't looked into the subsys strings listed in that sp59147, what's your opnion?

    Also what's your take on that enduro style driver from leshcat that he just posted? how does that compare to either sp59147 or sp59850?


    ==========================================================================


    Before I say anything else, I just wanted to point out that HP has now re-packaged sp59147 (REV: A1) as sp59407 (REV: B3). I removed sp59147 from the first post and added sp59407.

    The packages are exactly the same from the looks of it (down to the components and their versions). The HP certified models in the CVA file are different (which I'm going to ignore for now), yet the product support as shown in C8146815.inf is exactly the same as that of sp59147.

    Driver component versions - support for Windows 8 x64 only:


    • 9.000.0.0000 (AMD graphics)
    • 9.17.10.2843 (Intel switchable graphics)
    • 8.0.0.8808 (AMD HDMI Audio)



    Code:

    [ATI.Mfg.NTamd64.6.2]

    "%AMD68E4.1%" = ati2mtag_ManhattanP_PXAI, PCI\VEN_1002&DEV_68E4&SUBSYS_3673103C"
    %AMD68E4.2%" = ati2mtag_ManhattanP, PCI\VEN_1002&DEV_68E4&SUBSYS_3675103C"
    %AMD6760.1%" = ati2mtag_Vancouver_PXAI, PCI\VEN_1002&DEV_6760&SUBSYS_1651103C
    "%AMD6760.2%" = ati2mtag_Vancouver_PXAI, PCI\VEN_1002&DEV_6760&SUBSYS_3584103C
    "%AMD6760.3%" = ati2mtag_Vancouver_PRAI, PCI\VEN_1002&DEV_6760&SUBSYS_1658103C
    "%AMD6760.4%" = ati2mtag_Vancouver_PXAI, PCI\VEN_1002&DEV_6760&SUBSYS_1656103C"
    %AMD6760.5%" = ati2mtag_Vancouver_PRAI, PCI\VEN_1002&DEV_6760&SUBSYS_165B103C
    "%AMD6760.6%" = ati2mtag_Vancouver_PXAI, PCI\VEN_1002&DEV_6760&SUBSYS_1659103C
    "%AMD6741.1%" = ati2mtag_VancouverA_PXAI, PCI\VEN_1002&DEV_6741&SUBSYS_3385103C
    "%AMD6741.2%" = ati2mtag_VancouverA_PRAI, PCI\VEN_1002&DEV_6741&SUBSYS_1617103C
    "%AMD6741.3%" = ati2mtag_VancouverA_PXAI, PCI\VEN_1002&DEV_6741&SUBSYS_1646103C"
    %AMD6740.1%" = ati2mtag_Vancouver_PRAI, PCI\VEN_1002&DEV_6740&SUBSYS_1658103C"
    %AMD6740.2%" = ati2mtag_Vancouver_PXAI, PCI\VEN_1002&DEV_6740&SUBSYS_1657103C
    "%AMD6740.3%" = ati2mtag_Vancouver_PRAI, PCI\VEN_1002&DEV_6740&SUBSYS_165B103C
    "%AMD6740.4%" = ati2mtag_Vancouver_PXAI, PCI\VEN_1002&DEV_6740&SUBSYS_165A103C
    "%AMD6740.5%" = ati2mtag_Vancouver_PRAI, PCI\VEN_1002&DEV_6740&SUBSYS_3388103C
    "%AMD6740.6%" = ati2mtag_Vancouver_PXAI, PCI\VEN_1002&DEV_6740&SUBSYS_3389103C"
    %AMD6760.7%" = ati2mtag_Vancouver_PXAI, PCI\VEN_1002&DEV_6760&SUBSYS_166C103C"
    %AMD6760.8%" = ati2mtag_Vancouver_PXAI, PCI\VEN_1002&DEV_6760&SUBSYS_185C103C
    "%AMD6760.9%" = ati2mtag_Vancouver_PXAI, PCI\VEN_1002&DEV_6760&SUBSYS_1863103C
    "%AMD6760.10%" = ati2mtag_Vancouver_PXAI, PCI\VEN_1002&DEV_6760&SUBSYS_1794103C
    "%AMD6760.11%" = ati2mtag_Vancouver_PXAI, PCI\VEN_1002&DEV_6760&SUBSYS_185D103C
    "%AMD6741.4%" = ati2mtag_VancouverA_PXAI, PCI\VEN_1002&DEV_6741&SUBSYS_1688103C
    "%AMD6740.7%" = ati2mtag_Vancouver_PXAI, PCI\VEN_1002&DEV_6740&SUBSYS_185E103C


    Code:

    AMD68E4.1 = "Radeon (TM) HD 6370M"
    AMD68E4.2 = "Radeon (TM) HD 6370M"
    AMD6760.1 = "Radeon (TM) HD 6470M"
    AMD6760.2 = "Radeon (TM) HD 6470M"
    AMD6760.3 = "Radeon (TM) HD 6490M"
    AMD6760.4 = "Radeon (TM) HD 6490M"
    AMD6760.5 = "Radeon (TM) HD 6490M"
    AMD6760.6 = "Radeon (TM) HD 6490M"
    AMD6741.1 = "Radeon (TM) HD 6630M"
    AMD6741.2 = "Radeon (TM) HD 6750M"
    AMD6741.3 = "Radeon (TM) HD 6750M"
    AMD6740.1 = "Radeon (TM) HD 6770M"
    AMD6740.2 = "Radeon (TM) HD 6770M"
    AMD6740.3 = "Radeon (TM) HD 6770M"
    AMD6740.4 = "Radeon (TM) HD 6770M
    "AMD6740.5 = "Radeon (TM) HD 6770M
    "AMD6740.6 = "Radeon (TM) HD 6770M
    "AMD6760.7 = "Radeon (TM) HD 7450M
    "AMD6760.8 = "Radeon (TM) HD 7450M
    "AMD6760.9 = "Radeon (TM) HD 7450M
    "AMD6760.10 = "Radeon (TM) HD 7470M
    "AMD6760.11 = "Radeon (TM) HD 7470M
    "AMD6741.4 = "Radeon (TM) HD 7690M
    "AMD6740.7 = "Radeon (TM) HD 7690M XT"


    HOODY8, I suggest you remove all of the older graphics drivers and then give sp59407 a try. The installation wizard should know which Intel switchable graphics components to install. Please let us know how this goes for you...if you experience any problems, try to post them here if you can.
      My System SpecsSystem Spec

  6. #396


    Quote Originally Posted by HOODY View Post
    well Aleseba77 here is still another "updated" driver lololol it just goes on and on buddy
    ----------------------------------------------------------------------------------------------------

    ftp://ftp.hp.com/pub/softpaq/sp59001-59500/sp59407.exe



    Originally Posted by HOODY8Right, now the question is would that sp59147 posted here on page 1 be a better choice? since you stated that it had a more updated intel driver?

    However sometimes those Intel drivers can cause problems themselves, I haven't looked into the subsys strings listed in that sp59147, what's your opnion?

    Also what's your take on that enduro style driver from leshcat that he just posted? how does that compare to either sp59147 or sp59850?


    ==========================================================================


    Before I say anything else, I just wanted to point out that HP has now re-packaged sp59147 (REV: A1) as sp59407 (REV: B3). I removed sp59147 from the first post and added sp59407.

    The packages are exactly the same from the looks of it (down to the components and their versions). The HP certified models in the CVA file are different (which I'm going to ignore for now), yet the product support as shown in C8146815.inf is exactly the same as that of sp59147.

    Driver component versions - support for Windows 8 x64 only:


    • 9.000.0.0000 (AMD graphics)
    • 9.17.10.2843 (Intel switchable graphics)
    • 8.0.0.8808 (AMD HDMI Audio)



    Code:

    [ATI.Mfg.NTamd64.6.2]

    "%AMD68E4.1%" = ati2mtag_ManhattanP_PXAI, PCI\VEN_1002&DEV_68E4&SUBSYS_3673103C"
    %AMD68E4.2%" = ati2mtag_ManhattanP, PCI\VEN_1002&DEV_68E4&SUBSYS_3675103C"
    %AMD6760.1%" = ati2mtag_Vancouver_PXAI, PCI\VEN_1002&DEV_6760&SUBSYS_1651103C
    "%AMD6760.2%" = ati2mtag_Vancouver_PXAI, PCI\VEN_1002&DEV_6760&SUBSYS_3584103C
    "%AMD6760.3%" = ati2mtag_Vancouver_PRAI, PCI\VEN_1002&DEV_6760&SUBSYS_1658103C
    "%AMD6760.4%" = ati2mtag_Vancouver_PXAI, PCI\VEN_1002&DEV_6760&SUBSYS_1656103C"
    %AMD6760.5%" = ati2mtag_Vancouver_PRAI, PCI\VEN_1002&DEV_6760&SUBSYS_165B103C
    "%AMD6760.6%" = ati2mtag_Vancouver_PXAI, PCI\VEN_1002&DEV_6760&SUBSYS_1659103C
    "%AMD6741.1%" = ati2mtag_VancouverA_PXAI, PCI\VEN_1002&DEV_6741&SUBSYS_3385103C
    "%AMD6741.2%" = ati2mtag_VancouverA_PRAI, PCI\VEN_1002&DEV_6741&SUBSYS_1617103C
    "%AMD6741.3%" = ati2mtag_VancouverA_PXAI, PCI\VEN_1002&DEV_6741&SUBSYS_1646103C"
    %AMD6740.1%" = ati2mtag_Vancouver_PRAI, PCI\VEN_1002&DEV_6740&SUBSYS_1658103C"
    %AMD6740.2%" = ati2mtag_Vancouver_PXAI, PCI\VEN_1002&DEV_6740&SUBSYS_1657103C
    "%AMD6740.3%" = ati2mtag_Vancouver_PRAI, PCI\VEN_1002&DEV_6740&SUBSYS_165B103C
    "%AMD6740.4%" = ati2mtag_Vancouver_PXAI, PCI\VEN_1002&DEV_6740&SUBSYS_165A103C
    "%AMD6740.5%" = ati2mtag_Vancouver_PRAI, PCI\VEN_1002&DEV_6740&SUBSYS_3388103C
    "%AMD6740.6%" = ati2mtag_Vancouver_PXAI, PCI\VEN_1002&DEV_6740&SUBSYS_3389103C"
    %AMD6760.7%" = ati2mtag_Vancouver_PXAI, PCI\VEN_1002&DEV_6760&SUBSYS_166C103C"
    %AMD6760.8%" = ati2mtag_Vancouver_PXAI, PCI\VEN_1002&DEV_6760&SUBSYS_185C103C
    "%AMD6760.9%" = ati2mtag_Vancouver_PXAI, PCI\VEN_1002&DEV_6760&SUBSYS_1863103C
    "%AMD6760.10%" = ati2mtag_Vancouver_PXAI, PCI\VEN_1002&DEV_6760&SUBSYS_1794103C
    "%AMD6760.11%" = ati2mtag_Vancouver_PXAI, PCI\VEN_1002&DEV_6760&SUBSYS_185D103C
    "%AMD6741.4%" = ati2mtag_VancouverA_PXAI, PCI\VEN_1002&DEV_6741&SUBSYS_1688103C
    "%AMD6740.7%" = ati2mtag_Vancouver_PXAI, PCI\VEN_1002&DEV_6740&SUBSYS_185E103C


    Code:

    AMD68E4.1 = "Radeon (TM) HD 6370M"
    AMD68E4.2 = "Radeon (TM) HD 6370M"
    AMD6760.1 = "Radeon (TM) HD 6470M"
    AMD6760.2 = "Radeon (TM) HD 6470M"
    AMD6760.3 = "Radeon (TM) HD 6490M"
    AMD6760.4 = "Radeon (TM) HD 6490M"
    AMD6760.5 = "Radeon (TM) HD 6490M"
    AMD6760.6 = "Radeon (TM) HD 6490M"
    AMD6741.1 = "Radeon (TM) HD 6630M"
    AMD6741.2 = "Radeon (TM) HD 6750M"
    AMD6741.3 = "Radeon (TM) HD 6750M"
    AMD6740.1 = "Radeon (TM) HD 6770M"
    AMD6740.2 = "Radeon (TM) HD 6770M"
    AMD6740.3 = "Radeon (TM) HD 6770M"
    AMD6740.4 = "Radeon (TM) HD 6770M
    "AMD6740.5 = "Radeon (TM) HD 6770M
    "AMD6740.6 = "Radeon (TM) HD 6770M
    "AMD6760.7 = "Radeon (TM) HD 7450M
    "AMD6760.8 = "Radeon (TM) HD 7450M
    "AMD6760.9 = "Radeon (TM) HD 7450M
    "AMD6760.10 = "Radeon (TM) HD 7470M
    "AMD6760.11 = "Radeon (TM) HD 7470M
    "AMD6741.4 = "Radeon (TM) HD 7690M
    "AMD6740.7 = "Radeon (TM) HD 7690M XT"


    HOODY8, I suggest you remove all of the older graphics drivers and then give sp59407 a try. The installation wizard should know which Intel switchable graphics components to install. Please let us know how this goes for you...if you experience any problems, try to post them here if you can.
    ey Hoody, take a look, it was an update on the sp59850

    ftp://ftp.hp.com/pub/softpaq/sp59501-60000/sp59850.html

    now, our notebooks are compatible!!!!!!!

    PURPOSE:
    Routine
    SoftPaq NUMBER:
    sp59850
    SUPERSEDES:
    None
    EFFECTIVE DATE:
    November 23, 2012
    CATEGORY:
    Driver - Graphics
    SSM SUPPORTED:
    YES
    PRODUCT TYPE(S):
    Notebooks
    HARDWARE PRODUCT MODEL(S):
    HP Pavilion dm4 Notebook PC Series
    HP Pavilion dv6 Notebook PC Series
    HP Pavilion dv7 Notebook PC Series
    DEVICES SUPPORTED:
    Intel Display Audio
    Intel HD Graphics Family
    Radeon HD 7590
    Radeon HD 6490M
    Radeon HD 6770M
    Radeon HD 7470M
    Radeon HD 7690M XT

    OPERATING SYSTEM(S):
    Microsoft Windows 8 Chinese Market 64 Edition
    Microsoft Windows 8 Emerging Markets 64 Edition
    Microsoft Windows 8 Enterprise 64 Edition
    Microsoft Windows 8 Multi-Language 64 Edition
    Microsoft Windows 8 Professional 64 Edition
    LANGUAGE(S):
    Global
    ENHANCEMENTS:
    - Provides the Microsoft WHQL Certified driver.
      My System SpecsSystem Spec

  7. #397


    VA USA
    Posts : 349
    W8.1up1 Pro x64 w/media center


    thanks for the new info aleseba77 It may just be the light at the end of the tunnel, however its still not listed on driver download page, oh well if HP says its for our series, than it will work, (right lol )

    ftp://ftp.hp.com/pub/softpaq/sp59501-60000/

    see the highlighed in red sp59850 for a direct download.
      My System SpecsSystem Spec

  8. #398


    Quote Originally Posted by HOODY View Post
    thanks for the new info aleseba77 It may just be the light at the end of the tunnel, however its still not listed on driver download page, oh well if HP says its for our series, than it will work, (right lol )

    ftp://ftp.hp.com/pub/softpaq/sp59501-60000/

    see the highlighed in red sp59850 for a direct download.
    hoody good news!!!! on the HP support and drivers, in my model is list the new driver sp59850!!! chek it out, let see if in the dv7 too!!!! and tell me
      My System SpecsSystem Spec

  9. #399


    Posts : 2
    Windows 8 64 bit Professional


    I'm using a Lenovo Y470p, and I read through most of this thread, and downloaded the UnifL Catalyst for AMD+Intel (AMD Radeon 7690m HD and Intel Graphics 3000 HD). I now have the switchable graphics menu available, and it looks fine on the surface, but I'm still only using the Intel card, not the Radeon. Any help?

    Also, device manager is reporting my card as a 7670, is that a problem too? Thanks.
      My System SpecsSystem Spec

  10. #400


    VA USA
    Posts : 349
    W8.1up1 Pro x64 w/media center


    Quote Originally Posted by aleseba77 View Post
    Quote Originally Posted by HOODY View Post
    thanks for the new info aleseba77 It may just be the light at the end of the tunnel, however its still not listed on driver download page, oh well if HP says its for our series, than it will work, (right lol )

    ftp://ftp.hp.com/pub/softpaq/sp59501-60000/

    see the highlighed in red sp59850 for a direct download.
    hoody good news!!!! on the HP support and drivers, in my model is list the new driver sp59850!!! chek it out, let see if in the dv7 too!!!! and tell me
    right on homes, its there now whew, took them long enough. Now to get hold of my buddy neighbor and use his high speed to get this mess going, install W8 and this driver.
      My System SpecsSystem Spec

Page 40 of 59 FirstFirst ... 30383940414250 ... LastLast
Win 8 AMD Switchable Graphics FAQ
Related Threads
I have HP Envy M6 1102tx with 2GB Radeon Switchable Graphics card but Catalyst Control Center can't be started.... Tried updating the ATI Radeon and Intel HD Graphics drivers and still not working. I am running Windows 8.1 64-bit
Greetings, I have been following the thread and so forth on the switchable graphics and anything to do with windows 8 for the longest time. I got one of those laptops where HP claims it doesnt support windows 8 and so forth. HP Envy 14 1211nr with beats audio. AMD 5650 1gb & Intel HD Video (FG)...
Hello! I have a notebook pc that comes with windows 7 from factory. I would like to install windows 8 in my machine. It has integrated intel hd graphics chip and separate nvidia geforce 420m graphic card. I heard switchable graphics are not working fine with windows 8. Is that true? BTW my system...
Switchable Graphics Driver in Graphic Cards
Hello, So I downloaded windows 8 onto my HP envy laptop (2011 model) and everything was going dandy until I tried connecting to my external monitor. It does not even acknowledge that my monitor is connected. I have looked online and it seems like the problem lies with my drivers. Apparently my...
Ok, so I have an HP ENVY dv6z-7200 Notebook PC that came with Windows 8 already installed. I've done A LOT of digging and came to the solution that I need to switch things around in the bios. I need to switch from Dynamic mode to Fixed mode, but there is no option in the new W8 EUFI thing, or...
Hello, I have an ati/amd radeon hd 6370 graphics card but it won't work on windows 8 RTM since the old drivers won't even install properly on windows 8(they install but don't seem to work). Can i get updated drivers(switchable graphics) for the ati graphics card? Also are there any updated...
If it's working, I'll grab the Windows 8 Release Preview. If it's not yet, I'll hold off for the retail version.
Eight Forums Android App Eight Forums IOS App Follow us on Facebook