Windows 8 and 8.1 Forums


GTX 970 In Game Artifacts and Stopped Working Error

  1. #1


    Posts : 3
    Windows 8

    GTX 970 In Game Artifacts and Stopped Working Error


    Hello,

    I have artifacting problem with my EVGA GTX 970 FTW the video about the issue is at the end of the post. I get the same problem in WoW, Watch Dogs and H1Z1. So basicly I used memtest86+ no errors, formatted windows and keep having same errors. I also changed PSU and send card back for RMA, they said that they have tested it for a long period of time and no errors and send it back. The only thing which is unchanged is motherboard now. I also get NVIDIA driver stopped working errors at random times(for example I get one while writing this post) Do you have any suggestions / input for me to solve this ?



    System Specs are following;
    i5-4670k CPU
    MSI Z87-G45 mobo, Corsair 2x4 GB RAMS
    EVGA Supernova 750 G2 PSU
    Samsung SSD 840 EVO 120GB, Windows installed on
    EVGA GTX 970 FTW Graphics card


    Thanks,

      My System SpecsSystem Spec

  2. #2


    Posts : 2
    Windows 8.1 x64 bit (might upgrade to win 10 soon)


    Hello from SevenForums! Also, welcome to Eight Forums!

    Since your artifacting was seen on the games you're playing, I highly doubt that Unigine's Valley and Heaven Benchmarks would create artifacts also, but in the mean time try testing both of them and see if you find artifacts. If you see artifacts on both benchmarks, use MSI Afterburner to downclock to nvidia reference speeds and see if the artifacts are still there. Also, I would reccomend that you install the hotfix driver 353.38 since the driver fixes the dreaded desktop TDR errors while internet browsing or anything that uses hardware acceleration. Try that and do what I would suggest above.

    Those FTW cards are highly problematic with some GTX 900 users who own this model of the card mostly because of the voltage while the clock and memory were overclocked caused some instability such as driver crashes or artifacts. Source comes from the EVGA forums: So GTX 980 FTW are very bad cards?
      My System SpecsSystem Spec

  3. #3


    Posts : 3
    Windows 8


    Yeah actually what you are saying is absolutely right and I think I solved this. I downclocked the card all the way back down -350 MHz core clock, and artifacts disappeared. They do exist in -300 MHz and get lost in a place in between. However I dont think this is a proper solution since I paid a laptop price for this card and what I get is not what I paid.
      My System SpecsSystem Spec

  4. #4


    Posts : 2
    Windows 8.1 x64 bit (might upgrade to win 10 soon)


    I'm glad you've solved it by underclocking it. Tell EVGA that underclocking solved the problem wanted to start an RMA because you've not getting it what you've payed for. I'm sure EVGA will took care of you.

    Its a pain that you've gone over 2 cards that causes instability because of unstable factory overclocked. Just like mine when I've been through. Never buying factory oc cards again. On the bright side, those coolers look very nice!
      My System SpecsSystem Spec

  5. #5


    Posts : 3
    Windows 8


    Quote Originally Posted by RyougaLolakie View Post
    I'm glad you've solved it by underclocking it. Tell EVGA that underclocking solved the problem wanted to start an RMA because you've not getting it what you've payed for. I'm sure EVGA will took care of you.

    Its a pain that you've gone over 2 cards that causes instability because of unstable factory overclocked. Just like mine when I've been through. Never buying factory oc cards again. On the bright side, those coolers look very nice!
    So I am adding the solution for future reference if somebody else has the same problem. My journey with RMA of factory overclocked cards lasted for nearly 2 years and it finally ended when I buy a MSI gaming 4G. It is not factory overclocked and it seems that it is doing OK for 5 months . Thanks for answers.
      My System SpecsSystem Spec

GTX 970 In Game Artifacts and Stopped Working Error
Related Threads
Hi I've been receiving this error message saying "Scripted Diagnostics Native Host has stopped working" for the past few weeks, and I have no idea what started this. I've tried downloading this antivirus program called Avira to test whether or not my laptop has been infected but that doesn't seem...
Hi, I found this forum considering people knew alot about Windows 8 here. Anyways, I am running Windows 8.1, and I got this error while web browsing. The screen went black, then came back and said something about my display driver crashing, but successfully recovering. I have an Nvidia GTX 760....
Hi! I am repeatedly getting the error "Internet Explorer not working" / Windows checking for solution/Last browsing closed unexpectedly , then Restore Session. I went to google to find a fix for this error .I'm being told to Press Window + W key then type in Troubleshooting in the Search box , then...
I purchased Return to Mysterious Island through Steam and whenever I play it, it randomly crashes when right clicking into the inventory. Sometimes this happens soon after loading and sometimes I can play for 10 minutes or so. I get the error message "Return to Mysterious Island has stopped...
Hello. Recently after doing restore of windows 8 of my computer and resetting all my data, i noticed i had Microsoft Basic Display Adapter by default as my video card. So, i updated my drivers to its respective update and started playing some games. On all of them , either in the midst of gameplay...
SEE the next POST #2 please... the problem was: "Setup.exe has stopped working". I was trying to install new ASUS software for my motherboard using W8x64 Pro. When I attempt to run the Setup.exe file as an Administrator, or by double clicking the Setup.exe file itself, or used the 'RUN'...
I upgraded from win 7 to win 8 pro about a month ago. Ever since then, when I go to my F drive and open 2 folders that have video clips/screenshots in them a box pops up saying com surrogate has stopped working. When I click on close the program it comes right back and a green bar starts filling in...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook