Windows 8 and 8.1 Forums


Can run certain games on intel, but not GeFroce GPU

  1. #1


    Cincinnati
    Posts : 54
    Windows 8.1

    Can run certain games on intel, but not GeFroce GPU


    This seems to be an issue with Saints Row IV and Gat Outta Hell. If I right click and run from the Intel 4600, the games run (shockingly well for the Intel). But when run through my GeFroce 750m, the games freeze up at the first screen. Just some sound, the start of animation... And then frozen. I've googled this and played around with the display.ni file all day only to get the same result. I've re-installed my graphics drivers and am clueless. I've had this same exact setup but re-formatted and now I have this issue. The games were located on a secondary drive that wasn't formatted... But I re-installed them and the same thing happens. I know these games worked before without an issue, please any help would be cool. If you're just going to google it, maybe you'll see something I missed, but the chances are, I've tried it.

      My System SpecsSystem Spec

  2. #2


    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit


    Assuming you've played with some of the settings for the game(s) in Nvidia Control Panel I would try DDU then re-install drivers.
    Display Driver Uninstaller Download version 13.6.4.3
      My System SpecsSystem Spec

  3. #3


    Cincinnati
    Posts : 54
    Windows 8.1


    I had a go at it, because I'm willing to try anything, I don't care about reformatting at this point... But now I can't re-install the GeFroce drivers, and when I went to the device manager, the GPU isn't even listed. I'm pretty sure this is not a hardware issue. Not a connection issue. The GeForce GPU was working and worked with other games before using this uninstall tool.
    Quote Originally Posted by popeye View Post
    Assuming you've played with some of the settings for the game(s) in Nvidia Control Panel I would try DDU then re-install drivers.
    Display Driver Uninstaller Download version 13.6.4.3
      My System SpecsSystem Spec

  4. #4


    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit


    Did you make a restore point as suggested on the DDU site? Also enable hidden devices in Device Manager. Reboot again.
    Try installing the drivers.
      My System SpecsSystem Spec

  5. #5


    Cincinnati
    Posts : 54
    Windows 8.1


    Nah, I just restored from a system image of only drivers and windows updates and nothing else really installed. I tried running the game and the same thing happened. I wonder why the heck my GeForce 750m poops on the Volition games I have, but doesn't mind the others. I mean, I ran these same games a month ago.
      My System SpecsSystem Spec

  6. #6


    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit


    Maybe need to try an older driver if you are on the latest one. Did you have the same driver a month ago?
      My System SpecsSystem Spec

  7. #7


    Cincinnati
    Posts : 54
    Windows 8.1


    I've tried several older drivers, it's strange. Because I've had the exact same setup as before. I'm clueless.
      My System SpecsSystem Spec

  8. #8


    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit


    Is strange, I'm kind of out of ideas too. Just seems something had to have changed on your system. Was the image you restored from taken before or after this started?
      My System SpecsSystem Spec

  9. #9


    Cincinnati
    Posts : 54
    Windows 8.1


    Yes. ... A system image of simply windows 8.1 with updates and drivers and that's all. And the games worked on it before. I've since then done a fresh install and it's all the same. I've literally played these games on the same exact system image I've used before, I'm baffled.
      My System SpecsSystem Spec

  10. #10


    Cincinnati
    Posts : 54
    Windows 8.1


    Just as an update to anyone who's seeing this... None of my games are launching from the 750m... The default is set to it, so when I ran Ultra Street Fighter 4, I assumed it was using it. Got an A in the benchmark with the intel, that's pretty sweet... But now I'm seeing nothing is running on the GeForce. I wonder what the hell I did or could have happened. This stinks of driver issues, but I'm not seeing how it could be as I can re-format and install old drivers all day with the same problem occurring.
      My System SpecsSystem Spec

Can run certain games on intel, but not GeFroce GPU
Related Threads
terran219 wanted a modified Intel Series 4 graphics driver for his Windows 8 Consumer Preview. So, I'm going to just leave this here for those who want it. Enjoy. I've Also uploaded the Intel HD First Generation Driver for windows 8. It's a modified windows 7 driver. If you have one of these...
Hello Guys, Just Want To Ask Which Gaming Company (And Of-course Games) Do You Like More? EA Games OR Rockstar Games Just Vote The One You Like More. ;):D
Solved Intel HD 4000 VS Intel GMA 4500M in Drivers & Hardware
Hey guys I'm planning on buying a new laptop and I know my hardware quite well The new laptop has a Intel HD 4000 graphics and my current graphics are Intel GMA 4500M I know the Intel 4000 HD is much better However I want to know how much of an improvement the Intel HD 4000...
I am completely new to Windows 8 since I installed it today, and when I went into the X-Box games app, I couldn´t see any of my purchased games from GFWL, what gives? It would only seem logical or doesn´t it?
Hello, i recently upgraded my windows 7 to windows 8 professional 64bit and after that my primary display adapter became intel graphics 3000 HD and my other display adapter amd radeon 7470 HD shown code 43 error. I rolled back the intel display adapter, which now is Intel HD Graphics Family...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook