Windows 8 and 8.1 Forums

Can't detect graphics card and SATA device simultaneously?

  1. #1

    Can't detect graphics card and SATA device simultaneously?

    So this is a strange issue that I don't think many people will even quite know what to say...
    First I should say that I'm not that tech savvy, and I'm not much of the forum person, so if I've put this thread in the wrong place then I'm sorry. I'll try and give you as much information about my specs as possible:

    Case: iBuyPower Revolt
    Motherboard: AsRock B75M-ITX
    Processor: Intel i3-3220 @ 3.30 GHz
    Hard Drive: WD Blue 500 GB
    Memory: 2 x 4 GB RAM
    OS: Windows 8.1
    Graphics Card: Geforce GTX 750 Ti
    Power Supplies: 350W and 250W
    And some DVD drive.

    Right, so as you can see, my situation is a little complicated, as I have TWO power supplies. That story's even more complicated, but it doesn't matter so much, all that matters is that those two power supplies are what I have to work with. The 350W supply (which is the supply that I bought later on) is powering everything in my computer EXCEPT the graphics card. Then the 250W power supply (came stock with my computer) is powering the graphics card exclusively. Or at least, that's what's supposed to happen.

    So I bought this graphics card about 6 months ago, and realized that I'd need more power for it. So I ordered a more powerful psu. When I realized the 350W psu didn't have the 6-pin pci-e power connector I needed, I realized that I'd have to use the paperclip method to power my graphics card with the 250W power supply instead. I sat the 250W psu outside my rig, powering the graphics card inside my computer ever since. Until about a day ago, when I updated windows. It just completely crapped out.

    I updated and shut down my computer. The next day when I woke up to turn it on, the display didn't respond. So I switched my VGA display to the onboard graphics, and I saw the words: "Reboot and Select proper Boot device or Insert Boot Media in selected Boot Device and press a key." I freaked out. I reboot my computer, opened up UEFI, and checked things out. This is what I saw:

    Click image for larger version

    So basically, what I saw was that my graphics card was being detected by the motherboard, but my SATA devices (hard drive, DVD drive, etc.) were not, so I was not able to boot Windows.
    So I moved on. I exited UEFI, I saved the changes I had made (I had made no changes) and reboot the computer:

    Click image for larger version

    But after I rebooted, suddenly my SATA devices were being detected again, Windows booted, and the computer went back to normal,EXCEPT for the graphics card. Upon checking my UEFI again, I found that right after clicking "Save Changes and Exit", the computer restarted, and then the graphics card was no longer detected, but all the SATA devices were found:

    Click image for larger version

    I'm very confused, and I would really love to get my graphics card working again. Right now I can use my computer fine, and I can use the display with the onboard graphics like nothing went wrong, it's just that I can't play video games like I used to be able to. Can anyone tell me what's going wrong, what's happening? Give me any explanation as to why on initial boot my graphics card is recognized, but after exiting UEFI it isn't? ANY HELP AT ALL would be greatly appreciated! :)

      My System SpecsSystem Spec

  2. #2


    After staring at my computer for an hour, and trying multiple random internet chats to no avail, I stared at my UEFI settings for a little bit longer and started messing around with some of the settings.

    I found one particular setting that said: "PCIE1 Link Speed," which was set to "Automatic".
    Since I didn't know what this meant, I didn't mess with it the first time I saw it; also, I figured since it was set to Automatic, it would automatically choose the best setting for me.
    But, this was not the case. Because, as my desperation for high-quality game performance continued, I grew more daring and started changing around different settings to see what (if anything) would happen. So I changed the link speed from "Automatic" to "Gen1". There was also "Gen2" and "Gen3", but by luck of the draw, I chose "Gen1." When I saved and exited UEFI, everything worked beautifully just as it always has for the past 6 months.

    I still don't know exactly what this means, or why it changed from the correct setting to "Automatic" but I'm just glad it works now. If anyone may have an explanation for why this works or what this means, I'm all ears, but I am currently able to game again at high quality, and that's all that matters.

    Curiously, the other settings, "Gen2" and "Gen3" don't work; they don't even let the computer recognize the onboard graphics, and I had to reset my CMOS.

    Thanks to all who pondered my question, and if you might know what caused this, I invite you to take a shot at explaining what happened! Thank you all again!
      My System SpecsSystem Spec

Can't detect graphics card and SATA device simultaneously?
Related Threads
I went to plug in a USB external hard drive (via 3.0 slot) and the drive isn't showing up either automatically or on the "This PC" tab. If I go to the search function and type in "D:" I can find the drive and it's accessible. However, I can't figure out for the life of me why it's not just...
First off, I have an HP Pavilion G6 that I purchased in December 2012. Yesterday I decided to get a new HDD to upgrade it and start fresh. It's a 1TB SSD+HDD hybrid by Seagate. It installed without a hitch, and I used my HP recovery CDs to do a factory format of the disk. It finishes, reboots,...
Hello, I have a newly home built MSI AM1i motherboard and have it running fine with Windows 8.1. I am trying to expand the number of SATA ports it has (comes with only 2). The mobo has a mini-PCIe card slot. I purchased a AsMedia 106x, 2-port, mini-PCIe card (had to use a ribbon-cable extender...
I purchased a new GPU Sapphire Dual X R9 270X 2GB DDR5 OC WITH BOOST My Graphics Card fan work fine but when I turn on my pc the monitor does not show anything. I had another graphics card before but needed to replace it so I dont know if this is the trouble. Anyone can help? Thanks in...
Graphics card in Graphic Cards
I have the Dell Inspiron 15R 7520 SE laptop with 2GB AMD Radeon dedicated graphics. As far as I remember I have the AMD Radeon 7730 HD series hardware.Recently while upgrading my catalyst control centre I noticed that my hardware changed to AMD Radeon 7700(as seen in device manager). Can someone...
Hey guys, This is an important post for me as its regarding my Graphics Card (as i use it a lot). I have a Lenovo G400 laptop with intel i5 3230m , Windows 8.1 and Switchable Graphics(Intel HD 4000 and AMD Radeon HD 8750m). Recently this morning i kept my laptop for an download and went away from...
My current graphics card is an internal NVIDIA GeForce 6150SE nForce 430 with 128MB video memory. With 128MB video memory, Ubuntu unity lags as well as MTA and TF2. 720p videos work fine but sometimes they lag too. Overall I experience frequent FPS drops with my current internal graphics card. ...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook