Windows 8 and 8.1 Forums


Black flashing screen when radeon hd 6570 is installed.

  1. #1


    Posts : 9
    Windows 8.1

    Black flashing screen when radeon hd 6570 is installed.


    First off, i would like to say thank you in advance for any help i can get with this issue.
    Second, my computer knowledge is limited so please be understanding of that.

    Now the problem.

    I purchased a Radeon hd 6570 card about 6 months ago. I replaced my nvidia card and and installed the amd drivers and everything worked great.
    Two days ago i discovered that i had forgotten to delete the nvidia drivers from the old card. I went into the control panal and deleted all of the nvidia software, everything still worked until i restarted my computer. Now I get a black flashing screen (black to darker black) with a cursor that flashes on and off every second or two. the only way that my computer works now is by using the on board intel hd graphics chip

    As far as i can tell windows will not even boot up if the 6570 is in the tower.
    if you need anymore info let me know

    please please please help me... I'm going mad without my games!

      My System SpecsSystem Spec

  2. #2


    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit


    Hello and welcome to the forum!

    Do you still have the old Nvidia card to plug back in and see if it works. If it does, then try to remove and uninstall the drivers, power down, then put the AMD card back in and see if it works.
      My System SpecsSystem Spec

  3. #3


    Posts : 9
    Windows 8.1


    No the old card got thrown out. i am thinking what might have happened is;

    when i uninstalled the nvidia drivers my computer reverted back to the onboard card drivers and i am forgetting a step on the re-installation of the amd card but i don't want to uninstall the the onboard card unless i know that is the problem because i do not want to make it so i cant use the monitor at all... does that make sense?
      My System SpecsSystem Spec

  4. #4


    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit


    Ok, wanted to know better what you're dealing with. What does Device Manager show, two graphics adapters? Would help to know make/model of computer to determine motherboard. There may also be a BIOS setting for using the just the onboard graphics or the ability to switch between them.

    Where are you getting the AMD drivers from? Have you tried re-installing them?
      My System SpecsSystem Spec

  5. #5


    Posts : 9
    Windows 8.1


    Tried re installing but might have missed a step computer is an hp pavilion p7-1423w

    HP Support document - HP Support Center

    device manager only shows the intel hd graphics (deleted catalyst control center after last failed attempt)

    i have no idea how to mess with BIOS settings (but i can follow instruction if detailed)

    and i got the drivers from the amd web site.
      My System SpecsSystem Spec

  6. #6


    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit


    If it was working then the BIOS is most likely not the problem. Do you have 8.1 disc to do repair install?
      My System SpecsSystem Spec

  7. #7


    Posts : 9
    Windows 8.1


    if you are talking about the windows disk then now it was pre installed on the PC

    if i understand correctly i am supposed to disable or un install the the intel hd graphics then power down the pc then insert the radeon card then install the drivers with the monitor still connected to the on board card then then power down again then connect the monitor to the radeon card.

    is that correct?

    either way if i disable the intel hd card and its just a matter of the radeon card being fried then will i be stuck with a computer with no form of video output at all?
      My System SpecsSystem Spec

  8. #8


    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit


    That is where the BIOS comes into play. There should be a setting to select the Intel HD graphics as the only video but you will have to check.

    But, no, don't uninstall the Intel HD graphics. I was talking about the Nvidia before if you still had the card.

    You didn't create a recovery USB Flash drive or disc when you first got the PC?

    Do you have a restore point from before you removed the Nvidia drivers?
      My System SpecsSystem Spec

  9. #9


    Posts : 9
    Windows 8.1


    sadly (stupidly?) no, i did not make a recovery backup... is it to late to do so?

    how would i find that section in the bios options?

    what are the odds that it is just a fried vid card?
      My System SpecsSystem Spec

  10. #10


    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit


    Quote Originally Posted by Hottheadliberty View Post
    sadly (stupidly?) no, i did not make a recovery backup... is it to late to do so?

    how would i find that section in the bios options?

    what are the odds that it is just a fried vid card?
    Always possible the card just happened to fry at the same time as you did the driver removal.

    Do you have a restore point from just before removal?
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
Black flashing screen when radeon hd 6570 is installed.
Related Threads
Hi guys, never had to post any questions about windows issues as I could find all my answers on the net. Well, not now. I had to reinstall the whole machine from scratch because old HDD has been playing up. This is what I did: 1. Imaged old (faulty) drive to new one - just because I needed...
Hello, So on my computer, something strange happens when I uninstall UxStyle. It has broken my Windows install once and it has done it again. The first time, I kept on doing system restores to see what was the problem that made that black screen. After trial and error, I narrowed it down to...
i was customizing my desktop with Rainmeter and i wanted to know how to change my toolbar's color because i didnt want the blue, someone said to download Vistaglazz and repatch some files. after doing so my computer restarted and after the initial normal startup and it saying "Please wait..." like...
Hey everyone, I recently started having the black screen with the flashing cursor come up sometimes when I start my PC. I have narrowed it down as being my 3rd HDD (2TB WD) as the culprit, which I only use as media storage. It is not set as a boot device since windows is on my SSD and when I unplug...
Fresh install of 8.1 Preview on HP Core Duo with new MSI Radeon 6570 1GB card. Driver bails on any/all/each browser used. Got about 5 errors in 30 seconds - no BSOD's, just the quick blue artifacting, display freeze, windows error message "Display Driver has stopped responding and has...
I just got a new laptop (Toshiba Satellite C850) that came with Windows 7 pre-installed so I decided to get windows 8 Pro at the discounted price. I downloaded it and so far I love it. However, one thing I noticed was that when I am using some downloaded apps (Shazam, Khan Academy, etc...) these...
flashing black and blue screen in Installation & Setup
OK so i just installed win8 it seemed to be doing OK and then it did the first boot up and the screen was flashing all different colors well it gave me the first run tutorial which didn't seem to be working right i tried to reboot looked good then i got a flashing black and blue screen and now...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook