Windows 8 and 8.1 Forums


Black flashing screen when radeon hd 6570 is installed.

  1. #11


    Posts : 9
    Windows 8.1


    no :-( could you possibly give me a brief rundown of the proper install process for the vid card and i will try that again?

      My System SpecsSystem Spec

  2. #12


    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit


    You say with the card installed you get a blank screen right?
      My System SpecsSystem Spec

  3. #13


    Posts : 9
    Windows 8.1


    correct. as far as i can tell windows does not even boot up i get part of the start up sound but thats it
      My System SpecsSystem Spec

  4. #14


    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit


    With the card installed, can you boot and press F11 or F8 and get to a repair screen? Have to be quick right at power on.
      My System SpecsSystem Spec

  5. #15


    Posts : 9
    Windows 8.1


    just tried, no luck.
      My System SpecsSystem Spec

  6. #16


    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit


    Well, can't rule out the card being bad or maybe the PSU.

    I would get it running without the card and make a USB flash recovery or disc. There should be software on your computer to do it. At least you will have that and then maybe you can get into repair mode with it when the card is installed. Either way you need to create recovery media.
      My System SpecsSystem Spec

  7. #17


    Posts : 9
    Windows 8.1


    ok ill do that i was thinking about just backing everything up and doing a full factory restore anyway.

    thank you for all of your help and time i am grateful.
      My System SpecsSystem Spec

  8. #18


    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit


    You're welcome. Post back if you want some further help.
      My System SpecsSystem Spec

  9. #19


    I had an HP Pavilion 6550a-uk last. Nvidia was screwing it up something rotten. The software did not like the pc at all. I bought an ATI Graphics 6670 or something like that, and I deleted everything to do with Nvidia and switched off, removed and installed ATI, then rebooted with software in DVD drive. Windows began to install drivers and all worked perfectamundo As it was me doing it, it must have been a fluke !!!!!
      My System SpecsSystem Spec

Page 2 of 2 FirstFirst 12
Black flashing screen when radeon hd 6570 is installed.
Related Threads
Hi guys, never had to post any questions about windows issues as I could find all my answers on the net. Well, not now. I had to reinstall the whole machine from scratch because old HDD has been playing up. This is what I did: 1. Imaged old (faulty) drive to new one - just because I needed...
Hello, So on my computer, something strange happens when I uninstall UxStyle. It has broken my Windows install once and it has done it again. The first time, I kept on doing system restores to see what was the problem that made that black screen. After trial and error, I narrowed it down to...
i was customizing my desktop with Rainmeter and i wanted to know how to change my toolbar's color because i didnt want the blue, someone said to download Vistaglazz and repatch some files. after doing so my computer restarted and after the initial normal startup and it saying "Please wait..." like...
Hey everyone, I recently started having the black screen with the flashing cursor come up sometimes when I start my PC. I have narrowed it down as being my 3rd HDD (2TB WD) as the culprit, which I only use as media storage. It is not set as a boot device since windows is on my SSD and when I unplug...
Fresh install of 8.1 Preview on HP Core Duo with new MSI Radeon 6570 1GB card. Driver bails on any/all/each browser used. Got about 5 errors in 30 seconds - no BSOD's, just the quick blue artifacting, display freeze, windows error message "Display Driver has stopped responding and has...
I just got a new laptop (Toshiba Satellite C850) that came with Windows 7 pre-installed so I decided to get windows 8 Pro at the discounted price. I downloaded it and so far I love it. However, one thing I noticed was that when I am using some downloaded apps (Shazam, Khan Academy, etc...) these...
flashing black and blue screen in Installation & Setup
OK so i just installed win8 it seemed to be doing OK and then it did the first boot up and the screen was flashing all different colors well it gave me the first run tutorial which didn't seem to be working right i tried to reboot looked good then i got a flashing black and blue screen and now...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook