Windows 8 and 8.1 Forums


Windows 8.1 upgrade and Nvidia (not installed) problem

  1. #1

    Windows 8.1 upgrade and Nvidia (not installed) problem


    This is a weird one. I had Windows 8 Pro X64 and installed an older Nvidia EVGA e-GeForce 8800GTX PCI-E card. WEI numbers from it were actually worse then the onboard Intel HD Graphics 4600 chip, so I removed the Nvidia card, but did not uninstall the driver.

    I just installed the 8.1 update and had a strange problem. Every time I right clicked on the desktop, I would get the spinning circle for 10-15 seconds then it would go away. I could not get to the desktop context menu.

    Booted to Safe Mode and the problem was gone so I knew it was something starting at boot time. Process of elimination finally got it down to the Nvidia Display Driver Service. Disabled that and all was well. Since I did not have the Nvidia card installed any more, I uninstalled the driver.

    Thought this might help someone else.

      My System SpecsSystem Spec

  2. #2


    Posts : 22,568
    64-bit Windows 10


    Hey Rich,

    The NVIDIA driver was set to run at startup, so it would still run even with the card removed. You'd think it would be smart to not load if it didn't detect the card though, but nope.
      My System SpecsSystem Spec

  3. #3


    Funny it didn't cause a problem in Win 8, just after I updated to 8.1.

    I wonder what other drivers are like that? Run at startup even though the hardware is not present. Any way to tell?
      My System SpecsSystem Spec

  4. #4


    Posts : 22,568
    64-bit Windows 10


    Usually you should be able to check and see what's in your startup programs compared to what you have.

    Startup Items - Manage in Windows 8
      My System SpecsSystem Spec

  5. #5


    In this case that was true, thanks.
      My System SpecsSystem Spec

  6. #6


    Posts : 22,568
    64-bit Windows 10


    Anytime Rich.
      My System SpecsSystem Spec

Windows 8.1 upgrade and Nvidia (not installed) problem
Related Threads
I recently got an GeForce GTX 650 Ti BOOST card a couple weeks back. I think right after I upgraded from windows 8 64-bit to windows 8.1 64-bit. it was running well for awhile. But after some updates, now videos will stutter badly even after reboot. After updating to the latest driver, I've...
At work i have Windows 8 Pro installed from an MSDN ISO, having been waiting for the 8.1 update today i have now just seen a quote on Microsoft's site saying "If you installed Windows 8 using an MSDN ISO, you might be able to install Windows 8.1 using a similar ISO from MSDN" Is there an easy...
nVidia GTX 680 problem in Graphic Cards
I bought a MSI nvidia GTX 680 Twin Frozr III five months ago. About a month ago, I was gaming and my computer would lock up and crash. I shutdown the computer, then turned it on, it worked for a little while when I was gaming then the same problem again. Eventually after restarting/powering...
Please advice me and help me understand at least why is happening this. I use latest nvidia driver, clean install, a s24b350h monitor + gtx680 connected via HDMI cable, native GPU to monitor. So, i select my desired monitor OSD colors, then i want to be a little more lower gamma, and i use...
I installed windows 8 in HDD 1tb Seagate. Then I bought Corsair 240 SSD drive and fresh installed everything there. Now if I boot from SSD drive my Seagate won't show up and I have tried other cables I have 5 hard drives in my system. It shows up in boot menu but won't show up in Disk management...
Trying to install driver for GeForce 9920M GS on my Samsung Q310 using the recommended 64 bit driver from the Nvidia site. Every time I try to install it the computer restarts halfway through the installation. Getting VERY frustrated by this.. Anyone any ideas?? Thanks
Does anybody know how can this be done?
Eight Forums Android App Eight Forums IOS App Follow us on Facebook