Windows 8 and 8.1 Forums


Strange problem with the display in Windows 8.1

  1. #1


    Posts : 6
    Windows 8.1

    Strange problem with the display in Windows 8.1


    I'm using my laptop MSI GE60-2OE. When I first boot into the system, everything looks fine

    Click image for larger version Click image for larger version

    But after using for a while, the display becomes odd. Every item becomes bigger than normal and the entire screen seems bigger than the screen size

    Click image for larger version

    Even worse, in the desktop mode, the taskbar change to strange state and the menu start is disabled

    Click image for larger version

    This problem happens when I set the screen resolution at 1920*1080. Things change back to normal when I reduce the resolution to 1600*900

    Is there anyone encountering the same problem as me? Is there any solution?
    Last edited by tcm2029; 19 Mar 2014 at 11:19.

      My System SpecsSystem Spec

  2. #2


    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit


    Welcome tcm2029. You don't give machine specifics but I assume you have a NVidia discrete graphics plus Intel HD graphics. First question has to be do you have latest drivers installed?
      My System SpecsSystem Spec

  3. #3


    Posts : 6
    Windows 8.1


    Quote Originally Posted by popeye View Post
    Welcome tcm2029. You don't give machine specifics but I assume you have a NVidia discrete graphics plus Intel HD graphics. First question has to be do you have latest drivers installed?
    My laptop specification:
    CPU; Intel Core i7 4800MQ
    GPU: Intel 4600 + Nvidia Geforce 765M
    RAM: 8GB

    I did install the latest driver from Intel but it's no help
      My System SpecsSystem Spec

  4. #4


    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit


    OK, so NVidia driver is updated too? Have you checked for virus? Also run this: SFC /SCANNOW Command - Run in Windows 8
      My System SpecsSystem Spec

  5. #5


    Posts : 6
    Windows 8.1


    Quote Originally Posted by popeye View Post
    OK, so NVidia driver is updated too? Have you checked for virus? Also run this: SFC /SCANNOW Command - Run in Windows 8
    I updated the Nvidia driver and run the virus scan. I also ran the command sfc /scannow. But the problem still persists
      My System SpecsSystem Spec

  6. #6


    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit


    Short of a hardware problem I would uninstall the video drivers, reboot, then install first the Intel driver then the Nvidia.
      My System SpecsSystem Spec

  7. #7


    Posts : 6
    Windows 8.1


    Quote Originally Posted by popeye View Post
    Short of a hardware problem I would uninstall the video drivers, reboot, then install first the Intel driver then the Nvidia.
    I did as what you said but it's useless
      My System SpecsSystem Spec

  8. #8


    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit


    Well, I admit to being stumped on this. Maybe some kind of hardware issue. Could try safe mode, see if it does the same thing. Maybe let Windows install default drivers and see if that makes a difference.

    Maybe someone else will jump in with some ideas.

    Forgot to ask if you upgraded to 8.1 or did it come installed with the laptop? If upgrade, did this just start with the upgrade?
      My System SpecsSystem Spec

  9. #9


    Posts : 6
    Windows 8.1


    I really hope that someone could help me get out of this problem. It's driving me crazy
      My System SpecsSystem Spec

  10. #10


    Posts : 6
    Windows 8.1


    Quote Originally Posted by popeye View Post
    Well, I admit to being stumped on this. Maybe some kind of hardware issue. Could try safe mode, see if it does the same thing. Maybe let Windows install default drivers and see if that makes a difference.

    Maybe someone else will jump in with some ideas.

    Forgot to ask if you upgraded to 8.1 or did it come installed with the laptop? If upgrade, did this just start with the upgrade?
    Hi popeye
    ,

    After I re-install the OS, the problem has disappeared.

    So I guess that some action I did with the OS caused the problem (e.g uninstall Norton Internet security)
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
Strange problem with the display in Windows 8.1
Related Threads
So, I've been running Windows 8 for a year, never had any major problems, till now. When I'm watching any videos, say a 5 minutes video, I watch 2/3 of them, and the Audio suddenly stops working, at all. There's no sound. Volume bars doesn't show any sound generated, too. So, first I...
Hi Guys I was wondering if you might be able to help me out. I used to have a HTPC running windows 7 64 bit and it run perfect. I had a Nivida G-Force 630 Video card in it just to help with Video quality on the big screen. I just did a fresh format and install on Windows 8 64 Bit today....
Hi Guys I was wondering if you might be able to help me out. I used to have a HTPC running windows 7 64 bit and it run perfect. I had a Nivida G-Force 630 Video card in it just to help with Video quality on the big screen. I just did a fresh format and install on Windows 8 64 Bit today....
Solved Windows Services Very Strange Problem in BSOD Crashes and Debugging
Let me start off by saying that all my services are working fine. However, all the Windows services show this in the 'Description' column "Failed to read description. Error code: 2". Also when I click into any of my hard disks 'Properties' dialogue box I cannot run the disk error check. When...
I have had a strange problem. Occasionally after switching to the lock screen(Win + L), I am not able to type the letter "O" or "L". If my password contains either one of these letters, I am not able to log in unless I use the onscreen keyboard. Anyone has encountered similar problem or...
Hello, I run an ideapad z565 with Ati Radeon hd 4200 series gpu, Amd dual-core 2.8ghz phenom 2, 6.00gb ram. I play online Gta San Andreas whiich is pretty simple not very gpu intensive, everytime I've played on win7 it lags in a way thats kind of hard to describe. Its like jitters in the...
In desperate need of some help here, any advice massively appreciated - I installed windows 8 as dual boot alongside windows 7 on my laptop, (dev build) and having played with it for awhile decided to delete off my hard-drive... (Long story short, formatted whole harddrive yet windows 8 error...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook