Windows 8 and 8.1 Forums


external monitor on laptop won't show anything

  1. #1


    Posts : 4
    Win 8.1

    external monitor on laptop won't show anything


    Hi All,

    I bought a new laptop without OS, it's a XMG advanced with i7 4700MQ CPU, an Intel HD grafics 4600 chip and an NVIDIA geforce 765M GTX.
    I installed win 8.1 and updated all drivers. The laptop itself works fine. Now I wanted to connect an external Monitor ( HP w2207h) The laptop recognizes that there is an external Monitor and that it is an HP w2207h and tries to extend the desktop to it, but the monitor itself says that there is no input signal via the HDMI input and it goes to sleepmode.

    When I connect my old Laptop to it, it is no Problem, the monitor shows the extendes Desktop, so the monitor an all cables are OK. (old Laptop : Win7 core 2 duo CPU geforce 9600M GT )

    With the new Laptop I have the same problem, when I try to connect it to my LG TV set via HDMI, the Laptop recognizes the TV and tries to extend the desktop ( I can move the mouse out of the internal display to the TV ) but the TV says there is no input signal.

    I have set the Output to 60 Hz and different resolutions and tried to duplicate the display or only use the external one. Nothing helped.

    I can't force the Laptop to use the Gforce, he decides which one he wants to use.

    A friend bought the same laptop and made the same installation, but when he connects to his external moniotr everything is fine, but I don't know what kind of monitor he has and I have not connected my laptop to his monitor.

    Does anyone have any advice? I'm getting a little desperate.

    Thanks

      My System SpecsSystem Spec

  2. #2


    Posts : 1,883
    7601.18247.x86fre.win7sp1


    Hi,

    Try another cable. (Yes, I have read what you said about it.)

    Update motherboard bios. Check settings there too.

    Have a link to the video driver package you installed?
      My System SpecsSystem Spec

  3. #3


    Posts : 1,360
    Windows 8.1 Enterprise


    I had the same problem as well. It took me hours to find the appropriate solution which was to flush the Secure Boot settings in the BIOS. Unfortunately, not all Motherboards have the same options.
      My System SpecsSystem Spec

  4. #4


    Posts : 4
    Win 8.1


    Thanks for the quick answers.
    Tried a different cable at my TV, didn't work.
    And I didn't find any settings regading displays or grafics in the bios.

    @ectech
    what do you mean by "flush the Secure Boot settings" ? sorry, I am no nativ english speaker and I just dont understand that phrase.
      My System SpecsSystem Spec

  5. #5


    Posts : 1,360
    Windows 8.1 Enterprise


    Could you provide me with the exact model you have?

    I will attempt to get more detailed instructions.
      My System SpecsSystem Spec

  6. #6


    Posts : 4
    Win 8.1


    It is this model ( sorry, didn't find it on the english website)
    mySN.de | SCHENKER XMG | Schenker Technologies - XMG A503 ADVANCED Gaming Notebook 39,6cm (15.6") - Topangebot
    with all drivers according to their download site ( but I did try to update the intel drivers and the geforce drivers after the display didn't work the first time )
    And I installed Win 8.1 .
    Now Nvidia is at drivers version 9.18.13.2733
    and Intel grafic driver is at 10.18.10.3308


    but maybe it would be enought to explain the term "to flush the Secure Boot settings" in a different way, I just dont understand what you mean. update? delete? reset?

    And I looked into the BIOS:
    ME FE Version 9.0.20.1447
    MB Series W35xSTQ_37OST
    BIOS 1.03.02
    KB/EC Firmware Revision 1.03.01

    Maybe that helps .

    Thanks
      My System SpecsSystem Spec

  7. #7


    Posts : 1,883
    7601.18247.x86fre.win7sp1


    Quote Originally Posted by Daggoth View Post
    ( but I did try to update the intel drivers and the geforce drivers after the display didn't work the first time )
    There's your problem right there. Uninstall all video drivers and software.

    Download/install the latest video install package for your model.
      My System SpecsSystem Spec

  8. #8


    Posts : 4
    Win 8.1


    Ok, I tried that too now and it didn't work.
    So now I will pack everything and send it back to the shop.
      My System SpecsSystem Spec

external monitor on laptop won't show anything
Related Threads
Hello I have a laptop with two VGA (intel & nvidia). I can connect external monitor with HDMI (clone mode), only with intel (from intel's menu). is there any way to connect the external monitor with the nvidia card?
I posted a thread for quite some time about our laptop having issues with its own screen. Now it's fixed, I was wondering how we could make our external monitor as primary. The screen doesn't work now but the laptop is usable. We plugged in a VGA adapter to a monitor and it shows up. It starts...
My laptops screen resolution is 1366 x 768 and I plugged in a external monitor via hdmi and it's recommended resolution is 1920 x 1080. Everything on my monitor is too big for the screen and the taskbar is cut off along the bottom and when I go to full screen, stuff across the top is cut off.
External do not show up in Drivers & Hardware
Hi, I have this problem were external hard drive do not show up on my PC. First my I put my friends in and it did not work, then I went out and brought one myself (different brand) and it does not show up. Windows automatically installed the drivers it said it even know what time of external...
Hi there, I have seen some posts on internet, concerning connecting an external CRT Monitor with a Laptop computer. They pretty much said that there might be a blue cable with, and one can use it to connect that monitor with laptop. Now I am confused that mine monitor has two cables; one of...
Hi All, I was running the Windows 8 CP on my PDC laptop up until this weekend when that machine died. I picked up an Asus R500V from Micro Center. Everything seemed to be OK, but when I hook a second monitor up to the laptop nothing happens. The laptop my come out of power save for a second...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook