Windows 8 and 8.1 Forums


Damsel in distress

  1. #1

    Damsel in distress


    Can somebody please help me with this one. When Windows 8 first came out installed it on my Dell Dimension 9200, which has an ATi Radeon 1300/1550 series video card and a Dell 22in monitor. Don't remember any issues, all worked fine. However didn't like Windows 8 and deleted it from my system. Now 8.1 is out thought I would give it a go again. I have now purchased a win 8.1 pro license but when i try to boot from disc to install the OS I get the Windows 8 logo for a minute then "Cannot display this video mode - maximum resolution 1280x1024, 60hz on the screen.

    Have tried various things from the google searches I've done including going into safe mode and uninstalling the graphics drivers and also turning the monitor off for 15 seconds when it displys the message and turning back on again, but nothing works. Have also tried installing from within Windows 7, but get the same message as soon as the PC reboots.

    Is my video card and monitor not compatible with 8.1? I know it's too old for some functions such as snap display but seems strange that it wouldn't be able to run, seen as though Windows 8 ran fine.

    Please help a damsel in distreess,
    Nicki

      My System SpecsSystem Spec

  2. #2


    Southern California
    Posts : 788
    Windows 8.1 Pro with Media Center x64


    Hello Damsel,

    Install this to your windows 7 or 8 OS to find out if you can upgrade to 8.1 - http://go.microsoft.com/fwlink/p/?linkid=261871

    A good read: Update to Windows 8.1 from Windows 8 - Microsoft Windows
      My System SpecsSystem Spec

  3. #3


    Posts : 59
    windows 8.1


    its not your monitor.

    its your video card. no offence its kinda old. and driver(software) support for that card is lacking. surprised it had support for windows 8.0
      My System SpecsSystem Spec

  4. #4


    Posts : 59
    windows 8.1


    ....
      My System SpecsSystem Spec

  5. #5


    Don't remember any issues, all worked fine.
    Unless you specifically checked, you most likely had Windows Basic video drivers -- which is what MS installs when it does not have Win8 specific drivers. You wouldn't have seen any notice of this; instead, it would have simply installed it.

    The AMD driver site mostly doesn't work anymore for legacy cards -- but the best I could find for your card was Catalyst 10.2 -- way too old for Win8.
      My System SpecsSystem Spec

Damsel in distress
Related Threads
Can somebody please help me with this one. When Windows 8 first came out installed it on my Dell Dimension 9200, which has an ATi Radeon 1300/1550 series video card and a Dell 22in monitor. Don't remember any issues, all worked fine. However didn't like Windows 8 and deleted it from my system. Now...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook