Windows 8 and 8.1 Forums


GPU Fan too loud under Windows 8

  1. #1

    GPU Fan too loud under Windows 8


    I just bought an Nvidia 620 card today. I run both Linux and Windows on my system. When I go to Linux, everything work fine. But in Windows 8, the GPU fan start to scream. Its too noisy! I even updated the drivers. What might be the problem?

      My System SpecsSystem Spec

  2. #2


    India
    Posts : 1,034
    Windows 7 x64/ Windows 8.1 x64


    Hi THpubs, Welcome.

    Issue might be with auto fan speed. Linux does not use a lot of graphics as compared to Windows 8. So, as soon as you switch to Win, to keep the temps down of the card the fans speed up. You can change that to manual and set the fan speed same for both Linux and Win.

    You will need to download and install Nvidia System tools to be able to that or you could use MSI Afterburner.
      My System SpecsSystem Spec

  3. #3


    Quote Originally Posted by archer View Post
    Hi THpubs, Welcome.

    Issue might be with auto fan speed. Linux does not use a lot of graphics as compared to Windows 8. So, as soon as you switch to Win, to keep the temps down of the card the fans speed up. You can change that to manual and set the fan speed same for both Linux and Win.

    You will need to download and install Nvidia System tools to be able to that or you could use MSI Afterburner.
    I just installed the proper drivers for Ubuntu and the fan started to scream like in Windows If I set the speed in Windows using afterburner, will it effect Linux?
      My System SpecsSystem Spec

  4. #4


    India
    Posts : 1,034
    Windows 7 x64/ Windows 8.1 x64


    It will not. As they both are different OS. How many pins connector are you using to power up the GPU?
    4 pin means the motherboard can read the speed of the fan and control it. (3 pin just lets you read the speed and 2 pin just makes the fan spin)
      My System SpecsSystem Spec

  5. #5


    I would check to see if the GPU is correctly and fully seated in the right PCIe slot. Then re-check the cable connections of the GPU from the PSU to make sure they are fully seated.
      My System SpecsSystem Spec

  6. #6


    Quote Originally Posted by bassfisher6522 View Post
    I would check to see if the GPU is correctly and fully seated in the right PCIe slot. Then re-check the cable connections of the GPU from the PSU to make sure they are fully seated.

    Checked and its all fine
      My System SpecsSystem Spec

  7. #7


    India
    Posts : 1,034
    Windows 7 x64/ Windows 8.1 x64


    Did you install Nvidia system tool or MSI afterburner and set the fan speed in it? How many pins are you using to connect the card? You can use FanCon to control the fan speed in Linux..
      My System SpecsSystem Spec

  8. #8


    Quote Originally Posted by archer View Post
    Did you install Nvidia system tool or MSI afterburner and set the fan speed in it? How many pins are you using to connect the card? You can use FanCon to control the fan speed in Linux..

    Yes... also tried the EVGA software... both of them won't let me reduce the fan speed below 65!
      My System SpecsSystem Spec

  9. #9


    India
    Posts : 1,034
    Windows 7 x64/ Windows 8.1 x64


    Quote Originally Posted by archer View Post
    It will not. As they both are different OS. How many pins connector are you using to power up the GPU?
    4 pin means the motherboard can read the speed of the fan and control it. (3 pin just lets you read the speed and 2 pin just makes the fan spin)
    Can you let me know this? Fan speed control depends on how many pins are used to connect.
      My System SpecsSystem Spec

  10. #10


    Quote Originally Posted by archer View Post
    Quote Originally Posted by archer View Post
    It will not. As they both are different OS. How many pins connector are you using to power up the GPU?
    4 pin means the motherboard can read the speed of the fan and control it. (3 pin just lets you read the speed and 2 pin just makes the fan spin)
    Can you let me know this? Fan speed control depends on how many pins are used to connect.

    There are two pins connecting it to the card's body. The card doesn't have extra power connectors. Its PCI E 2
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
GPU Fan too loud under Windows 8
Related Threads
Since installing ssd drive I now have a loud fan noise, when I have checked speccy it is running at 59 degrees C so it is running hotter also. why is this and how do I fix it.
Hello I have this problem in foxit reader and adobe reader for all PDF files Then this problem is related to windows TTS. I'm using latest version of foxit reader and adobe reader and updated windows! This problem did not exist previously, I do not know why it was broken. I do not get any...
Hi there, When I use headphones with my Surface Pro (Win 8) I cant hear the voices in my videos - the background music/sound effects are just too loud. How can I fix this? I have tried using the Win 8 Video player as well as VLC Player and I still get the same issue. I have tried the...
Since yesterday, my graphics card has been starting to go to black screens and emit loud fan noises. I suspect it may be due to a recent update regarding something about WDDM 1.3 since that too was installed yesterday. I have managed to play The Sims 3 at max settings today without the problem,...
Hi everyone, Recently I made a post on the BSOD subforum in regards to recent BSODs I've been having. After investigation, it seems that it was my Corsair Vengeance 1500 headset drivers. I've since uninstalled the drivers and I've experience no more problems. I hope they make drivers that work...
Eight Forums, So I open Zune. I start a song. It starts off at normal volume, at the quieter beginning part, but then it gets REALLY soft when the more louder part of the song plays. It never did that before I did a clean install of Windows 8. Do you know what's causing that and how to...
Hi everyone, I hope i'm posting in the right place. I joined this forum because i need some help. Less then a week ago i purchased a new sony laptop model number sve151a11w. My problem is almost every time i play a game (i only have dawn of war 2 + expansions and minecraft at the moment) after a...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook