Windows 8 and 8.1 Forums


Problems upon removal of Nvidia drivers.

  1. #1


    Posts : 2
    Windows 8.1

    Problems upon removal of Nvidia drivers.


    I bought myself a Radeon HD 7770 a few months back to replace an old GeForce 9600GT. A few weeks after installing the AMD card, I was going through my programs cleaning out old files and decided to remove all the Nvidia stuff. I removed the drivers and stuff and upon reboot, my computer would no longer boot to the desktop. I ended up having to use system restore to get the computer working again...
    Fast forward to yesterday. I upgraded from Windows 8 Pro with Media Center to Windows 8.1 Pro with Media Center, and I started experiencing the same problem listed here: "Win 8.1 desktop right click takes 15 seconds!" I tried the same solution that was found and it did not work for me. My guess is it had something to do with the Nvidia driver software still being installed on my computer. So I again attempted to remove the drivers. At this point I couldn't even remove the Nvidia software as nothing happened when I pressed the uninstall button. I ended up having to reinsert the Nvidia card, and reinstall the drivers, in order to uninstall the drivers. After I restarted and reinstalled the AMD card, the computer, like before would no longer boot to the desktop. All I would get was a mouse pointer that would appear and disappear every couple of seconds and a Number lock button on the keyboard that would be turning on and off at the same interval. If I reinsert the Nvidia card the problem goes away, but obviously I don't want to keep the old card in my computer.

    My question is: Why would the computer boot with the Nvidia card when the Nvidia drivers are uninstalled and yet not boot with the AMD card when the AMD drivers ARE installed?

      My System SpecsSystem Spec

  2. #2


    Posts : 2
    Windows 8.1


    I find it funny that right after I post this I manage to figure it out and fix the issue that I have been working on for hours. My hypothesis is that when I removed the Nvidia drivers, it removed critical files required for the AMD drivers. I ended up booting with the Geforce in my PCIe 16x slot and put the AMD in to my PCIe 8x slot, where it then booted successfully. Once in windows, I reinstalled the AMD drivers restarted and put AMD card back into the 16x slot and problem solved. Now time to fix those pesky DLL errors on boot, but that is for another thread if I don't manage to figure it out.
      My System SpecsSystem Spec

Problems upon removal of Nvidia drivers.
Related Threads
Hi, Need Windows 8.1 Enterprise edition drivers for this VGA Card Link Amazon.com: NVIDIA Geforce FX5500 256 MB AGP 8x Video Graphics Card DVI/VGA/TVOUT: Computers & Accessories
Fresh install of Win 8.1 Pro, all patched and everything else is great but I cannot install the NVIDIA drivers or the GeForce Experience software for the GeForce GTX-760 video card. This is what I get... Can anyone help? Thanks!
Hello,I Have Problem With Nvidia Drivers on Windows 8 Pro When I Reboot Its Only Black Screen. Any Help?, ITMarkus Motherboard is Asus M2N-MX
Hi, I have tried a lot of things but I cant solve it. It only work with igpu, with I connect to 670 (without drivers or latest drivers). Black screen after Windows Blue logo... What can I do?
Hey Guys. I have just installed windows 8 to give it a try and I have a problem. I can not find the drivers for my video card and my screen res. is at 1024x768. My display is saying its a Generic Non-PnP Monitor and im sure thats cuz there are no video card drivers and its using the basic...
Hello, I like Windows 8, and my experience has been good so far. Yesterday I've installed Windows 8 and it had been hanging at 'Installing Drivers... 10%'. So I slammed my GeForce 8600 in my PC, and surprisingly it worked. However, I need my GeForce 6600 because another OS needs it...
I had these exact drivers working on win 7. They wont work on windows 8. It passes the checking system compatibility but fails during installation. While it installs the screen flashes black and then it says, "NVIDIA Installer failed". I have windows 8 64bit sony vaio vgr ar870 8600m Gt
Eight Forums Android App Eight Forums IOS App Follow us on Facebook