Windows 8 and 8.1 Forums


My Video Card fails to operate under UEFI.

  1. #11


    Posts : 12
    Windows 8 64-bit Home Edition


    Also, just to make sure I have left no stone unturned, I will ask: If i installed Windows 8 with the *boot mode* on Legacy: Then I would indeed have to reinstall, correct?

      My System SpecsSystem Spec

  2. #12


    Posts : 22,582
    64-bit Windows 10


    That would be correct if you wanted to install it using UEFI instead.

    UEFI (Unified Extensible Firmware Interface) - Install Windows 8 with
      My System SpecsSystem Spec

  3. #13


    Posts : 12
    Windows 8 64-bit Home Edition


    Quote Originally Posted by Brink View Post
    That would be correct if you wanted to install it using UEFI instead.

    UEFI (Unified Extensible Firmware Interface) - Install Windows 8 with
    What I meant was: I'd have to install Windows 8 under UEFI boot mode *right now* in order to eventually disable Legacy OPROM in the future.

    I could not do the same with the boot mode set as "Legacy." That would force me to keep "Legacy OPROM" enabled....

    Does that make sense?
    Last edited by SimplyShane; 28 Jan 2013 at 20:56.
      My System SpecsSystem Spec

  4. #14


    Posts : 22,582
    64-bit Windows 10


    Personally, I would just wait until you get a graphics card that supports UEFI GOP first before installing Windows 8 under UEFI mode unless you just wanted to. I don't think there's going to be any available soon.

    I suppose that depends on if the motherboard supports have it disabled while in "Legacy" boot mode, but I wouldn't think so.
      My System SpecsSystem Spec

Page 2 of 2 FirstFirst 12
My Video Card fails to operate under UEFI.
Related Threads
I got a new video card, namely the Sapphire Vapor-X R9 280X to replace my old (broken) video card, namely the Sapphire Radeon HD 7970 Boost. The problem is that I get no video signal when linking my new video card. The vga-led on motherboard turns on red (normally never) I thought my...
Okay, my graphics card, Nvidia GT650 is not ready for UEFI installation and I have no way to flash the bios. If I boot using legacy bios, install the card, then can I flash the card BIOS and then return to UEFI booting? The card is currently not installed and I have no other system to use to...
I just bought a new 27" monitor, should be delivered Monday. On my desktop system I currently have a 24" monitor which I'll pair with my new monitor. I have an nVidia GeForce 8600 GT video card with 512 MB memory, one DVI port and one VGA (d-sub) port. I have a Gigabyte GA-Z77X-UD3H motherboard...
I added Media Center feature and tried to play VOB video. I double clicked the file and the Windows Media Player said there is no video in the library. I added it to the library but still no avail. What could be wrong with this W8 or add-on WMC?
Hi, I'm trying to update my AMD HD 4800 series graphic card, but each time I do it I get a fail. I get the error messages saved in a note pad 22847 would anyone be able to have a look and help me please?? :)
On the gaming PC that I'm fixing for my son's friend, the WEI fails to complete, and fails the "video" portion... could the old 9800 GTX 512MB video card be failing? I've installed the newest nVidia drivers and all seems to running well, but I can't use WEI to get a baseline before I start tweaking...
Hi, I am tring to do a clean install of Win 8 in UEFI mode and can't figure how to get a graphic card to work. Some advise turning off secure boot ( How?), but i can't even get started. When I disable CSM in my Asus M5A97 motherboard, my screen goes blank. I had an Nvidia 7300SE card which needs an...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook